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Getting Started

Flash is the foremost authoring software for creating scalable, interactive 
animation for the web. Whether you are creating animated logos, web site 
navigation controls, long-form animations, or entire Flash web sites, you’ll find 
the power and flexibility of Flash an ideal medium for your own creativity. 

System requirements for Flash authoring
The following hardware and software is required to run the Flash:

 þ For Microsoft Windows™: An Intel Pentium® 133 or equivalent processor 
running Windows 95, 98, or NT version 4.0 or later; 16 MB of RAM 
(Windows 95 or 98; 24 MB recommended) or 24 MB of RAM (Windows 
NT; 32 MB recommend) plus 20 MB of available disk space; a color monitor; 
and a CD-ROM drive.

 þ For the Macintosh®: A Power Macintosh running System 7.5 or later; 
32 MB of RAM plus 20 MB of available disk space; a color monitor; and 
a CD-ROM drive.
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System requirements for the Flash Player
To play Flash Player movies in a browser requires the following hardware 
and software:

 þ Microsoft Windows 95, NT 3.5.1 or later; or a 68K Macintosh computer 
(PowerPC recommended) with System 7.1 or later. 

 þ Netscape plugin that works with Netscape 2 or later (Windows and 
Macintosh).

 þ If running ActiveX controls, Microsoft Internet Explorer 3 or later (Windows 
95 or later, Windows NT) is required.

 þ If running Flash Player Java Edition, a Java-enabled browser is required.

Installing Flash
Follow these steps to install Flash on either a Windows or Macintosh computer.

To install Flash on a Windows or a Macintosh computer:

1 Insert the Flash 4 CD into the computer’s CD-ROM drive.

2 Choose from the following options:

 þ In Windows, choose Start > Run. Click Browse and choose the file Setup.exe 
on the Flash 4 CD. Click OK in the Run dialog box to begin the installation.

 þ On the Macintosh, double-click the Flash 4 Installer icon.

3 Follow the on-screen instructions.

4 If prompted, restart your computer.

What’s new in Flash 4
Flash 4 offers exciting new features for creating immersive, lush interactive web 
sites. New playback features include MP3 streaming audio, text fields for placing 
user-editable text in a movie, and enhancements to Flash actions that let you 
create sophisticated games, forms, and surveys. New authoring features include a 
streamlined publishing process, a redesigned Library window, a variety of new 
inspectors, and an enhanced graphical interface. 

MP3 streaming audio

Export both streaming and event audio with MP3 compression to create 
compelling movie sound tracks while maintaining files small enough for efficient, 
low-bandwidth delivery. See “Exporting movies with sound” on page 219.
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Editable text fields

Place text fields in a movie to let your audience edit text while a movie plays. Use 
text fields to create password entry fields, registration forms, surveys, and other 
forms for collecting data from users. See “Setting text field properties” on 
page 118.

Additional, sophisticated actions

The addition of sophisticated actions that can evaluate events and information 
while a movie is playing, and change depending on the result, let you create fully-
functional interface elements such as slider controls, radio buttons, application 
menus, and more. Use the new actions to duplicate much of the functionality that 
can be performed with JavaScript and other scripting languages to create movies 
that maintain cross-browser, cross-platform compatibility so viewers have the 
same experience regardless of their configuration. See “Creating interactive movies 
overview” on page 173.

Improved Library window

The redesigned Library window now makes it much easier to manage hundreds of 
assets for large projects. Create folders to organize and store assets. In addition to 
the name of a symbol, Library window columns now display symbol type, the 
number of times the item appears in the movie, and the last modification date. 
Sort library items by any of the columns. See “Using the Library window” on 
page 65.

Streamlined web publishing

The Publish command is a one-step process for exporting a movie in multiple 
formats, as well as the supporting HTML file. Customize the individual 
properties of each format prior to publishing. You can also create your own 
external template file that instructs Flash how to write out specific HTML syntax. 
For more information, see “Publishing and exporting overview” on page 223.
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Layers and animation enhancements

With the redesigned Timeline, smart motion guides, and updated layer controls, 
Flash 4 reduces the time it takes to create web animation:

 þ The Create Motion Tween command lets you create a motion tween in one 
step. Motion-tweened objects automatically snap to a motion path drawn on a 
motion guide layer. You can also link and unlink multiple layers to a motion 
guide or mask layers. See “Tweening instances, groups, and type” on page 159.

 þ Updated layer controls let you easily hide, display, lock, and unlock layers. 
Outline colors mode lets you easily distinguish the objects on a layer from 
other objects in the movie. See “Viewing layers” on page 135.

 þ Drag the Timeline to its own window or dock it to any side of the application 
window. See “Using the Timeline” on page 59

Color palettes

Import and export custom color palettes to ensure colors are used consistently 
across your web site. See “Using color palettes” on page 89.

Enhanced user interface

Improve your productivity with the following interface enhancements:

 þ Object and Transform inspectors let you view and manipulate the position, 
scale, rotation, and skew of selected objects. See the appropriate section in 
Chapter 4, “Working with Objects.”

 þ The Scene inspector lets you manage and edit multiple scenes in a Flash 
movie. See “Using scenes” on page 63.

 þ Circle and rectangle tools let you easily create these simple objects. A round 
rectangle radius modifier lets you round the corners of rectangles. See 
“Drawing straight lines, ovals, and rectangles” on page 80. 

 þ Edit symbols in a separate window or in relation to other artwork on screen. 
See “Editing symbols” on page 148. 
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Guide to instructional media
The Flash 4 package contains a variety of media to help you learn the program 
quickly and become proficient in creating your own Flash Player movies—
including online help that appears in your web browser, interactive lessons, a 
tutorial, a printed book, and a regularly updated web site.

Flash lessons and tutorial

If you are new to Flash, or if you used only a limited set of its features, start with 
the lessons. The lessons introduce you to the main features of Flash, letting you 
practice on isolated examples. The tutorial introduces the workflow in Flash by 
showing you how to create a basic movie. The tutorial assumes an understanding 
of the topics covered in the lessons.

To start with the lessons, choose Help > Lessons > 1 Introduction. 

Using Flash

Using Flash contains instructions and information for using all Flash tools and 
commands. It is provided as both online help and a printed book. The online help 
contains a variety of Flash Player movies demonstrating effects and features. 

For the best experience when using Flash Help, Macromedia strongly 
recommends that you use Netscape Navigator 4.0 or higher or Microsoft Internet 
Explorer 4.0 or higher on Windows, and Netscape Navigator 4.0 or higher on the 
Macintosh. If you use a 3.0 browser, all the content of the movies and the Flash 
Help is still accessible, but some features (such as Search) will not work. Running 
Flash and Flash Help simultaneously on a Macintosh requires up to 32 MB of 
memory, depending on your browser’s memory needs.
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To use the Flash Help:

1 Choose Help > Flash Help Topics. 

2 Navigate the help topics using any of these features:

 þ Contents organizes information by subject. Click top-level entries to 
view subtopics. 

 þ Index organizes information like a traditional printed index. Click a term to 
jump to a related topic.

 þ Search finds find any character string in all topic text. Search requires a 4.0 
browser with Java enabled. To search for a phrase, simply the type the phrase 
into the text entry box.

To search for files that contain two keywords (for example, layers and style), 
separate each word with a plus (+) sign.

 þ Previous and Next buttons let you move through the topics within a section. 

 þ Flash icon links you the Flash Developers Center web site. 
Introduction14



    
Flash Developers Center

The Flash Developers Center web site is updated regularly with the latest 
information on Flash, plus advice from expert users, advanced topics, examples, 
tips, and updates. Check the web site often for the latest news on Flash and how 
to get the most out of the program at www.macromedia.com/support/flash/.
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Tutorial

Tutorial overview
In this tutorial you will build on the basic skills you learned in the lessons and 
create a more complex piece of work. You’ll create a home page for a refrigerator 
magnet company that features animated symbols, animated buttons, and a way to 
store email addresses. 

Understanding and taking advantage of the power of symbols is crucial to learning 
Flash. This tutorial emphasizes more advanced uses of symbols. You’ll learn 
how to:

 þ Create animated movie clip symbols and button symbols

 þ Use editable text fields in symbols

 þ Assemble a movie 

 þ Attach actions to buttons that control other content

 þ Publish a movie 

You’ll also learn some animation tricks you might find useful in future projects.
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Before you begin 

This tutorial requires basic Flash skills that are covered by the seven lessons 
included in Flash. The lessons are available by choosing Help > Lessons. Be sure to 
complete these lessons before starting this tutorial. 

 þ Lesson 2, Drawing

 þ Lesson 3, Symbols

 þ Lesson 4, Layers

 þ Lesson 5, Text

 þ Lesson 6, Buttons

 þ Lesson 7, Sound

 þ Lesson 8, Animation
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Preview the completed movie

Begin by taking a look at the finished movie to become familiar with what you’ll 
be working towards. 

1 In Flash, choose File > Open. Navigate to the Flash application folder, then 
open the Tutorial folder and select Tutorial Finish.fla.

Do not edit this movie, since it is already complete. You will edit an alternate 
version during the tutorial.

2 To run the movie, choose Control > Test Movie.

The movie opens with an animation that moves a photograph to the 
refrigerator and secures it with a crown magnet. 

3 Pass the pointer over the buttons and notice that they animate and display the 
title of the content you’ll see when you click them. Click the buttons to see 
additional content. 

4 When you finish exploring the movie, close the movie window and then close 
the Tutorial Finish.fla file. 

You can refer to the Tutorial Finish.fla file throughout the tutorial to make sure 
you’ve done the work correctly, or get back on track if you’re lost. 
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Open the starting file
1 In Flash, Choose File > Open, and then open the Tutorial Start.fla file. 

2 Choose File > Save As and save the movie with a new file name so that you do 
not alter the Tutorial Start.fla file.

If you, or another user, want to use the tutorial again, it’s important to keep 
the original Tutorial Start.fla file. 

3 Tutorial Start should open with the Library window displayed. If the Library 
window isn’t open, choose Window > Library to open it. 

Tutorial Start has no content in the main Timeline, but the Library window 
contains basic artwork you could have created with the skills you acquired 
doing the Flash lessons. 

Timeline

Library window
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Define the movie properties

It’s a good idea to start building a movie from the bottom up, so begin with its size 
and background.

1 Choose Modify > Movie. 

2 In the Movie Properties dialog box, set the movie’s dimensions to 
550 pixels by 400 pixels.

3 For Background, select an orange color.

4 Click OK to apply the properties. 

The Stage is now orange.

Create an animated symbol
Lesson 3, “Symbols,” taught you how to work with graphic symbols and 
instances. Symbols can also include instances of other symbols and animation. In 
this section, you create a symbol that shows the photograph moving to the 
refrigerator door at the beginning of the movie. 

You begin by creating a movie clip symbol and then adding other symbols to it. A 
movie clip symbol is like a self-contained movie that you can place in a host movie 
as if it were a single object. It can include animation and interactivity just like a 
regular movie. 

Note: While working in Flash, it’s often useful to undo your actions. Flash can undo several 
of your recent actions. Choose Edit > Undo (or press Control+Z (Windows) or 
Command+Z (Macintosh)) repeatedly to step backwards through your recent actions. 
Choose Edit > Redo (or press Control+Y (Windows) or Command+Y (Macintosh)) to step 
forward through actions you’ve undone.

Movie dimensions 

Background color 
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Create a movie clip symbol

1 Choose Insert > New Symbol.

2 In the Symbol Properties dialog box, enter the name 
“INTRO - ANIMATION.” 

3 Select Movie Clip as the behavior and then click OK. 

Flash switches to symbol-editing mode. Symbol-editing mode looks almost 
exactly the same as movie-editing mode. Notice that the name of the symbol 
you’re editing appears in the top left corner above the Timeline. The name also 
now appears in the Library window. 

4 In the Timeline, double-click the existing layer name and enter “Photo.” 

Symbol name
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5 Drag an instance of the INTRO - PHOTO symbol from the Library window 
and place it over the registration point in the center of the Stage as shown in 
the picture that follows. 

This adds an instance of the INTRO - PHOTO symbol to the 
INTRO - ANIMATION symbol. 

Use the arrow keys to move a symbol one pixel at a time. Press Shift and use 
the arrow keys to move ten pixels at a time. 

6 In the Timeline, select frame 20 in the Photo layer and choose 
Insert > Keyframe. 

Because you want the animation to begin off the Stage, you must define a new 
position for INTRO - PHOTO in the first frame.

7 Select the keyframe in frame 1.

8 Move the instance of INTRO - PHOTO about two inches to the right of the 
registration point. 

The exact location is not important.

Now that you’ve positioned the image for the first frame, you can create a 
motion tween to make it move to the position of the keyframe in frame 20.

Registration point 
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9 Making sure the keyframe in frame 1 is still selected, choose 
Insert > Create Motion Tween. 

The Timeline should now look like this:

10 Choose Window > Controller to open the Controller and then rewind and 
play the animation to see what you’ve done so far. 

The photograph should slide in from the right and stop on the symbol’s 
registration point.

Tween rotation and a fade

Now modify the motion tween to make the photograph fade in and rotate as it 
moves. You do this by specifying an alpha (transparency) setting of 0 in the 
keyframe where the photograph first appears, and by setting the number of 
rotations in the Tweening Properties dialog box. 

1 Select frame 1 in the Photo layer.

2 On the Stage, select the instance of INTRO - PHOTO and choose 
Modify > Instance. 

3 Click the Color Effect tab in the Instance Properties dialog box and choose 
Alpha from the Color Effect pop-up menu. 

4 Move the Alpha slider to 0 and click OK.

The photo becomes completely transparent (invisible). Only the selected 
border is visible.

5 Make sure that the keyframe in frame 1 in the Photo layer is still selected, 
choose Modify > Frame, and then click the Tweening tab.
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6 Choose Clockwise from the Rotate pop-up menu, enter 1 in the Times box, 
and then click OK.

7 Use the Controller to rewind and play the animation.

As the motion tween moves the symbol instance, it also rotates the image and 
changes the alpha settings between 0 and 100 to make the photograph fade in.

Next, add the crown magnet to the top of the photograph.

8 Select the keyframe in frame 20 in the Photo layer, and then drag an instance 
of the INTRO - CROWN symbol from the Library onto the photograph. 

9 Rewind and play the animation to make sure it works correctly. 
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Add a frame action to stop the animation

Although the animation you’ve created appears to stop at the last frame while 
you’re in symbol editing mode, it will work differently when placed in the movie 
Timeline. Movie clip symbols loop as long as a movie plays unless you make the 
movie clips stop. 

Add a frame action to make this animation stop when it reaches the last frame.

1 Select the Photo layer in the Timeline, and then choose Insert > Layer.

2 Double-click the layer name, and then enter “Actions.”

3 Insert a keyframe in frame 20 in the Actions layer, and then choose 
Modify > Frame. 

4 Click the Actions tab in the Frame Properties dialog box, click + (plus), and 
then choose Stop from the Action pop-up menu. Click OK.

You’ve now completed the INTRO - ANIMATION symbol. 
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Create animated buttons
Lesson 6, “Buttons,” taught you how to create a very simple button. In this 
section, you create a more complex button that animates when the mouse rolls 
over it and displays label text with transparency. To create an animated button, 
you place an animated movie clip symbol in one of the button’s frames. Begin by 
creating the animation.

1 Double-click the icon for the BUTTON - HOME symbol in the Library 
window to open the symbol for editing. 

Be sure to click the symbol icon, not the symbol name, otherwise you just edit 
the symbol name. 

BUTTON - HOME is a partially completed button included to save you a 
few steps.

2 Choose View > Show Frame to center the button in the window. Click the 
magnifier tool in the toolbox to enlarge the button if necessary. 

3 In the Timeline, name the first layer “Button.” 

4 Insert a keyframe in the Over frame in the Button layer. 

5 Making sure the keyframe in the Over frame is still selected, click anywhere on 
the Stage with arrow tool to deselect the button image. 

Symbol icon
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6 Drag an instance of the BUTTON - CROSS symbol from the Library to the 
registration point in the BUTTON - HOME symbol. 

BUTTON - CROSS is a movie clip symbol that already contains an 
animation of a rotating cross. The instance of BUTTON - CROSS should 
line up exactly with the cross underneath. You can use the arrow keys to move 
the selection one pixel at a time.

Add text transparency to the button

First, add the transparent text layer to the button.

1 In the Timeline, insert a new layer and name it “Text Transparency.” 

2 Select the Text Transparency layer in the Timeline and drag it below the 
Button layer in the Timeline. 

Arranging layers this way makes the content of the Text Transparency layer 
appear behind the content of the Button layer.

3 Create a keyframe in the Over frame in the Text Transparency layer.
Chapter 128



4 Select the BUTTON - BACKGROUND symbol in the Library, and then 
drag it so that its left side is on the registration point in the button.

Now, make the button background blend nicely with any background by applying 
an alpha setting to it. 

1 With BUTTON - BACKGROUND still selected in the work area, choose 
Modify > Instance.

2 Click the Color Effect tab in the Instance Properties dialog box, and choose 
Alpha from the Color Effect pop-up menu. 

3 Enter 50 as the Alpha value, and click OK.

4 Making sure the Over keyframe in the Text Transparency layer is still selected, 
click the text tool. 

5 Use the text tool modifiers to choose Arial (Windows) or Helvetica 
(Macintosh), 18 points, bold, italic text.

6 Enter the word “Home” over the BUTTON - BACKGROUND symbol. 

You don’t need to change the content of any other frames in the button.
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Duplicate the animated button

The button you just created displays “Home” when you roll over it. Now, you 
need to create another button that displays “Contact” when you roll over it. To 
save time, you’ll duplicate the BUTTON - HOME and then change its text.

1 In the Library, click the BUTTON - HOME symbol, and then choose 
Duplicate from the Library Options menu. 

2 Name the duplicate symbol “BUTTON - CONTACT,” and click OK.

3 Double-click the new BUTTON - CONTACT symbol in the Library 
to edit it. 

If necessary, Choose View > Show Frame to center the button in the window 
and use the magnifier tool to enlarge the button. 
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4 Select the Over frame in the Text Transparency layer and use the text tool and 
modifiers to edit the text to read “Contact.”

You won’t be able to see the buttons animating yet because movie clip 
animation does not work in the authoring environment. 

If you want to see the buttons work, choose Edit > Edit Movie, drag an 
instance of BUTTON - HOME or BUTTON - CONTACT onto the Stage, 
and then choose Control > Test Movie. After the movie plays, close the movie 
window and delete the instance of the button from the Stage. 
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Use editable text fields
In Flash, you can place interactive controls and editable text fields inside 
symbols. In this section, you’ll add basic data entry capabilities to the 
TEXT - CONTACT symbol. 

1 Double-click the icon for the TEXT - CONTACT symbol in the Library to 
open the symbol for editing.

2 Create a new layer in the Timeline and name it “Data Entry.”

3 Select the first frame in the Data Entry layer in the Timeline. 

4 With the first frame in the Data Entry layer selected, click the text tool and the 
Text Field modifier.

5 Draw editable text fields for Name, Email, and Comment. 

Use the arrow tool to adjust the size and position of the fields. It’s not 
important at this point to get them perfect. Notice that the square resize 
handle on an editable text field is on the field’s lower right corner. 

6 Using the arrow tool, select the Name text field and choose 
Modify > Text Field to open the Text Field Properties dialog box.

7 Enter “Name” in the Variable box and click OK. 

Flash assigns the content entered in the editable text field to the variable whose 
name you enter here. You can then use the value of the variable in actions.

8 Repeat steps 6 and 7 for the Email text field; name the variable “Email.”

9 Repeat steps 6 and 7 again for the Comment text field; name the variable 
“Comment”, and click the Multiline and Word Wrap options before 
clicking OK.
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Add the Send button

Now add the Send button to the TEXT - CONTACT symbol.

1 Make sure that the first frame of the Data Entry layer is still selected, and then 
drag an instance of the BUTTON - SEND symbol from the Library window 
and place it just below the editable fields.

2 Double-click the instance of the BUTTON - SEND symbol to open the 
Instance Properties dialog box. 

3 On the Actions tab, click + (plus) and choose Get URL from the 
pop-up menu.

4 Type a URL in the box on the right, choose Send Using GET from the 
Variables pop-up menu, and then click OK.

This sends the contents of all variables (the text entered in the editable fields) 
to the URL you specify. In a real application, you would need to create a valid 
CGI script at the URL location to receive the information, but for learning 
purposes you can enter any URL and it won’t matter if there is no CGI script.

At this point, you are done creating symbols for the movie. You’re now ready 
to use the symbols you’ve created in the main movie.
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Assemble the movie
Using the symbols you’ve created so far, assembling the movie’s content is easy. As 
you do this, you will learn more about using layers to organize the content of 
a movie.

1 Choose Edit > Edit Movie.

2 Name the first layer in the Timeline “Fridge.”

3 Drag an instance of the BACKGROUND - FRIDGE symbol from the 
Library window onto the Stage. 

4 In the Timeline, insert a new layer above the Fridge layer and name it “Green 
Background.”

5 Make sure the Green Background layer is selected, and then drag an instance 
of the BACKGROUND - GREEN symbol onto the Stage. 
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Add the animated buttons

Now, add the animated buttons you created.

1 Insert a new layer and name it “Buttons.” Make sure it is the top layer in 
the Timeline. 

As you add layers, you’ll want to be able to see all of them in the Timeline. 

2 Drag the lower border of the Timeline window so that all of the layers 
are visible.

3 Select the Buttons layer and drag an instance of the BUTTON - HOME 
symbol onto the Stage. 

Because buttons respond differently to the mouse than other objects do, you 
need to disable buttons before you can select them and make changes. After 
you finish working on buttons, you can enable them again. 

4 Choose Control > Enable Buttons and make sure that Enable Buttons is 
not checked. 

5 Select the instance of BUTTON - HOME and move it into position.

6 Make sure the Buttons layer is still selected in the Timeline, and then place an 
instance of the BUTTON - CONTACT symbol below the 
BUTTON - HOME instance on the Stage.

Timeline lower border
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7 To align the buttons, click BUTTON - CONTACT and hold down the Shift 
key as you click BUTTON - HOME to select both buttons. Choose 
Modify > Align and choose the horizontally left-aligned option.

8 Choose Control > Test Movie to see the buttons animate when you roll the 
mouse over them.

After the movie plays, close the test window to continue working in the movie. 

Add the animated movie clip

Now add the INTRO - ANIMATION movie clip you created.

1 Insert a new layer in the Timeline and name it “Intro Animation.” Make sure 
it is the top layer.

2 Lock the other layers to make sure you’re working only in the Intro 
Animation layer. 

3 Drag an instance of the INTRO - ANIMATION symbol from the Library 
window onto the Stage. 

Remember that the photograph image is completely transparent in the first 
frame on the movie clip, so the only visible part of INTRO - ANIMATION is 
the registration point.
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4 Move the INTRO - ANIMATION instance so that its registration point is 
over the refrigerator. 

Remember that movie clip animation does not run in the authoring 
environment.

5 Choose Control > Test Movie to see the movie with the animation working. 

The animation only runs the first time the movie runs the test window. 
To see the animation again, close the test window and choose 
Control > Test Movie again. 

When you finish viewing the animation, close the test window to continue 
working in the movie.

Registration point of 
INTRO - ANIMATION
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Add the text content layers

The buttons you’ve added are supposed to make the text content appear in the 
green area on the right. Now you’re ready to add the text content to the movie.

1 Insert a new layer at the top of the Timeline and name it “Text Home.”

2 Select the keyframe in frame 1 of the Text Home layer and drag an instance of 
the TEXT - HOME symbol onto the Stage. Fit the symbol in the green area as 
shown here: 

3 To make it easier to see what you’re doing, click in the Eye column of the Text 
Home layer to hide it before you add the next layer.

A red X appears to show that the layer has been hidden.
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4 Insert a new layer at the top of the Timeline and name it “Text Contact.”

5 Select the keyframe in frame 1 of the Text Contact layer and drag an 
instance of the TEXT - CONTACT symbol onto the Stage so that it fits in 
the green area.

Use actions to control content
You create interactive movies by setting up actions—sets of instructions that run 
when a specific event occurs. These events can be when the playhead reaches a 
frame, or when the user clicks a button or presses keys on the keyboard. 

Now you’ll add actions to the buttons to make the appropriate text content appear 
when the buttons are clicked. 
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Modify the instances of the text symbols

Because actions can only target movie clip symbols, you begin by changing the 
instances of the text symbols that you just added into movie clips and giving them 
names. In the next section you use these names to identify the instances as targets 
of an action. Begin with the TEXT - CONTACT instance.

1 Make sure the Text Contact layer is still selected in the Timeline, and then 
double-click the TEXT - CONTACT symbol instance on the Stage to open 
the Instance Properties dialog box.

2 Click the Definition tab, and then click Movie Clip as the behavior.

Notice that an Instance Name field appears under Instance Options.

3 Enter “Contact” as the instance name and click OK.

Now, change the instance of the TEXT - HOME symbol.

1 In the Timeline, click the visibility controls to hide the Text Contact layer and 
show the Text Home layer.

Remember that the visibility controls for each layer are in the column below 
the eye icon in the Timeline.

2 Select the Text Home layer in the Timeline, and then double-click the instance 
of the TEXT - HOME symbol on the Stage to open the Instance Properties 
dialog box. 

3 Click the Definition tab, and then click Movie Clip as the behavior.

4 Enter “Home” as the instance name, and click OK.
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Add an action to the BUTTON - HOME button

Now you can add an action to the BUTTON - HOME button that displays the 
Home text and hides the Contact text when the button is clicked.

The buttons should still be disabled so that you can select them and 
make changes.

1 Choose Control > Enable Buttons and make sure that Enable Buttons is 
not checked. 

2 Make sure the Buttons layer is selected in the Timeline and unlocked, then 
double-click the BUTTON - HOME button on the Stage to open the 
Instance Properties dialog box. 

3 On the Actions tab, click + (plus) and choose Set Property from the 
pop-up menu. 

4 Choose Visibility from the Set pop-up menu.

5 Click the button to the right of the Target box and choose Target Editor from 
the pop-up menu.

6 In the Target Editor, double-click Home to select it as the target, and then 
click OK.

7 In the Value box on the Actions tab, enter 1.
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Now, add a second statement that hides the Contact text. 

1 Click + (plus) and choose Set Property again from the pop-up menu.

2 Choose Visibility from the Set pop-up menu.

3 Click the button to the right of the Target box and choose Target Editor from 
the pop-up menu.

4 In the Target Editor, double-click Contact to select it as the target, and then 
click OK. 

5 In the Value field, enter 0 (zero).

The action for BUTTON - HOME should look like this: 

If you make a mistake, you can click the minus button (-) to remove the 
selected line in the action and then re-create the statement. You can also 
choose Edit > Undo.

6 Click OK to close the dialog box.
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Add an action to the BUTTON - CONTACT button

Now give the BUTTON - CONTACT button an action that displays the 
Contact text and hides the Home text.

1 Double-click the BUTTON - CONTACT button on the Stage to open the 
Instance Properties dialog box. 

2 On the Actions tab, click + (plus) and choose Set Property from the 
pop-up menu. 

3 Choose Visibility from the Set pop-up menu.

4 Click the button to the right of the Target box and then choose Target Editor 
from the pop-up menu.

5 In the Target Editor, double-click Contact to select it as the target, and then 
click OK.

6 In the Value field on the Actions tab, type 1.

Now, add a second statement that hides the Home text. 

1 Click + (plus) and choose Set Property again from the pop-up menu.

2 Choose Visibility from the Set pop-up menu.

3 Click the button to the right of the Target box and choose Target Editor from 
the pop-up menu. 

4 In the Target Editor, double-click Home to select it as the target, and then 
click OK.

5 In the Value field, enter 0 (zero). 

The action for BUTTON - CONTACT should look like this: 

6 Click OK to close the dialog box.
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Add a frame action

Hiding layers in the Timeline has no effect on content when you run the movie 
outside of the authoring environment. To hide both the Home and Contact text 
when the movie starts, add a frame action to the movie. 

1 Create a new layer in the Timeline and name it “Frame Actions.”

2 Double-click the first frame in the Frame Actions layer to open the Frame 
Properties dialog box. 

3 Click the Actions tab and choose + (plus), and then choose Set Property from 
the pop-up menu.

4 Select Visibility from the Set pop-up menu.

5 Click the button to the right of the Target box and choose Target Editor from 
the pop-up menu.

6 In the Target Editor, double-click Home to select it as the target, and then 
click OK.

7 In the Value field on the Actions tab, type 0 (zero).
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Now, create a new statement in the action by copying the existing statement. 

1 Press Control+C (Windows) or Command+C (Macintosh) to copy the first 
statement in the action.

2 Press Control+V (Windows) or Command+V (Macintosh) to paste a copy of 
the statement into the window.

This creates a copy of the line you just created. You only need to change 
the target.

3 Use the Target Editor to change the target from Home to Contact.

The action should look like this: 

4 Click OK to close the Frame Properties dialog box when you’re done.

At this point, you are done with the content of the movie. Your movie should 
look like the Tutorial Finish.fla example.
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Test the movie

Now that the movie content is complete, you can test the movie to see all of 
its features.

1 Choose Control > Test Movie.

2 While testing the movie, enter some data in the Contact fields. Enter more 
than one line in the Comment field to see the lines word wrap. 

3 Choose Control > List Variables to display the Output window.

4 Click Send to see it how the variables work. 

The Output window displays the data that Flash sends to the server. 

A functioning application would require additional actions, such as an action 
that clears the fields after sending the data, but this example should give you a 
basic understanding of how you can use Flash to send data to a server.

5 Close the Output window, and then close the window in which the movie 
is playing. 

You’re now ready to publish the movie.
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Publish the movie
The movie’s content is now complete. To play the movie in a browser, you need to 
export it as a Flash Player file. Flash has been doing this for you every time you use 
the Test Movie command. 

When you create a web site with Flash, you often need to include several 
accompanying files. In addition to a Flash movie, you must create an HTML 
document that opens in a browser and runs the Flash movie or displays other 
Flash-generated graphics. You may also want to create an animated-GIF version of 
your movie or a JPEG image to display if the Flash Player is not installed. 

Use the Publish command to export to all the supported formats at once and 
create an HTML document with all the required settings.

1 Make sure you’ve closed the separate window in which the movie was playing, 
and then choose File > Publish Settings.

2 On the Formats tab, select Flash and HTML. Make sure that the Use Default 
option for file names is selected.

Although you are not using any additional formats for this tutorial, this is 
where you can choose additional formats such as JPEG or QuickTime.

3 Click the Flash tab.

You don’t need to change any of these options now, but you may need them 
later for your own work. You may, for example, want the layers to appear from 
the top down instead of the bottom up as they do in this movie. 

4 Click the HTML tab. 

There are several ways to control Flash movies with HTML code. The 
settings in the HTML panel let you define the most common and useful 
settings, including the size, positioning, color, and quality of the movie. 
Flash inserts the settings you choose in a template document. Flash includes 
several template documents containing HTML code for useful features like 
browser detection. 

To complete this tutorial, you will choose a simple template that does nothing 
except display the Flash movie specified. 
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5 Choose Flash Only from the Template pop-up menu.

6 Deselect the Loop option.

This prevents the movie from playing over and over.

7 Click Paused at Start so that no check mark appears in the check box.

If you leave this option on, the movie does nothing until an action starts the 
movie. You want the animation to play as soon as the page is loaded, so this 
option should be off.

You don’t need to change the default values for the remaining HTML settings. 

8 Click Publish and then click OK to close the Publish Settings dialog box and 
generate the specified files.

Flash generates the new files and stores them in the same folder as the 
movie file.
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Play the movie inside a browser

Your work in Flash is complete at this point. Now you can see how the movie 
plays inside a browser.

1 Open a browser such as Netscape or Internet Explorer. 

2 Open the HTML file you just created.

 þ In Netscape Navigator, chose File > Open Page, and then browse to locate 
the file. 

 þ In Internet Explorer, choose File > Open, and then browse to locate the file.

The HTML file is in the same folder as the movie file and has the same name 
as the movie, with an .htm or .html file extension. 

The movie should run inside the browser window just as it did when you used 
the Test Movie command.
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Flash Basics

Flash basics overview
Flash movies are interactive vector graphics and animation for web sites. Web 
designers use Flash to create navigation controls, animated logos, long-form 
animations with synchronized sound, and even complete, sensory-rich web sites. 
Flash movies are compact, vector graphics, so they download rapidly and scale to 
the viewer’s screen size.

You’ve probably watched and interacted with Flash movies on many web sites 
including Disney®, The Simpsons®, and Pepsi®. Millions of web users have 
received the Flash Player with their computers, browsers, or system software; 
others have downloaded it from the Macromedia web site. The Flash Player 
resides on the local computer, where it plays back movies in browsers or as stand-
alone applications. 

As you work in Flash, you create a movie by drawing or importing artwork, 
arranging it on the Stage, and animating it with the Timeline. You make the 
movie interactive by making it respond to events and to change in specified ways. 
When the movie is complete, you export it as a Flash Player movie, embed it 
within an HTML page, and transfer it and the HTML page to a web server.

For an interactive introduction to Flash, choose Help > Lessons > 1 Introduction.

About vector and bitmap graphics
Computers display graphics in either vector or bitmap format. Understanding the 
difference between the two formats can help you work more efficiently with them. 
Flash lets you create and animate compact vector graphics. It also lets you import 
and manipulate bitmap graphics that have been created in other applications. 
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Vector graphics

Vector graphics describe images using lines and curves, called vectors, that also 
include color and position properties. For example, the image of a leaf is described 
by points through which lines pass, creating the shape of the leaf ’s outline. The 
color of the leaf is determined by the color of the outline and the area enclosed by 
the outline.

When you edit a vector graphic, you modify the properties of the lines and curves 
that describe its shape. You can move, resize, reshape, and change the color of a 
vector graphic without changing the quality of its appearance. Vector graphics are 
resolution-independent, meaning they can be displayed on output devices of 
varying resolutions without losing any quality. 

Bitmap graphics

Bitmap graphics describe images using colored dots, called pixels, arranged within 
a grid. For example, the image of a leaf is described by the specific location and 
color value of each pixel in the grid, creating an image much in the same manner 
as a mosaic.

When you edit a bitmap graphic, you modify pixels, rather than lines and curves. 
Bitmap graphics are resolution-dependent because the data describing the image is 
fixed to a grid of a particular size. Editing a bitmap graphic can change the quality 
of its appearance. In particular, resizing a bitmap graphic can make the edges of 
the image ragged as pixels are redistributed within the grid. Displaying a bitmap 
graphic on an output device that has a lower-resolution than the image itself also 
degrades the quality of its appearance. 
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Introducing the Flash work environment
When creating and editing movies, you typically work in these key areas: the 
Stage, the rectangular area where the movie plays; the Timeline window, where 
graphics are animated over time; the Library window, where the reusable media 
assets of the movie, called symbols, are organized; and symbol-editing mode, where 
symbols are created and edited. 

The Stage and the Timeline window

As with film, Flash movies divide lengths of time into frames. The Stage is where 
you compose individual frames in the movie, drawing directly on it or arranging 
imported artwork. 

The Timeline window is where you coordinate the timing of the animation and 
assemble the artwork on separate layers. The Timeline window displays each 
frame in the movie. Layers act like a stack of transparent acetate, keeping artwork 
separate so you can combine different elements into a cohesive visual image.

The logo, chair, and navigation controls in the movie are each on separate layers.

Stage

Timeline

Time
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The Library window

The Library window is where you store and organize symbols created in Flash, as 
well as imported files including sound files, bitmap graphics, and QuickTime 
movies. Symbols can consist of graphics, buttons, or movie clips. The Library 
window lets you organize library items in folders, see how often an item is used in 
a movie, and sort items by type. See “Using the Library window” on page 65.

Symbols and instances

Symbols are reusable graphics that you create with the drawing tools. When you 
place a symbol on the Stage or inside another symbol, you create an instance of 
that symbol. Symbols reduce file size because, regardless of how many instances 
you’ve created, Flash stores only one copy of it in the file. Use symbols, animated 
or otherwise, for every element that appears more than once in a movie. You can 
modify the properties of an instance without affecting the master symbol, and edit 
the master symbol to change all instances. 
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When editing a symbol, both the Stage and the Timeline change to display the 
content of the symbol. You can change the Stage to display the symbol in isolation 
or in its current context by graying other items on the Stage. You can also edit the 
symbol in a separate window. The Timeline displays only the timeline of the 
symbol you are editing. For more information on symbols and instances, see 
“Using symbols and instances overview” on page 141. 

Editing a symbol in isolation (left) and editing a symbol in its context in the movie.

Symbols and interactive movies

Symbols are also an integral part of creating interactive movies. For example, 
buttons that you can click, and which change in response to the mouse pointer, 
are a type of symbol. You use another type of symbol, called a movie clip, to create 
sophisticated interactive movies. See “Creating interactive movies overview” on 
page 173.
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Creating a new movie and setting 
its properties
Each time you open Flash, it creates a new file. Use the Movie Properties 
dialog box to set the size, frame rate, background color, and other properties of 
the movie. 

To create a new movie and set its properties:

1 Choose File > New.

2 Choose Modify > Movie.

3 For frame rate, enter the number of animation frames to be displayed every 
second. For most computer-displayed animations, especially those playing 
from a web site, 8 fps (frames per second) to 12 fps is sufficient.

4 For size, choose one of the following options:

 þ To specify the size in pixels, enter values for width and height. The default 
movie size is 550 pixels by 400 pixels. The minimum size is 18 pixels by 18 
pixels; the maximum is 2880 pixels by 2880 pixels.

 þ To set the Stage size so that there is equal space around the content on all 
sides, click Match Contents. To minimize movie size, align all elements to the 
upper left corner of the scene before using Match Contents.

 þ To set the Stage size to the maximum available print area, click Match Printer. 
This area is determined by the paper size currently selected in the Margins area 
of the Page Setup dialog box, minus the current margins. 

5 To use a grid, enter a value for the Grid Spacing, choose a color with the Grid 
color swatch, and select Show grid. 

6 To set the background color of your movie, choose a color from the 
Background color swatch.

7 Select the unit of measure from the Ruler Units option.
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Previewing and testing movies
As you create a movie, you’ll need to play it back to preview animation and test 
interactive controls. You have the following options:

 þ To test simple animation, basic interactive controls, and sound, use the 
Controller or the Play command to preview the movie within the Flash 
authoring environment.

 þ To test all animation and interactive controls, use the Test Movie and 
Test Scene commands to create Flash Player movies that play within a 
separate window.

 þ To test the movie in a web browser, use the File > Publish Preview > HTML 
command. See “Using Publish Preview” on page 240.

Controlling movie playback

Use commands on the Control menu, buttons on the Controller, or keyboard 
commands to control movie playback. 

To play the current scene:

Do one of the following:

 þ Choose Control > Play.

 þ Choose Window > Controller and click Play.

 þ Press Enter. The animation sequence plays in the Movie window at the frame 
rate you specified for the movie.

Use the Step Forward and Step Backward buttons on the Controller, or choose 
those commands from the Control menu to step through the frames of 
the animation. You can also press the < and > keys on the keyboard.

To play the movie in a continuous loop:

Choose Control > Loop Playback.

To play all the scenes in a movie:

Choose Control > Play All Scenes.

To play a movie without sound:

Choose Control > Mute Sounds.
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To enable frame actions:

Choose Control > Enable Frame Actions.

To enable button actions:

Choose Control > Enable Buttons.

Testing movies

Although Flash can play movies in the authoring environment, many animation 
and interactive functions do not work unless the movie is exported in its final 
format. Using commands on the Control menu, you can export the current movie 
as a Flash movie and immediately play the movie in a new window. The exported 
movie uses the options set in the Publish Settings dialog box.

You can also use this window to test downloading performance. See “Testing 
movie download performance” on page 226.

To test all interactive functions and animation:

Choose Control > Test Movie or Control > Test Scene. 

Flash creates a Flash Player movie, opens it in a separate window, and plays it with 
the Flash Player. The Flash Player file is located in the same folder as the FLA file. 
It is not a temporary file. 

Using the toolbox
The tools in the toolbox let you draw, select, paint, and modify artwork. Other 
tools let you change the view of the Stage. Most tools have modifiers that affect 
the painting or editing operations of the tool. 
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For information on using the drawing tools, see “Drawing and painting overview” 
on page 77.

To select a tool:

Do one of the following:

 þ Click the tool you want to use. Depending on the tool you select, a set of 
modifiers are displayed at the bottom of the toolbox.

 þ Press the tool’s keyboard shortcut. See “Drawing shortcuts” on page 267.

Using the Timeline
The Timeline organizes and controls a movie’s content over time in layers and 
frames. The most important components of the Timeline are frames, layers, and 
the playhead.

You can control the Timeline by changing the display of frames and by dragging it 
from the main application window, separating it into its own window, or by 
docking the Timeline to any side of the application window. 

displays the modifiers for that tool here.

Selecting a tool in the drawing toolbar...
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When there are more layers than can be displayed in the Timeline, scroll bars are 
available to the right of the layer time strips. You also can resize the Timeline 
and layers.

To move the Timeline: 

Drag from or double-click the area above the time ruler. Drag the Timeline 
window to the edge of the application window to dock it. Press Control to prevent 
the Timeline from docking.

To lengthen or shorten name fields:

Drag the bar separating the layer names and the Timeline.

To increase or decrease the number of layers displayed when the Timeline 
is docked:

Drag the bar separating the Timeline from the Stage area. 

Moving the playhead

The playhead moves through the Timeline to indicate the current frame displayed 
on the Stage. The Timeline header shows the frame numbers of the animation. 

To go to a frame:

Click the Timeline header or drag the playhead to the desired position. To stop an 
animation and deselect any selected frames, click the Timeline header.

Timeline header

Onion-skinning 
buttons

Frame View 
pop-up menuPlayhead

Frame-by-frame 
animation

Empty keyframe

Motion path 

Tweened 
animation
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To center the playhead:

Click Center frame on the Timeline status display.

Displaying the frame status

The Timeline status display indicates the number of the current frame, the current 
frame rate as set using Modify > Movie, and the elapsed time to the current frame. 
When playing an animation, the actual frame rate is displayed; this may 
differ from the movie frame rate if the computer can’t display the animation 
quickly enough.

Timeline status display
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Changing the display of frames in the Timeline

The Frame View pop-up menu on the Timeline determines how frames are 
displayed in the Timeline.

By default, frames appear as narrow cells. Change the width of these cells by 
choosing Tiny, Small, Normal, Medium, or Large. The Large frame height setting 
is useful for viewing the details of sound waveforms. Make the rows shorter by 
choosing Short. 

Frame View pop-up menu

Normal and Short frame view options

Two preview options are available to display a reduced image of the content of 
each frame in the layer in the Timeline frames. These thumbnails are useful as an 
overview of the animation, but they take up extra screen space.

The Preview option shows only the contents of each frame, scaled so it fits in the 
Timeline frames. This can cause the apparent content size to vary.

Click here to open 
the Frame View 
pop-up menu.
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The Preview in Context option displays each movie frame entirely, scaled to fit in 
the Timeline frames. This is useful for viewing how elements move within their 
frames over the course of the animation, but elements generally appear smaller 
than with the Preview option.

Creating frame labels and movie comments

Frame labels are useful for identifying keyframes in the Timeline and should be 
used instead of frame numbers when targeting frames in actions such as Go To and 
If Frame Is Loaded. If you add or remove frames, the label moves with the frame it 
was originally attached to, whereas frame numbers can change. 

Frame labels are exported with movie data, so avoid long names to minimize file 
size. Frames labeled with a pound sign are indicators of animated GIF and PNG 
formats. For more information, see “GIF publish settings” on page 233, and 
“PNG publish settings” on page 236.

Comments are useful for notes to yourself and others working on the same movie. 
You cannot use them in actions. Comments are not exported with movie data, so 
you can make them as long as you want.

To create a frame label or comment:

1 Double-click a frame, or select a frame and choose Modify > Frame.

2 In the Frame Properties dialog box, click the Label tab.

3 For behavior, choose Label or Comment.

4 Enter text in the Name box. 

Using scenes
Use scenes to organize a movie thematically. For example, use separate scenes for 
an introduction, loading teaser, or credits. 
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When you play a Flash movie that contains more than one scene, the scenes play 
back in the order they are listed in the Scene inspector, one after another. Use 
actions if you want the movie to stop or pause after each scene, or to let users 
navigate the movie in a non-linear fashion. See “Creating interactive movies 
overview” on page 173.

Scene inspector

If you organize your movie into several scenes, you may have difficulty 
implementing actions that use Wait for Frame when spanning scenes. In this case, a 
movie with one long scene provides better performance. You may also want to 
avoid scenes if you preload many actions in your movies. 

To display the Scene inspector:

Choose Window > Inspectors > Scene.

To view a particular scene:

Choose View > Goto and then choose the name of the scene. 

To add a scene:

Click Add in the Scene inspector or choose Insert > Scene.

To delete a scene

Click Delete in the Scene inspector, or open the scene you want to delete and 
choose Insert > Remove Scene.

To change the name of a scene:

Click Properties in the Scene inspector or choose Modify > Scene.

To duplicate a scene:

Click Duplicate in the Scene inspector.

To change the order of a scene in the movie:

Drag a scene name in the Scene inspector.
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Using the Library window
Each Flash file has its own library that may contain symbols, bitmaps, sound, and 
video files. Use the Library window to view and organize the contents of the file’s 
library. When you select an item in the Library window, Flash previews the item at 
the top of the window. If the selected item is animated or is a sound file, you can 
use the controller to preview it.

You can organize library items into folders. The Library window columns list 
the name of an item, its type, the number of times it’s used in the file, and the 
date on which is was last modified. You can sort items in the Library window by 
any column. 

To display the Library window:

Choose Window > Library. 

To change the width of columns:

Position the pointer between column headers and drag to resize. You cannot 
change the order of columns. 
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To resize the Library window:

Do one of the following:

 þ Drag the lower right corner.

 þ Click the Wide State button to enlarge the Library window so that it displays 
all the columns.

 þ Click the Narrow State button to reduce the width of the Library window to 
the Name column only. 

Sort order
Wide State
Narrow State

Options menu

Item preview

New Symbol

New Folder

Delete item
Item Properties
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Working with folders in the Library window

You can organize items in the Library window using folders, much like the 
Windows Explorer or the Macintosh Finder. When you create a new symbol, it is 
stored in the selected folder. If no folder is selected, it is stored at the root of the 
Library window.

To create a new folder:

Click the New Folder button at the bottom of the Library window.

To move an item between folders:

Drag it from one folder to another. 

To open or close a folder:

Do one of the following:

 þ Double-click a folder.

 þ Select a folder and choose Expand Folder or Collapse Folder from the Options 
menu in the Library window. 

To open or close all folders:

Choose Expand All Folders or Collapse All Folders from the Options menu in the 
Library window.

Sorting items in the Library window

You can sort items in the Library window by any of the column criteria. Sorting 
items lets you view related items together. Items are sorted within folders.

To sort items in the Library window:

Click the column header to sort by that criteria. Click the triangle button at the 
right edge of the column headers to reverse the sort order. 

Renaming library items

Renaming imported files, whether bitmaps or sounds, does not change the 
file name.

To rename a library item:

To rename a library item, do one of the following:

 þ Choose Rename from the Library window’s Options menu.

 þ Right-click (Windows) or Command-click (Macintosh) and choose Rename.

 þ Click the Information icon at the bottom of the Library window.

 þ Double-click the item’s name.
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Deleting library items

When you delete an item from the Library window, all instances or occurrences of 
that item in the movie are also deleted. You can see if an item is in use by the Use 
Count column in the Library window. 

To delete a library item:

Select the item and click the Delete button at the bottom of the Library window.

Finding unused library items

You can reduce the size of a Flash file by deleting any unused library items. 
Unused library items are not included, however, in the published Flash Player 
movie (SWF file).

To find unused media:

Do one of the following:

 þ Choose Select Unused Items from the Options menu in the Library window.

 þ Sort library items by the Use Count column. See “Sorting items in the Library 
window” on page 67.

Updating imported files

If you’ve edited files you’ve imported into a Flash, such as bitmaps and sounds, 
you can update the file in the Flash movie without importing it again.

To update an imported file:

Select the imported file in the Library window and choose Update from the 
Library window’s Options menu. 

Using the Libraries menu

To store or retrieve other libraries included in Flash, use the Libraries menu. The 
Libraries menu displays the button and animation libraries included with Flash. 

You can also add your own symbols to the Libraries menu by placing a Flash file in 
the Libraries folder located in the Flash application folder. 

To open a Flash file as a library:

Choose File > Open as Library. 
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Using inspectors
Inspectors help you view, organize, and change elements in a Flash movie. You can 
show, hide, and group inspectors as you work. 

To show or hide an inspector:

Choose the desired Window > Inspector command.

To group inspectors:

Drag inspectors from their tab into the same window. 

To bring an inspector within a group to the front:

Click its tab.

To ungroup an inspector into a separate window:

Drag the inspector from its tab outside of the window.

Using context menus
Context menus contain commands relevant to the current selection. For example, 
when you select a frame in the Timeline window, the context menu contains 
commands for creating, deleting, and modifying frames and keyframes. 

Context menu for a selected frame

To open a context menu:

Right-click (Windows) or Control-click (Macintosh) an item in the Timeline, the 
Library window, or on the Stage.
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Viewing the Stage
View the entire Stage on the screen, or a particular area of your drawing at high 
magnification, by changing the magnification level. The maximum magnification 
depends on the resolution of your monitor and the movie size.

Zooming

Use these techniques to magnify or reduce your view of the stage:

 þ To zoom in on a a certain element, select the magnifier tool and click the 
element. Use the Zoom Control pop-up menu or the magnifier tool to zoom 
in or out on particular areas of the Stage. To switch the magnifier tool between 
zooming in or out, use the Increase or Decrease modifiers or hold down the 
Alt (Windows) or Option (Macintosh) key.

 þ To zoom in on a specific area of your drawing, drag a rectangle with the 
magnifier tool. Flash sets the magnification level so that the specified rectangle 
fills the window.

 þ Choose a percentage from the Zoom Control pop-up menu or enter a value. 
Percentages larger than 100% zoom in.

Moving the view

When the Stage is magnified, you may not be able to see all of it. The hand tool 
lets you move the Stage so that the view changes without making you change the 
magnification.

To move the view:

1 Select the hand tool. To temporarily switch between another tool and the 
hand tool, hold down the Spacebar. 

2 Drag the Stage. 
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Using View commands

Use commands on the View menu to adjust your view of the Stage. 

100% Sets the zoom level to 100% so that your drawing appears as close as 
possible to actual size. This is the same as using the zoom controls on the toolbox. 
(Depending on your monitor and video card, 1 inch on the screen may not equal 
1 inch on the Flash rulers.)

Show All Sets the zoom level to display the contents of the current frame. If the 
scene is empty, the entire scene is displayed.

Show Frame Sets the zoom level to display the entire scene. As a shortcut to this 
command, double-click the hand tool. 

Work Area Makes the work area that surrounds the frame of your movie visible. 
The work area is shown in light-gray. Use the Work Area command when you 
need to work with parts of your drawing that are partly or completely out of the 
scene. For example, to have a bird fly onto the screen, you would initially position 
the bird off-screen in the work area. To see the most work area and Stage, choose 
View > Work Area and View > Show All.

Using the grid and rulers
The Grid command shows or hides the drawing grid in all scenes. This is the 
same as turning on Show Grid in the Movie Properties box (Modify > Movie). 
Set grid spacing by choosing Modify > Movie and entering a value into the 
Grid Spacing box.

You can display rulers along the top and left sides of the movie. When you move 
an element on the stage with the rulers displayed, lines indicating the element’s 
dimensions appear on the rulers.

Note: To create custom guide or irregular guides, use guide layers. See “Using guide layers” 
on page 136.

To display or hide rulers:

Choose View > Rulers.

To specify the units of measurement for the movie:

Choose Modify > Movie and choose the preferred units. 

Regardless of the currently chosen units, you can enter numeric values in any 
dialog box in any of the recognized measurement units. Include the appropriate 
abbreviation with the entered value (for example, 0.25” or 10 pt).
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Printing Flash files
Use the Print dialog box to specify the range of scenes or frames you want to print, 
as well as the number of copies. In Windows, the Page Setup dialog box specifies 
paper size, orientation, and various print options—including margin settings and 
whether all frames are to be printed for each page. On the Macintosh, these 
options are divided between the Page Setup and the Print Margins dialog boxes. 

The Print and the Page Setup dialog boxes are standard within either operating 
system and their appearance depends on the printer driver selected.

To set printing options: 

1 Choose File > Page Setup (Windows) or File > Print Margins (Macintosh).

2 Set page margins. Select the Center options to print the frame in the center of 
the page.

3 Choose to print every frame in the movie or only the first frame of each scene 
with the Frames option.

4 For Layout, choose one of the following options:

 þ Actual Size prints the frame at full size. Enter a value in the scale option to 
reduce or enlarge the printed frame.

 þ Fit on One Page reduces or enlarges each frame so it fills the print area of 
the page.

 þ Storyboard options print several thumbnails on one page. Set the number of 
thumbnails per page with the frames option. Set the space between the 
thumbnails with the story Margin option. Click Label to print the frame label 
as a thumbnail.

To preview how your scene is arranged on the printer paper:

Choose File > Print Preview.
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Solving printing problems

If you experience problems printing Flash files on your PostScript printer, one of 
the filled areas in your drawing may be too complex. (This is more common with 
older PostScript Level 1 printers.) There are two solutions to this problem:

 þ Choose Disable PostScript in the Print Margins dialog box (Macintosh) or in 
the Options dialog box (Windows), and try printing again. This can slow 
down printing considerably, but it should solve the problem.

 þ Simplify your drawing. Printing problems are typically caused by a single large 
area of color with complex borders. You can solve this problem by dividing the 
complex area into several simpler areas. Use Modify > Curves > Optimize to 
reduce the complexity of such areas.

Also note that Flash cannot print transparency (alpha channel) effects or 
mask layers.

Speeding up the display
To speed up the display, you can use commands on the View menu to turn off 
rendering quality features that require extra computing and slow down movies. 

None of these commands have any affect on how Flash exports a movie. Use 
OBJECT and EMBED parameters to specify the display quality of Flash movies 
in a web browser. The publish command can do this for you automatically. For 
more information, see “Publishing Flash movies” on page 228.

Outlines Displays only the outlines of the shapes in your scene and all lines appear 
as thin lines. This makes it easier to reshape your graphic elements and to display 
complex scenes faster.

Fast Turns off anti-aliasing and displays all the colors and line styles of your 
drawing. This is the most common mode in which to work. 

Antialias Turns on anti-aliasing for lines, shapes, and bitmaps. It displays shapes 
and lines so that their edges appear smoother on the screen. This option draws 
more slowly than the Fast option. Anti-aliasing works best on video cards that 
provide thousands (16-bit) or millions (24-bit) of colors. In 16- or 256-color 
mode, black lines are smoothed, but colors might look better in Fast mode. Also, 
note that Antialias has very little effect on a black-and-white display.

Antialias Text Smooths the edges of any text. This command works best with large 
font sizes and can be slow with large amounts of text.
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Setting preferences
Choose File > Preferences to set various Flash parameters. See also “Setting 
drawing preferences” on page 94. 

Bitmaps on Clipboard (Windows only) Places a bitmapped version of your drawing 
on the Clipboard, in addition to the standard Windows Metafile information, 
when you choose Edit > Copy. This is useful when pasting information into an 
application that works best with bitmapped drawings. You can choose a 
bitmapped format and resolution, as well as enable anti-aliasing. 

Size limit (Windows only) Limits the amount of RAM that is used when putting a 
bitmapped image on the Clipboard. Increase this value when working with large 
or high-resolution bitmapped images. If your computer has limited memory, 
choose None.

Gradients on Clipboard Controls the quality of gradient fills placed in the 
Windows Metafile that is generated each time you copy elements to the 
Clipboard. Because of limitations of the Windows Metafile format, generating 
these gradients can be slow. If you are only pasting back into Flash, choose None 
to speed copying. Flash always keeps the full gradient quality with its native 
Clipboard data.

Printing Options (Windows only) Disables PostScript output when printing to a 
PostScript printer. By default, this box is not checked. Select it only if you have 
problems printing to a PostScript printer. Printing to a PostScript printer can be 
much slower when Flash's PostScript is disabled.

PICT Settings for Clipboard (Macintosh only) Controls the type of PICT 
information that is generated when you use Edit > Copy. Choose Object to 
keep your drawing information in a vector format or choose one of the various 
bitmap formats. These options are similar to the options available with the PICT 
Export dialog box. The default is Objects at a resolution of 300 dpi with 
PostScript Included.

Gradients (Macintosh only) Controls the quality of gradients placed in the PICT 
that is generated each time you copy elements to the Clipboard. Because of 
limitations of the PICT format, generating these gradients can be slow. If you are 
only pasting back into Flash, choose None to speed copying. Flash always keeps 
the full gradient quality with it's native Clipboard data.

Undo Levels Sets the number of undo/redo levels (up to 200). Undo levels require 
memory; the more undo levels you use, the more system memory is taken up. 
Setting a large number of levels of undo can increase the amount of memory 
Flash requires.
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Shift Select Controls how Flash handles selection of multiple elements. With Shift 
Select off, clicking additional elements adds them to the current selection. With 
Shift Select on, clicking additional element deselects other elements unless you 
hold down the Shift key.

Show Tooltips Displays Tooltips when the pointer pauses over a window emblem. 
Deselect this option if you don't want to see the Tooltips.

Disable Timeline Docking Keeps the Timeline from attaching itself to the 
application window once its been separated into its own window. See also “Using 
the Timeline” on page 59.
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Drawing and Painting

Drawing and painting overview
The drawing and painting tools let you create and modify shapes for the artwork 
in your movies. For an interactive introduction to drawing in Flash, choose 
Help > Lessons > 2 Drawing.

Understanding drawing and painting in Flash
Before you draw and paint in Flash, it is important to understand how drawing, 
painting, and modifying shapes can affect other shapes on the same layer. When 
you draw a line across another line or painted shape, the line you draw acts like a 
knife and divides the other line or shape it crosses into separate segments. 
Furthermore, the drawn line itself is divided into segments, as shown in this 
illustration. You can select, move, and reshape each segment individually.

A fill; the fill with a line drawn through it; and the two fills and three line segments 
created by segmentation
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When you paint on top of shapes and lines, the portion underneath is replaced by 
whatever is on top. Paint of the same color merges together. Paint of different 
colors remains distinct. Use these features to create masks, cutouts, and other 
negative images. For example, the leaf cutout below was made by moving the 
ungrouped leaf image onto the red shape, deselecting the leaf, and then moving 
the leaf away from the red shape.

To avoid inadvertently altering shapes and lines, group them or use layers to 
separate them. See “Grouping objects” on page 112 and “Layers overview” on 
page 133. 

Drawing with the pencil tool
You can draw lines and shapes with the pencil tool, much like drawing with a real 
pencil. After you draw lines, Flash straightens or smooths them. The amount of 
straightening or smoothing depends on the selected drawing mode. Flash also 
segments lines at sharp corners. 
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To draw with the pencil tool:

1 Select the pencil tool.

2 Choose a drawing mode:

 þ Straighten lets you draw straight lines and converts approximations 
of triangles, ovals, circles, rectangles, and squares into these common 
geometric shapes.

 þ Smooth lets you draw smooth curved lines.

 þ Ink lets you draw freehand lines.

Lines drawn with Straighten, Smooth, and Ink mode, respectively. 

3 Choose stroke attributes as described in “Setting fill and stroke attributes” on 
page 83. 

4 Drag on the Stage. Shift-drag to constrain lines to vertical or horizontal 
directions.

Drawing mode

Stroke color
Stroke color focus

Line width

Line style
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Drawing straight lines, ovals, and rectangles
You can use the line, oval, and rectangle tools to easily create these common 
shapes. The oval and rectangle tools let you stroke and fill the shape as you draw 
it. The rectangle tool lets you draw rectangles with square or rounded corners.

To draw a straight line, oval, or rectangle:

1 Select the line, oval, or rectangle tool. 

2 Choose stroke and fill attributes as described in “Setting fill and stroke 
attributes” on page 83. You cannot set fill attributes for the line tool. 

3 For the rectangle tool, specify rounded corners by clicking the Round 
Rectangle modifier and entering a corner radius value. A value of zero creates 
square corners.

4 Drag on the Stage. If you are using the rectangle tool, press the up and down 
arrow keys while dragging to adjust the radius of rounded corners. 

For the oval and rectangle tools, Shift-drag to constrain the shapes to circles 
and squares.

For the line tool, Shift-drag to constrain lines to multiples of 45°.

Painting with the brush tool
The brush tool draws brush-like strokes as if you were painting. The brush tool 
lets you create special effects, including calligraphic effects and painting with the 
image in an imported bitmap. On most pen and pressure-sensitive tablets, you can 
vary the width of the brush stroke by varying pressure on the pen tip. For 
information on using the image in an imported bitmap to fill a brush stroke, see 
“Painting with a bitmap’s image” on page 129.

A variable-width brush stroke drawn with a pen and pressure-sensitive tablet.
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To paint with the brush tool:

1 Select the brush tool.

2 Choose a painting mode:

Original image, Paint Normal, Paint Behind, Paint Fills, Paint Selection, 
and Paint Inside

 þ Paint Normal paints over lines and fills on the same layer.

 þ Paint Behind paints in blank areas of the Stage, leaving lines and fills 
unaffected.

 þ Paint Fills paints fills and empty areas, leaving lines unaffected.

 þ Paint Selection paints the selected fill.

 þ Paint Inside paints the fill in which you start a brush stroke and never paints 
lines. This works much like a smart coloring book, in which you can never 
paint outside the lines. If you start painting in an empty area, the stroke 
doesn’t affect any existing filled areas.

3 Choose a brush size, brush shape, and paint color from the brush 
tool modifiers.

4 If a pen and pressure-sensitive table is attached to your computer, you can 
select the Pressure Modifier to vary the width of your brush strokes by varying 
the pressure on your pen tip. 

5 Drag on the Stage. Shift-drag to constrain brush strokes to horizontal and 
vertical directions.

Painting mode

Fill color

Brush size

Brush shape

Lock fill

Fill color focus
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Erasing
Erasing with the eraser tool removes lines and paint. You can quickly erase 
everything on the Stage, erase line segments and fills, or erase by dragging. 

You can customize the eraser tool to erase only lines, only paint, or only a single 
area of paint. The eraser tool can be either round or square, and have one of 
five sizes. 

To quickly delete everything on the Stage:

Double-click the eraser tool.

To remove entire line segments or fills:

1 Select the eraser tool and then click the Faucet modifier. 

2 Click the line or filled area you want to delete. 

To erase by dragging:

1 Select the eraser tool.

2 Choose an erasing mode:

 þ Erase Normal erases lines and fills on the same layer.

 þ Erase Fills erases only fills; lines are not affected.

 þ Erase Lines erases only lines; fills are not affected.

 þ Erase Selected Fills erases only the currently selected fills and does not affect 
lines, selected or not.

 þ Erase Inside erases only the fill on which you begin the eraser stroke. If you 
begin erasing from an empty point, nothing will be erased. Lines are 
unaffected by the eraser in this mode.

3 Choose an eraser shape and make sure that the Faucet modifier is not selected.

4 Drag on the Stage. 
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Filling and stroking shapes
Filling a shape paints the shape with color. Stroking a shape paints the outline of 
the shape with color. Stroking a line paints the line with color. 

Use the paint bucket tool to fill shapes. Use the ink bottle tool to stroke lines 
and shapes. Use the eyedropper tool to sample fill or stroke attributes from one 
shape and immediately apply them to another shape with the paint bucket or ink 
bottle tools. 

Setting fill and stroke attributes

The pencil, line, rectangle, oval, brush, paint bucket, and ink bottle tools share the 
same modifiers for fill and stroke attributes. When you switch between these tools, 
the fill and stroke attributes do not change. Lines can’t be filled unless you convert 
lines to fills. See “Creating special curve effects” on page 99.

To set fill and stroke attributes:

1 Select a drawing or painting tool.

2 To set stroke or fill color, do one of the following:

 þ Position the pointer over the stroke or fill color modifier and drag to highlight 
a color in the palette. 

 þ Choose Window > Colors and select a color from the Solid tab. If you are 
using the oval or rectangle tools, click the color focus next to the stroke or fill 
color modifiers in the toolbox to set the appropriate attribute.

3 To set line width and style, choose options from the line width and line 
style modifiers. 

Stroke color

Stroke color focus

Line width

Line style

Fill color

Fill color focus
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Applying fills and strokes with a value of None

When drawing ovals and rectangles, you can apply fills and strokes with a value of 
None. This lets you create stroked shapes with no fill or filled shapes with no 
stroke. If you happen to apply a stroke and fill of None to an object, Flash deletes 
it from the Stage. 

To apply fills and strokes with a value of None:

1 Select the oval or rectangle tool. 

2 From the stroke or fill color modifier, select the blank swatch in the upper left 
corner of the palette.

3 Drag on the Stage.

Creating custom line widths and styles

You can customize the list of options available with the line width and line style 
modifiers. For the line width modifier, you can change the value of the last option 
in the list. For the line style modifier, you can change the appearance of each 
option. Using custom line styles increase the file size of your Flash movie.

None value
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To create a custom line width:

1 Choose Custom from the line width modifier of the line, pencil, oval, or 
rectangle tools.

2 Enter a value for line width.

To create a custom line style:

1 Choose Custom from the line style modifier of the line, pencil, oval, or 
rectangle tools. 

2 Choose a line style from the Type list and modify the displayed options. The 
options available depend on the line style. 

Using the paint bucket tool

The paint bucket tool fills enclosed areas with color. It fills empty areas and 
changes the color of existing paint. You can paint with solid colors, gradient fills, 
and bitmap fills. You can also use the paint bucket tool to adjust the size, 
direction, and center of gradient and bitmap fills. For information on using the 
image in a bitmap to fill a shape, see “Painting with a bitmap’s image” on page 129

The hand shape is not fully enclosed but can still be filled. The star shape consists of 
individual lines that enclose an area that can be filled. 

To use the paint bucket tool to fill an area: 

1 Select the paint bucket tool.

2 Choose a fill color. 

3 Choose a gap size option. 

 þ Choose Don’t Close Gaps if you want to close the gaps yourself. This can be 
faster for complex drawings.

 þ Choose a close option to have Flash automatically fill the gaps. 

4 Click a shape or enclosed area.

Note: Zooming in or out changes the apparent, but not the actual size of the gaps. If gaps 
are too large, you may have to close them manually.
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To use the paint bucket tool to adjust a gradient or bitmap fill:

1 Choose the paint bucket tool.

2 Click the Transform Fill modifier.

3 Click an area filled with a gradient or bitmap fill.

When you select a gradient or fill for editing, its center point appears and its 
bounding box is displayed with editing handles. When the pointer is over any 
one of these handles, it changes to indicate the function of the handle.

Press Shift to constrain the direction of a linear gradient fill to multiples 
of 45°.

4 Reshape the gradient or fill in the following ways:

 þ To reposition the center point of the gradient or bitmap fill, drag the 
center point.

 þ To change the width of a gradient or bitmap fill, drag the square handle on the 
side of the bounding box.

 þ To change the height of a bitmap fill, drag the square handle at the bottom of 
the bounding box.
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 þ To rotate the gradient or bitmap fill, drag the circular rotation handle at the 
corner of a linear gradient or a bitmap fill. You can also drag the lowest handle 
on the bounding circle of a circular gradient or a fill.

 þ To scale a linear gradient or a fill, drag the square handle at the center of the 
bounding box.

 þ To change the radius of a circular gradient, drag the middle circular handle on 
the bounding circle.

 þ To skew or slant a fill within the shape, drag one of the circular handles on the 
top or right side of the bounding box.

 þ To tile a bitmap inside a shape, scale the fill.

Note: To see all of the handles when working with large fills or fills close to the edge of the 
Stage, choose View > Work Area.
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Using the Lock Fill modifier

Locking a gradient or bitmap image creates the effect of scaling a gradient or 
bitmap as if it filled the entire Stage and that the shapes it fills are masks revealing 
the underlying gradient or fill. Painting with a locked fill has the effect of 
uncovering the fill. 

Use locked fills to make it appear that a single gradient or bitmap fill extends 
across multiple objects. 

The upper and lower boxes are filled with the same locked gradient. 

To use a locked gradient or bitmap fill:

1 Select the brush or paint bucket tools and choose a gradient or bitmap as fill.

To use a bitmap as fill, break the bitmap apart and use the dropper tool to 
select a bitmap before selecting the brush or paint bucket tools. See “Painting 
with a bitmap’s image” on page 129.

2 Click the Lock Fill modifier.

3 Paint the areas where you want to place the center of the fill first, and then 
move to other areas. 

Using the ink bottle tool

You can stroke lines and shapes with only solid colors, not gradients or bitmaps. 
Stroke attributes also include line width and line style.

To use the ink bottle tool: 

1 Select the ink bottle tool.

2 Choose line color, line style, and line width from the tool modifiers. 

3 Click a line or shape on the Stage. 
Chapter 388



Using the eyedropper tool

Use the eyedropper tool to copy fill and stroke attributes from one shape or line 
and immediately apply them to another shape or line. The eyedropper tool also 
lets you sample the image in a bitmap to use as paint. See “Painting with a 
bitmap’s image” on page 129.

When you Shift-click an area with the dropper tool, the sampled fill and stroke 
attributes are applied to the modifiers for all the drawing tools. 

To use the eyedropper tool to copy and apply stroke or fill attributes:

1 Select the eyedropper tool and click a line or shape.

When you click a line, the tool automatically changes to the ink bottle tool. 
When you click a fill, the tool automatically changes to the paint bucket tool 
and the Lock Fill modifier is turned on. See “Using the Lock Fill modifier” on 
page 88.

2 Click another line or shape.

Using color palettes
Each Flash file contains its own color palette. This palette is stored in the Flash 
file, but it doesn’t affect the file size. You can import and export both solid and 
gradient color palettes between Flash files, as well as between Flash and other 
applications, such as Macromedia Fireworks and Adobe Photoshop. The default 
palette is the web-safe palette of 216 colors. 

Flash displays the colors in a file’s palette as swatches in the modifiers for fill, 
stroke, and type color. It also displays them in the Colors window. Use the Colors 
window to import, export, and modify a file’s color palette. Use the color picker in 
the Colors window to specify color values. 

To display the Colors window:

Choose Window > Colors.

To load or save the default palette:

In the Colors window, choose one of the following commands from the palette 
pop-up menu in the lower left corner.

 þ Load Default Colors replaces the current palette with the default palette.

 þ Save as Default saves the current color palette as the default palette. The 
default palette used when you create new files.
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To clear colors from a palette:

In the Colors window, choose Clear Colors from the palette pop-up menu in the 
lower left corner.

All the colors are removed except black and white, and one gradient.

To load the web-safe 216 color palette:

In the Colors window, choose Web 216 from the palette pop-up menu in the 
lower left corner.

To sort colors in the palette:

In the Colors window, choose Sort by Color from the palette pop-up menu in the 
lower left corner.

Colors are sorted based on luminosity values.

Importing and exporting color palettes

You can import and export both RGB colors and gradients between Flash files 
using Flash Color Set files (CLR files). You can import and export RGB color 
palettes using Color Table files (ACT files) that can be used with Macromedia 
Fireworks and Adobe Photoshop. You cannot import or export gradients from 
ACT files. You can also import color palettes, but not gradients, from GIF files. 

To import a color palette:

1 In the Colors window, choose one of the following commands from the 
palette pop-up menu in the lower left corner:

 þ Add Colors appends the imported colors to the current palette.

 þ Replace Colors replaces the current palette with the imported colors.

2 Navigate to and select the desired file.

To export a color palette:

1 In the Colors window, choose Save Colors from the palette pop-up menu in 
the lower left corner.

2 In the Export Color Swatch dialog box, enter a name for your color palette, 
and choose between Flash Color Set or Color Table.
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Creating and editing solid colors

A Flash movie can have more colors than appear in the color palette of the stroke 
and fill color modifier. The number of colors in a movie is limited only by your 
system’s color depth setting (256, thousands, or millions of colors).

None value

Current palette

Colors window button

Available gradients
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To create or edit solid colors:

1 Click the Colors window button at the top of the fill or stroke color palette, or 
choose Window > Colors.

2 Click the Solid tab to display the panel for changing solid colors.

3 Select the color in the palette you want to change.

4 Change the color in the following ways:

 þ To set the hue, tint, and brightness, drag the crosshair in the color space to 
define the hue and move the slider to the right of the color space to set the tint 
and brightness. 

 þ To define the degree of transparency for the color, use the slider or enter a 
percentage in the Alpha box, from 0 for complete transparency, to 99 for some 
transparency (100 is opaque). Solid colors with transparency appear with a 
grid showing through the color.

 þ To define a color by the value of its red, green, and blue components, enter 
values in the appropriate text boxes.

 þ To define a color by its hex value, select the Hex option, and enter the hex 
value in the RGB text boxes. 

Current color Color preview

Alpha slider

Color space

RGB values
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5 When you have finished changing color settings, do one of the following:

 þ To replace the currently selected color with a newly defined color, 
click Change.

 þ To add a newly defined color to the end of the color table, click New.

 þ To delete the currently selected color cell from the color table, click Delete.

 þ To prepare the movie for use in a browser, turn on Solid Colors to match the 
selected color in the color space to the closest color from the palette of 216 
web-safe colors.

Creating and editing gradients

Use the Colors window to create and edit gradients. The Gradient tab in the 
Colors window displays all of the gradients presently available to Flash.

A gradient is a blended transition between 2 or more colors, up to 8. The 
transition can be in linear bands, or concentric circles. Any color in a gradient can 
also include a degree of transparency. 

Current gradient

Pointer well

Gradient
definition bar

Gradient Type 
pop-up menu

Gradient 
preview box Color space

Hue bar

Color pointers

Solid Colors 
pop-up menu
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To create or edit a gradient:

1 Click the Colors window button at the top of the fill or stroke color palette or 
choose Window > Colors.

2 Click the Gradient tab.

3 Do one of the following:

 þ To create a new gradient, select a gradient to use as a starting point and 
click New. 

 þ To edit a gradient, select it. 

4 Choose Radial or Linear from the Type list.

5 Add a pointer to the gradient definition bar by dragging it from the pointer 
well; remove a pointer by dragging it off the bar in any direction.

Color pointers define where colors change in a gradient. 

6 Click the color swatch directly below the color picker window, and select a 
color for the transition. 

Both the pointer and transition are updated with the color you selected.

7 Use the Alpha slider to set the degree of transparency, from 0 for complete 
transparency to 99 for some transparency. Each color in a gradient can have its 
own Alpha setting. 

8 Select and choose settings for additional color pointers. 

9 Click Change. 

Setting drawing preferences
The File > Assistant command sets preferences that affect the drawing tools. Each 
option can be off or on and each has a set of tolerances. Turn on an option by 
selecting a tolerance setting. Tolerance settings are relative, depending on the 
resolution of your computer screen and the current magnification of the scene. As 
with drawing in general, zooming in provides better control. 

Snap to Grid Determines how close the end of a line being drawn must be to a 
grid line before the endpoint snaps to the grid. The options are Off, Must be 
Close, Normal, Can be Distant, and Always Snap.
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Connect Lines Determines how close the end of a line being drawn must be to an 
existing line segment before the endpoint snaps to the nearest point on the other 
line. The available options are Off, Must be Close, Normal, and Can be Distant. 

This setting also controls horizontal and vertical line recognition: that is, how 
nearly horizontal or vertical a line must be drawn before Flash makes it exactly 
horizontal or vertical.

Smooth Curves Specifies the amount of smoothing applied to curved lines drawn 
with the pencil tool when the drawing mode is set to Straighten or Smooth. 
(Smoother curves are easier to reshape, while rougher curves match more closely 
the original line strokes.) The selections are Off, Rough, Normal, and Smooth.

Note: You can further smooth existing curved segments using Modify > Curves > Smooth 
and Modify > Curves > Optimize.

Recognize Lines Defines how nearly straight a line segment must be drawn before 
Flash recognizes it and makes it perfectly straight. The selections are Off, Strict, 
Normal, and Tolerant.

If Recognize Lines is off while you draw, you can straighten lines later by selecting 
one or more line segments and choosing Modify > Curves > Straighten.

Recognize Shapes Controls how precisely you must draw circles, ovals, squares, 
rectangles, and 90° and 180° arcs for them to be recognized as geometric shapes 
and redrawn accurately. The options are Off, Strict, Normal, and Tolerant.

If Recognize Shapes is off while you draw, you can straighten lines later by 
selecting one or more shapes (for example, connected line segments) and choosing 
Modify > Curves > Straighten.

Click Accuracy Specifies how close to an item the pointer must be before Flash 
recognizes the item. The options are Strict, Normal, and Tolerant.

Reshaping lines and shape outlines
You can reshape lines and shape outlines by dragging, using the straightening and 
smoothing modifiers of the arrow tool, or by optimizing their curves. 

Reshaping using the arrow tool

Flash does not have handles for reshaping lines. Instead, you drag on any point on 
a line using the arrow tool. The pointer changes to indicate what reshaping it can 
perform on the line or fill.
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To reshape a line or shape outline using the arrow tool: 

1 Select the arrow tool.

2 Do the following:

 þ Drag from any point on the segment to reshape it. 

 þ Control-drag (Windows) or Option-drag (Macintosh) a line to create a new 
corner point.

Flash adjusts the curve of the line segment to accommodate the new position of 
the moved point. If the moved point is an end point, you can lengthen or shorten 
the line. If the moved point is a corner, the line segments forming the corner 
remain straight as they become longer or shorter.

When a corner appears next to the pointer, you can change an endpoint. When a curve 
appears next to the pointer, you can adjust a curve.

Some brush stroke areas are easier to reshape if you view them as outlines. See 
“Working with complex drawings” on page 100.

If you are having trouble reshaping a complex line, you can smooth it to remove 
some of its details, making reshaping easier. Increasing the magnification can also 
make reshaping easier and more accurate; see “Optimizing curves” on page 97 or 
“Viewing the Stage” on page 70.

Straightening and smoothing lines

You can reshape lines and shape outlines by straightening or smoothing them. 

Note: Adjust the degree of automatic smoothing and straightening by choosing 
File > Assistant.

Use the Straighten modifier of the arrow tool or choose Modify > Curves > 
Straighten to make small straightening adjustments to lines and curves you 
have already drawn. Straightening has no effect on already straight segments.
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You can also use the straightening technique to make Flash recognize shapes. Flash 
makes geometrically perfect any circles, ovals, rectangles, squares, triangles, and 
arcs you drew with shape recognition options turned off. Shapes that are 
touching, and thus connected to other elements, are not recognized. 

Shape recognition turns the top shapes into the bottom shapes.

Smoothing softens curves and reduces bumps or other variations in a curve’s 
overall direction. Smoothing also reduces the number of segments in a curve. 
Smoothing is relative, however, and has no effect on straight segments. Smoothing 
is particularly useful when you are having trouble reshaping a number of very 
short line segments. Selecting all the segments and smoothing them reduces the 
number of segments, producing a gentler curve that is easier to reshape.

Repeated application of smoothing or straightening makes each segment 
smoother or straighter, depending on how curved or straight each segment 
was originally.

To smooth the curve of each selected fill outline or curved line:

Select the arrow tool and click the Smooth modifier, or choose 
Modify > Curves > Smooth.

To make small straightening adjustments on each selected fill outline or 
curved line:

Select the arrow tool and click the Straighten modifier, or choose 
Modify > Curves > Straighten.

To use shape recognition:

Select the arrow tool and click the Straighten modifier, or choose 
Modify > Curves > Straighten.

Optimizing curves

Another way to smooth curves is to optimize them. This refines curved lines and 
fill outlines by reducing the number of curves used to define these elements. 
Optimizing curves also reduces the size of the Flash movie and the size of exported 
Flash Player movie. As with the Smooth modifier or command, you can apply 
optimization to the same elements multiple times.
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To optimize curves:

1 Select the drawn elements to be optimized and choose 
Modify > Curves > Optimize. 

2 In the Optimize Curves dialog box, use the slider to specify the degree 
of smoothing.

The exact results depend on the curves selected. Generally, optimizing 
produces fewer curves, with less resemblance to the original outline. 

3 Set the additional options:

 þ Turn on Use Multiple Passes to repeat the smoothing process until no further 
optimization can be accomplished; this is the same as repeatedly choosing 
Optimize with the same elements selected.

 þ Turn on Show Totals Message to display an alert box that indicates the extent 
of the optimization when smoothing is complete.

Snapping
The snapping feature helps you draw by automatically aligning elements with 
each other and with the scene grid. If the Snap modifier is on, a small black ring 
appears under the pointer when you drag an element. Flash displays a heavier 
circle when two points can be precisely aligned and snapped.

To turn snapping off and on:

Do one of the following: 

 þ Select the arrow tool and click the Snap modifier in the toolbox. 

 þ Choose View > Snap. A checkmark is displayed next to the command when 
it is on. 

When moving or reshaping elements, the position of the arrow tool on the 
item provides the reference point for the snap ring. For example, if you move 
a filled shape by dragging near its center, the center point snaps to grid lines 
and other items. This is particularly useful for snapping shapes to motion paths 
for animating.

To adjust snapping tolerances:

Choose File > Assistant and choose Snap to Grid from the pop-up menu.

To make sure that Flash snaps to snap points when dragging:

Begin dragging from a corner or center point.
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Creating special curve effects
You can use Lines to Fills, Expand Shape, and the Soften Edges commands to add 
special effects such as filling lines with gradients, or erasing portions of a line, 
expanding filled shapes, and blurring the edges of shapes.

Expand Shape and Soften Edges can produce unexpected results and perform 
slowly on shapes that are very small or have small details. Soften Edges may create 
complex shapes that can quickly increase the file size of a Flash Player movie.

To convert lines to fills:

1 Select a line.

2 Choose Modify > Curves > Lines to Fills.

Selected lines are converted to filled shapes. This is useful for creating special 
effects such as filling lines with gradients or being able to erase a portion of a 
line. Converting lines to fills can make file sizes larger, but may also speed up 
drawing for some animations.

To expand the shape of a filled object:

1 Select a filled shape. This command works best on a single filled color shape 
with no stroke.

2 Choose Modify > Curves > Expand Shape.

3 Set the Distance in pixels and Direction in the Expand Path dialog box. 
Expand enlarges the shape and Inset reduces it.

To soften the edges of an object:

1 Select a filled shape. This command works best on a single filled shape that has 
no stroke.

2 Choose Modify > Curves > Soften Edges.

3 Set the following options:

 þ Distance is the width of the soft edge.

 þ Expand or Inset controls whether the shape will be enlarged or reduced to 
soften the edges.

 þ Number of Steps controls how many curves will be used for the soft edge 
effect. More steps will provide a smoother effect but will also create larger files 
and be slower to draw. 
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Working with complex drawings
As with any other graphics application, working with very complex drawings in 
Flash can slow performance. If your drawing is extremely complex, try drawing it 
in several logical pieces and then assembling those pieces into your final drawing.

Whenever you move lines or fills on the Stage, Flash looks at all of the lines to see 
where they intersect and all of the fills to discard overlaps and calculate for 
connecting lines. Also, when dragging lines or fills, Flash temporarily floats these 
above the Stage. This can take a few moments. Grouping reduces the amount of 
work Flash performs because it doesn’t connect the lines in separate groups.

To speed up screen redrawing:

Choose a display option:

 þ Choose View > Outlines or View > Fast.

 þ Use View > Antialias and View > Antialias Text only to preview your work. 
These options are much slower than View > Outlines and View > Fast.

 þ Use simple line styles when drawing or stroking shapes. Fancy line styles such 
as stipple and hatched can take longer to redraw than simple line styles.

To speed up selecting and moving:

1 Choose the arrow tool and select elements that comprise logical groups.

2 Choose Modify > Group.

To speed up creating fills:

Do any of the following:

 þ Close any gaps manually and use Don’t Close Gaps modifier of the paint 
bucket tool so Flash won’t look for gaps to close.

 þ Zoom in on the specific portion of the drawing you want to fill.

Flash only finds gaps in the visible portion of the window. Choose View > 
Work Area and View > 100% to see the maximum area.
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Working with Objects

Working with objects overview
Flash lets you move, transform, stack, align, and group objects. Note that 
modifying lines and shapes can alter other lines and shapes on the same layer. See 
“Understanding drawing and painting in Flash” on page 77.

Selecting objects
You select an object to modify it. Flash provides a variety of methods for making 
selections. Selecting lines and filled shapes is different than selecting groups, 
instances, and type. 

Flash displays selected lines and filled shapes differently than selected instances 
and groups. Selected fills and lines are cross-hatched. Selected groups and symbols 
are enclosed in a bounding box. You select objects with the arrow and lasso tools.

Unselected 
original shape

Outline 
selected

Fill 
selected

Group 
selected

Outline and 
fill selected
101



To add to a selection:

Hold down the Shift key while making additional selections. For information on 
turning this feature on and off, see “Setting preferences” on page 74.

To select everything on every layer of the scene.

Choose Edit > Select All, or press Control+A (Windows) or Command+A 
(Macintosh). Select All doesn’t select objects on locked or hidden layers.

To deselect everything on every layer.

Choose Edit > Deselect All, or press Control+Shift+A (Windows) or 
Command+Shift+A (Macintosh).

To select everything on one layer between keyframes:

Click a frame in the Timeline. See also “Using the Timeline” on page 59.

To prevent a group or symbol from being selected and accidently changed.

Select it and choose Modify > Arrange > Lock. Choose Modify > Arrange > 
Unlock All to unlock all locked groups and symbols. 

Using the arrow tool

Use the arrow tool to select entire objects by clicking them or by dragging to 
enclose them within a rectangular selection marquee. 

Note: To select the arrow tool you can also press the A key. Temporarily switch to the arrow 
tool when another tool is active by holding down the Control (Windows) or Command 
(Macintosh) key.

To select a line, shape, group, instance, or type block:

Select the arrow tool and click the object.

To select connected lines:

Select the arrow tool and double-click one of the lines.

To select a filled shape and it’s stroked outline:

Select the arrow tool and double-click the fill. 

To select objects with a rectangular area:

Select the arrow tool and drag a box (marquee) around elements with the 
arrow tool. Instances, groups, and type blocks must be completely enclosed to 
be selected.
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Using the lasso tool

Use the lasso tool and its polygon lasso modifier to select objects by drawing either 
a freehand or straight-edged selection area. When using the lasso tool, you can 
switch between the freeform and straight-edged selection modes.

To select objects by drawing a freehand selection area:

Select the lasso tool and drag around the area. End the loop approximately where 
you started, or let Flash automatically close the loop with a straight line.

To select objects by drawing a straight-edged selection area:

1 Select the lasso tool and select the Polygon Lasso modifier.

2 Click to set the starting point.

3 Position the pointer where you want the first line to end, and click. Continue 
setting endpoints for additional line segments.

4 To close the selection area, double-click. 

To select objects by drawing both freehand and a straight-edged selection area:

1 Select the lasso tool and deselect the Polygon Lasso modifier.

2 To draw a freehand segment, drag on the Stage.

3 To draw a straight-edged segment, hold down Alt (Windows) or Option 
(Macintosh) and click to set start and end points. You can continue switching 
between drawing freehand and straight-edged segments.

4 To close the selection area, do one of the following:

 þ If you are drawing a freehand segment, release the mouse button. 

 þ If you are drawing a straight-edged segment, double-click.
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Moving, copying, and deleting objects
You can move objects by dragging them on the Stage, cutting and pasting them, 
by using the arrow keys, and by specifying an exact location in the Object 
inspector. You can also move objects between Flash and other applications by 
using the Clipboard. You can copy objects by dragging or pasting them, or while 
transforming them.

To move an object or a copy of an object by dragging:

1 Select an object. You can also select multiple objects. 

2 Position the pointer over the object and drag to the new position. To move a 
copy of the object, Alt-drag (Windows) or Option-drag (Macintosh). To 
constrain movement of the object multiples of 45°, Shift-drag.

When moving an object, you can use the Snap modifier to quickly align it with 
points on other objects. See “Snapping” on page 98. 

To move an object by using the arrow keys:

1 Select an object. You can also select multiple objects.

2 Press the arrow key for the direction in which you want the object to move by 
1 pixel. Press Shift+arrow key to move the selection by 8 pixels. 

To move an object by using the Object inspector:

1 Select an object. You can also select multiple objects.

2 Open the Object inspector (Window > Inspectors > Object).

3 Enter values for the location of the top left corner of the selection. The units 
are set in Movie Properties and are relative to the top left corner of the Stage.

Moving and copying objects by pasting

Move or copy objects by pasting when you need to move them between layers, 
scenes, or other Flash files. When pasting objects, you can paste them in the center 
of the Stage or in their Stage-relative position.

To move or copy an object by pasting:

1 Select an object or multiple objects.

2 Choose Edit > Cut or Edit > Copy.

3 Select another layer, scene, or file and choose one of the following:

 þ Edit > Paste to paste the selection in the center of the Stage.

 þ Edit > Paste in Place to paste the selection in the same position relative to 
the Stage. 
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Copying artwork with the Clipboard

Elements copied to the Clipboard are antialiased, so they look as good in other 
applications as they do in Flash. This is particularly useful for frames that include 
a bitmap image, gradients, transparency, or a mask layer. 

Graphics pasted from other movies or programs are placed in the current frame of 
the current layer. How a graphic element is pasted into a Flash scene depends on 
the type of element it is, its source, and the preferences you have set as follows:

 þ Text from a text editor becomes a single text object.

 þ Vector-based graphics from any drawing program become a group that can be 
ungrouped and edited like any other Flash element.

 þ Bitmaps become a single grouped object just like imported bitmaps. Choose 
Modify > Trace Bitmap to convert a bitmap to a vector graphic.

Note: Before pasting graphics from FreeHand 8 into Flash, set your FreeHand export 
preferences to convert colors to CMYK and RGB for Clipboard formats. 

Copying transformed objects

You can use the Transform inspector to create a scaled, rotated, or skewed copy of 
an object. 

To copy a transformed object:

1 Select an object.

2 Open the Transform inspector (Window > Inspectors > Transform).

3 Enter scale, rotation, or skew values. See “Scaling objects” on page 107, 
“Rotating objects” on page 108, and “Skewing objects” on page 110.

4 Click Copy. 

Using the Paste Special command (Windows)

The Paste Special command pastes or embeds the Clipboard contents in a 
specified format. It also can create a link to information in another movie. The 
Paste Special dialog box contains the following options:

Source Displays the name of the source data and its location.

Paste Inserts the Clipboard contents into your drawing.

Paste Link Inserts the Clipboard contents into your drawing and creates a link to 
the source application so that the pasted items are updated automatically.
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As Defines the type of information you want to paste. Choose Object to paste an 
object and the information needed to edit the object. The name of the object 
depends on the application that created it. The object can later be converted to an 
editable Flash drawing using Modify > Break Apart.

Choose Picture (Metafile) to paste an image that Flash converts to a form that can 
be edited in Flash. Choose Text (ASCII) to paste unformatted text. Choose Text 
(Native) to paste text with formatting information. Choose Flash Drawing to 
paste a portion of a Flash drawing.

Display As Icon Displays the link as an icon in your drawing.

Result Describes the result of the selection operation.

Change Icon Opens the Change Icon dialog box. Use the options in this dialog 
box to choose a different icon. This option is available only if the Display As Icon 
option is selected.

Deleting objects

Deleting objects removes them from the file. Deleting an instance on the Stage 
does not delete the symbol from the Library. 

To delete objects:

1 Select an object or multiple objects.

2 Do one of the following:

 þ Press Delete or Backspace.

 þ Choose Edit > Clear.

 þ Choose Edit > Cut.

Stacking objects
Within a layer, Flash stacks objects based on the order in which they were created, 
placing the most recently created object on the top of the stack. The stacking 
order of objects determines how they appear when they are overlapping. 

Drawn lines and shapes always appear at the bottom of the stack. To move them 
up the stack, you must group them or make them into symbols. You can change 
the stacking order of objects at anytime. 

Note that layers also affect the stacking order. Everything on layer 1 appears on 
top of everything on layer 2, and so on. To change the order of layers, drag the 
layer name in the Timeline to a new position. See “Layers overview” on page 133.
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To change the stacking order of an object: 

1 Select the object.

2 Choose one of the following commands:

 þ Modify > Arrange > Bring to Front or Send to Back to move the group to the 
top or bottom of the stacking order. 

 þ Modify > Arrange > Move Ahead or Move Behind to move the group up or 
down one position in the stacking order.

If more than one group is selected, they move in front of or behind all unselected 
groups, while maintaining their order relative to each other.

Scaling objects
Scaling an object enlarges or reduces the object horizontally, vertically, or 
horizontally and vertically. You can scale an object by dragging or by entering 
values in the Transform inspector. Scaling an instance, group, or type block scales 
it in relation to its registration point. See “Moving an object’s registration point” 
on page 112.

To scale an object by dragging:

1 Select an object.

2 Select the arrow tool and click the Scale modifier.

3 Do the following:

 þ To scale the object both horizontally and vertically, drag one of the corner 
handles. Proportions are constrained as you scale.

 þ To scale the object horizontally or vertically, drag a center handle.

Note: When you increase the size of a number of items, those near the edges of the 
bounding box can be moved out of the scene. If this occurs, choose View > Work Area to 
see the elements that are beyond the edges of the scene.
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To scale an object with the Transform inspector:

1 Select an object.

2 Choose Window > Inspectors > Transform.

3 Enter a scale value between 10 and 1000, and click Apply. 

Rotating objects
Rotating an object turns it around its registration point. By default, this is the 
center of the object, but you can move it. See “Moving an object’s registration 
point” on page 112. You can rotate an object by dragging or by specifying an angle 
in the Transform inspector. 

To rotate an object by dragging:

1 Select an object. 

2 Select the arrow tool and click the Rotate modifier.

3 Drag one of the corner handles.

To rotate an object by value:

1 Select an object.

2 Do one of the following:

 þ Open the Transform inspector (Windows > Inspectors > Transform), enter a 
rotation angle, and click Apply. Negative values rotate the object 
counterclockwise, positive values rotate it clockwise. 

 þ To rotate the selection 90° clockwise, choose Modify > Transform > 
Rotate Right. 

 þ To rotate the selection 90° counterclockwise, choose Modify > Transform > 
Rotate Left. 
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Flipping objects
You can flip objects across their vertical or horizontal axis without moving their 
relative position on the Stage. 

To flip an object:

1 Select an object.

2 Choose Modify > Transform > Flip Vertical or Flip Horizontal.

Original

Flipped 
vertically

Flipped 
horizontally

Original
Rotated 
left

Rotated 
right
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Skewing objects
Skewing an object transforms it by slanting it along one or both axes. You can 
skew an object by dragging or entering a value in the Transform inspector. 

To skew an object by dragging:

1 Select an object.

2 Click the arrow tool and click the Rotate modifier.

3 Drag a center handle. 

To skew an object by specifying values: 

1 Select an object.

2 Open the Transform inspector (Window > Inspectors > Transform).

3 Click Skew.

4 Enter angles for the horizontal and vertical values, and click Apply. 

Restoring transformed objects
When you scale, rotate, and skew instances, groups, and type with the Transform 
inspector, Flash saves the original size and rotation values with the object. Thus, 
you can restore the original values, removing any transformations.

To restore a transformed object to its original state:

1 Select an object.

2 Open the Transform inspector (Window > Inspectors > Transform).

3 Click Reset.
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Aligning objects
Modify > Align can line up two or more selected items in a scene. Align can resize 
elements so that their horizontal or vertical dimensions are the same. Resized 
elements change to match the dimensions of the largest selected item. Align can 
also distribute elements so their centers, their left or top borders, or their right and 
bottom borders are evenly spaced. Use alignment options individually or in 
combination. The Align to Page option aligns elements to each other and to the 
Stage in one step. 

When aligning several objects, Flash aligns them to the edges or center of the 
rectangle that encloses all the objects. It doesn’t matter in what order you select 
the objects.

Objects aligned to the top object

To align elements:

1 Select the elements to align.

2 Choose Modify > Align.

3 Choose options in the Align dialog box and click OK.
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Grouping objects
Group elements to manipulate them as a single object. For example, after creating 
a drawing such as a tree or flower, group the elements so you can easily select and 
move them. 

You can edit groups without ungrouping them.

To create a group:

1 Select the objects on the Stage you want to group.

You can select shapes, other groups, symbols, text, and so on.

2 Choose Modify > Group, or press Control+G (Windows) or 
Command+G (Macintosh).

To edit a group:

1 Choose Edit > Edit Selected, or double-click the group with the arrow tool.

Everything on the page that is not part of the group is dimmed, indicating it 
is inaccessible. 

2 Edit any element within the group separately.

3 Choose Edit > Edit All, or double-click a blank spot on the stage with the 
arrow tool. 

Flash restores the group to its status as a single entity and you can work with 
other elements on the Stage.

To prevent a group or symbol from being selected and accidently changed:

Select the group and choose Modify > Arrange > Lock. Choose 
Modify > Arrange > Unlock All to unlock all locked groups and symbols. 

Moving an object’s registration point
All groups, instances, type blocks, and bitmaps have a registration point that Flash 
uses for positioning and transformations. By default, this point is located at the 
center of the object. By moving an object’s registration point, you can position 
and transform the object relative to, for example, the object’s lower left corner. 
Note that lines and shapes do not have registration points and are positioned and 
transformed relative to their upper left corner. 
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When editing the registration point of an instance, you’ll often have better results 
if you edit the symbol, and move the artwork in symbol-editing mode such that 
the registration point appears where you’d like it. See “Editing symbols” on 
page 148. 

To edit the registration point of an object:

1 Select an object. 

2 Choose Modify > Transform > Edit Center.

A crosshair representing the center point is highlighted. 

3 Drag the highlighted crosshair to a new location. 

4 Click elsewhere on the page to deselect the crosshair. 

Breaking apart groups and objects
The Modify > Break Apart command separates groups, type blocks, instances, 
bitmaps, and OLE objects into ungrouped editable elements. It significantly 
reduces the file size of imported graphics.

Breaking apart is not entirely reversible, and affects objects as follows:

 þ Severs a symbol instance’s link to its master symbol.

 þ Discards all but the current frame in an animated symbol. 

 þ Converts a bitmap to a fill.

 þ Converts text characters to outlines.

 þ Severs an OLE object’s link to its source application.

The Ungroup command separates grouped elements into discrete components. It 
does not break apart type, bitmaps, or instances. It returns grouped elements to 
the same state they were in prior to grouping. It does not convert type to outlines. 

Note: Breaking apart animated symbols, or groups within an interpolated animation, is not 
recommended and might have unpredictable results. Breaking apart complex symbols and 
large blocks of text can take a long time. You might need to increase the application’s 
memory allocation to properly break apart complex objects.
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Using Type

Using type overview
You can add type to your Flash movies. You can set the size, typeface, style, 
spacing, color, and alignment of type. You can transform type like an object, 
rotating, scaling, skewing, and flipping it, and still edit its characters. You can also 
break type apart and reshape its characters. 

You can also place text in a movie that is editable when the movie is playing. 
Editable text lets users enter text to fill out forms, to customize a game, and so on.

For an interactive introduction to creating type in Flash, choose Help > Lessons > 
5 Type.

Using type in Flash movies
You can use Type 1 PostScript® fonts, TrueType®, and bitmap fonts in your Flash 
movies. Flash exports type to your final movie with all its system information 
intact. Type you create while authoring on one platform may not appear properly 
on other platforms; moreover, your audience must have the type’s font installed 
for it to display properly, even on the same platform. 

You can avoid these potential conflicts by using special fonts in Flash called device 
fonts. Flash includes three device fonts named _sans, _serif, and _typewriter. 
When you set type in these fonts, the Flash Player uses whatever font on the local 
computer that most closely resembles the device font. Device fonts are particularly 
useful for text fields, for large blocks of type where you may not want anti-
aliasing, and for making the published movie smaller because no outlines are 
needed. Breaking apart type to convert characters to shapes also eliminates 
potential conflicts, but it does increase file size. See “Reshaping type” on page 123.
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Not all fonts displayed in Flash can be exported with a movie. A good way to tell 
whether or not a font will export properly is to turn on View > Antialias Text. If 
the type remains jagged, then Flash does not recognize that font’s outline and will 
not export the text.

For additional text-handling capabilities, manipulate text in FreeHand and export 
it as a SWF file. 

Creating type
Use the text tool to place type on the Stage. You can place type on a single line 
that expands as you type or in a fixed-width block that wraps words automatically. 
Flash displays a round handle at the upper right corner of type blocks that extend, 
and a square handle for type blocks with a defined width. 

Flash displays a square handle at the bottom right corner of editable text fields, 
indicating that you can vertically size the text field according to the amount of text 
to be entered.

To create type: 

1 Select the text tool.

2 Use the text tool modifiers to set type attributes as described in “Setting type 
attributes” on page 120.

3 Do one of the following:

 þ To create a type block that widens as you type, click where you want the type 
to start.

 þ To create a type block with a fixed width, position the pointer where you want 
the type to start and drag to the desired width. 

Note: If you create an expanding type block, it can continue past the right edge of the Stage 
as you type. The text isn’t lost. Add line breaks, move the type block, or choose View > 
Work Area to make the handle accessible again. 

Extending type block handle

Fixed type block handle

Text field handle
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To change the width of either kind of type block:

Drag its resize handle.

To remove the width setting from a type block:

Double-click the resize handle.

Creating text fields and editable text
Text fields let you place text in a movie that users can change as the movie is 
playing. This lets you collect information from users for forms or surveys. Text 
fields can also be used to dynamically replace text that is not editable. For 
example, you can display sport scores, stock quotes, or weather reports.

When you create a text field, you assign the field a variable. A variable is a fixed 
name for a value that changes. You can use actions to pass the variable to other 
parts of the movie, to a server-side application for storing in a database, and so on. 
You can also replace the value of a variable by reading it from a server-side 
application or by loading it from another part of the movie. For more on using 
variables, see “Setting and identifying variables” on page 191.

To create a text field:

1 Select the text tool.

2 Click the Text Field modifier.

3 Drag to create the desired width and height of the text field. 

To turn a regular type block into a text field:

1 Select the text tool.

2 Click the text inside a regular text block.

3 Click the Text Field modifier.

The drag handle moves to the bottom right corner and a solid black outline is 
displayed around the type block, indicating that it is a text field.

4 Set text field properties as described in “Setting text field properties” on 
page 118.
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Setting text field properties

Select a text field with either the arrow tool or the text tool and choose Modify > 
Text Field to open the Text Field Properties dialog box.

The Text Field Properties dialog box contains the following options:

Variable Specifies the variable name for the text field. For more information on 
variables, see “Setting and identifying variables” on page 191.

Draw Border and Background Displays a border and background for the text field.

Password Displays only asterisks in the field when a user types it in the published 
movie. These cannot be copied or cut while the movie is playing.

Multiline Enables line breaks when text is entered in the published movie. It has 
no affect in the authoring environment.

Word Wrap Inserts line breaks when text reaches the right margin in the 
published movie.

Restrict Text Length To Limits the number of characters users can enter in the field 
to the number you specify.

Disable Editing Prevents other users from changing the value in the field. Use this 
option when you want to display text dynamically.

Disable Selection Prevents the user from selecting any text in the field.
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Outlines Lets you choose whether you want to save all font outlines, none, or only 
the font outlines you specify with the published movie. You can limit the 
inclusion of font outlines to Uppercase, Lowercase, Numbers, Punctuation, or 
Characters. Choosing these options can help reduce the size of your Flash movie.

Editing text
You can use most common word-processing techniques to edit text in Flash. You 
can use the Cut, Copy, and Paste commands to move type within a Flash file as 
well as between Flash and other applications.

To edit text:

Do one of the following:

 þ With the text tool, click inside a type block or drag over type to highlight 
characters.

 þ With the arrow tool, double-click a type block. 

Selecting text

When editing text or changing type attributes, you must first select the characters 
you want to change.

To select characters within a type block:

1 Select the text tool and click a type block to place the cursor.

2 Do one of the following:

 þ Drag to select characters.

 þ Double-click to select a word.

 þ Click to specify the beginning of the selection and Shift-click to specify the 
end of the selection.

 þ Press Ctrl+A (Windows) or Command+A (Macintosh) to select all the 
characters in the block. 

To select type blocks:

Select the arrow tool and click a type block. Shift-click to select multiple 
type blocks.
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Setting type attributes
Flash gives you control over the type attributes, including font, type size, line 
spacing, kerning, alignment, and color. When creating new type, Flash uses the 
current type attributes. To change the type attributes of existing type, you must 
first select it. 

Choosing a font, type size, and style

A font is an assortment of alphanumeric characters in a particular typeface design. 
You can set the font, type size, and style for selected type using either the text tool 
modifiers or the Font dialog box. Type size is set in points, regardless of the 
current ruler units. 

To choose a font, type size, and style with modifiers:

1 Select the characters you want to change as described in “Selecting text” on 
page 119.

2 If you selected type blocks with the arrow tool, select the text tool.

3 Choose a font from the Font modifier.

4 For type size, choose a size from the Size modifier or type a value.

5 For style, click the Bold or Italic modifiers.

To choose a font, type size, and style with the Font dialog box:

1 Select the characters you want to change as described in “Selecting text” on 
page 119.

2 Choose Modify > Font.

3 Choose a font, type size, and style from the options in the dialog box. 

Font modifier

Font size

Font color swatch

Bold and Italic modifiers

Text alignment modifiers

Text field modifier
Chapter 5120



Setting margins, indents, and line spacing

Margins determine the amount of space between the border of a type block and a 
paragraph of text. Indents determine the distance between the margin of a 
paragraph and the beginning of the first line. Line spacing determines the distance 
between adjacent lines in a paragraph. 

To set margins, indents, and line spacing:

1 Select the characters you want to change as described in “Selecting text” on 
page 119.

2 Choose Modify > Paragraph or click the Paragraph modifier of the text tool.

3 Enter margin, indent, and line spacing values. 

Setting kerning and letter spacing

Kerning is the process of reducing the spacing between certain pairs of letters to 
improve their appearance. Most fonts include information that automatically 
reduces the amount of space between certain letter pairs, such as TA or VA. By 
default, Flash uses a font’s kerning information when displaying type, but you 
may want to turn it off at smaller point sizes.

Letter spacing inserts a uniform amount of space between characters. Use letter 
spacing to adjust the spacing of selected characters or entire blocks of type. 

To disable automatic kerning:

1 Select the characters you want to change as described in “Selecting text” on 
page 119.

2 Choose Modify > Font. 

3 Deselect Kerning. 
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To set letter spacing:

1 Select the characters you want to change as described in “Selecting text” on 
page 119.

2 Do one of the following:

 þ To set letter spacing by value, choose Modify > Font and enter a letter 
spacing value.

 þ To decrease spacing by half a pixel, choose Modify > Kerning > Narrower, or 
press Ctrl+Alt+Left Arrow (Windows) or Command+Option+Left Arrow 
(Macintosh).

 þ To decrease spacing by two pixels, press Shift+Ctrl+Alt+Left Arrow 
(Windows) or Shift+Command+Option+Left Arrow (Macintosh).

 þ To increase spacing by half a pixel, choose Modify > Kerning > Wider, or press 
Ctrl+Alt+Right Arrow (Windows) or Command+Option+Right Arrow 
(Macintosh).

 þ To increase spacing by two pixels, press Shift+Ctrl+Alt-Right Arrow 
(Windows) or Shift-Command-Option-Right Arrow (Macintosh).

 þ To reset spacing to normal, choose Modify > Kerning > Reset, or press 
Control+Alt+Up Arrow (Windows) or Command+Option+Up Arrow 
(Macintosh).

Defining type color

You can set the color of type using either the Color modifier of the text tool or 
with the Color window. You can only use solid colors for type, not gradients. To 
apply a gradient to type, you must break it into its outlines. See “Reshaping type” 
on page 123.

To define type color:

1 Select the characters you want to change as described in “Selecting text” on 
page 119.

2 If you selected type blocks with the arrow tool, click the text tool.

3 Do one of the following:

 þ Position the pointer over the color box and drag to highlight a color in 
the palette. 

 þ Choose Window > Colors and select a color from the Solid tab. 
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Aligning type

Alignment determines the position of each line of type in a paragraph relative to 
the left and right edges of the type block. Type can be aligned to the left or right 
edges of the type block, centered within the type block, or aligned to both the left 
and right edges of the type block (full justification).

To align type:

1 Select the characters you want to change as described in “Selecting text” on 
page 119.

2 Do one of the following:

 þ Choose an alignment option from the Alignment modifier of the text tool.

 þ Choose Modify > Style and choose an alignment option from the submenu. 

Transforming type
You can transform type blocks in the same ways you can other objects. You can 
scale, rotate, skew, and flip type to create interesting effects. When scaling type as 
an object, increases or decreases in the point size are not reflected in the Font 
dialog box. 

The text in a transformed type block can still be edited, although severe 
transformations may make it difficult to read. See “Working with objects 
overview” on page 101. 

Reshaping type
To reshape, erase, and otherwise manipulate type, you convert it to its component 
lines and fills. As with any other shape, you can individually group these 
converted characters, or change them to symbols and animate them. Once you’ve 
converted type to lines and fills, you can no longer edit them as text. 

You can only convert entire type blocks to shapes, not characters within a 
type block. 
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To convert type to its component lines and fills:

1 Select the arrow tool and click a type block. 

2 Choose Modify > Break Apart. The characters in the selected text are 
converted to shapes on the Stage.

Note: Break Apart only applies to outline fonts such as TrueType fonts. Bitmap fonts 
disappear from the screen when you break them apart. PostScript fonts can only be 
broken apart on Macintosh systems running Adobe Type Manager® (ATM®). 
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Using Imported Artwork

Using imported artwork overview
You can use artwork created in other applications in your Flash movies. You can 
import both vector and bitmap graphics. You can trace a bitmap to convert its 
image to a vector graphic and you can paint with the image in a bitmap, letting 
you create patterned effects. 

Placing artwork into Flash
Flash recognizes a variety of bitmap and vector file formats. You can place artwork 
into Flash by importing or pasting. Flash imports bitmaps, sequences of images, 
and vector graphics as follows:

 þ Bitmaps (scanned photographs, BMP files) are imported as a single 
object in the current layer. Flash preserves the transparency settings of 
imported bitmaps.

 þ Any sequence of images (for example, a PICT and BMP sequence) is imported 
as successive frames of the current layer.

 þ Vector images from FreeHand or Adobe Illustrator, and WMF files are 
imported as a group in the current layer. (See “Choosing an import file 
format” on page 127 and “Using Adobe Illustrator files” on page 127.)

Flash can also import sound files in AIFF and WAV format. See “Importing 
sounds” on page 213. For information on specific file formats, see “Choosing an 
import file format” on page 127.
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To import a file into Flash:

1 Choose File > Import. 

2 In the standard import dialog box that is displayed, locate and open the 
desired file.

If an imported file has multiple layers, new layers might be created in Flash. Be 
sure the Timeline is visible when importing a file with multiple layers.

3 If you are importing a file with a name that ends with a number, and there are 
additional files in the sequence after that file in the same folder, at the prompt 
to import the sequence of files click Yes to import all of these files, or click No 
to import only the specified file.

Here are examples of file names that can be used as a sequence:

Frame001.gif     Frame002.gif     Frame003.gif
Bird 1     Bird 2     Bird 3
Walk-001.ai     Walk-002.ai     Walk-003.ai

To paste a bitmap from another application into Flash:

1 Copy the image from the other application.

2 Choose Edit > Paste.

To paste a bitmap into Flash as an embedded object (WIndows):

1 Copy the image from the other application.

2 Choose Edit > Paste Special.

When you want to edit the bitmap, Flash opens the original application. Flash 
can’t rotate an embedded bitmap unless you first select the bitmap and choose 
Modify > Break Apart. See “Grouping objects” on page 112.

Note: Before pasting graphics from FreeHand 8 into Flash, set your FreeHand export 
preferences to convert colors to CMYK and RGB for Clipboard formats.
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Choosing an import file format

Use the following table to determine what image import file types are recognized 
by the platform you are working on.

Using FreeHand files

FreeHand is the best choice for creating vector graphics for import into Flash. 
FreeHand exports layered images that are recognized by Flash. You can exchange 
RGB or CMYK graphics between FreeHand 8 and Flash 4. To convert CMYK 
images to RGB with good color fidelity, import the image into FreeHand and 
then export it as a Flash movie using the Convert Colors to RGB option in 
FreeHand preferences. See the FreeHand Designers Center on the Macromedia 
web site for more information (www.macromedia.com/support/freehand/). To 
copy and paste graphics from FreeHand 8 into Flash, change your FreeHand 
Export Preferences to the CMYK and RGB option. 

Using Adobe Illustrator files

Flash supports importing and exporting Adobe Illustrator® 88, 3.0, 5.0, and 6.0, 
and 7.0 formats. For information on exporting Illustrator files, see “Adobe 
Illustrator” on page 243.

File type Extension Windows Macintosh

Adobe Illustrator (version 6.0 
or lower). See “Using Adobe 
Illustrator files” on page 127.

.eps, .ai ✔ ✔

AutoCAD DXF. See “Using 
AutoCAD DXF files” on 
page 128.

.dxf ✔ ✔

Bitmap .bmp ✔

Enhanced Metafile .emf ✔

FutureSplash Player .spl ✔ ✔

GIF and animated GIF .gif ✔ ✔

JPEG .jpg ✔ ✔

PICT .pct, .pic ✔

PNG .png ✔ ✔

Flash Player .swf ✔ ✔

Windows Metafile .wmf ✔

QuickTime Movie .mov ✔ ✔
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When you import an Illustrator file into Flash, ungroup all the Illustrator objects 
on all layers. Once all the objects are ungrouped, they can be manipulated like any 
other Flash object. 

Using QuickTime movies

When you import a QuickTime movie into Flash, the movie file does not become 
part of the Flash file. Instead, Flash maintains a pointer to the source file. You can 
scale, rotate, and animate a QuickTime movie in Flash. You can play and set the 
path of the movie in the Library.

When you import a QuickTime movie, only the first frame of the movie is 
displayed. For more information on publishing your Flash file as a QuickTime 
movie, see “QuickTime publish settings” on page 239.

To play a QuickTime movie:

1 Add the number of frames on the Timeline that correspond to the length of 
the QuickTime movie you want to play. 

2 Choose Control > Play.

To set the path of a QuickTime movie:

1 Choose Window > Library and select the QuickTime movie you want to edit.

2 On the Options menu, choose Properties and click Set Path in the Video 
Properties dialog box.

3 Enter the new location of the QuickTime movie.

Using AutoCAD DXF files

Flash supports the AutoCAD DXF format in the release 10 version.

DXF files do not support the standard system fonts. Flash tries to map 
fonts appropriately, but the results can be unpredictable, particularly for the 
alignment of text.

Since the DXF format does not support solid fills, filled areas are exported as 
outlines only. For this reason the DXF format is most appropriate for line 
drawings, such as floor plans and maps.

You can import two-dimensional DXF files into Flash. Flash does not support 
three-dimensional DXF files.

Flash doesn’t support scaling in a DXF file. All imported DXF files produce 12-
inch by 12-inch movies that you can scale with Modify > Transform > Scale. Also, 
Flash supports only ASCII DXF files. If your DXF files are binary, convert them 
to ASCII before importing into Flash.
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Tracing bitmaps
Flash imports a bitmap as a single object that behaves just like a group of shapes. 
Use the Trace Bitmap command when you want to keep your file size down, or 
when you want to manipulate the image. The Trace Bitmap command converts a 
bitmap into a vector graphic with editable discrete areas of color. (To edit the 
color of a bitmap that has been broken apart, use the magic wand tool. See 
“Painting with a bitmap’s image” on page 129.) 

To convert a bitmap to a vector graphic:

1 Select a bitmap in the current scene.

2 Choose Modify > Trace Bitmap.

3 Enter a Color Threshold value.

When comparing two pixels, if the difference in the RGB color values is less 
than the color threshold, the two pixels are considered the same color. A high 
threshold value gives you a low number of colors.

4 Enter a value for Minimum Area to set the number of surrounding pixels to 
consider when assigning a color to a pixel.

5 Enter a value for Curve Fit to determine how smoothly outlines are drawn.

6 Enter a value for Corner Threshold to determine whether sharp edges are 
retained or smoothed out.

To create a vector graphic that looks most like the original bitmap, enter the 
following values: Color Threshold, 10; Minimum Area,1 pixel; Curve Fit, Pixels; 
Corner Threshold, Many Corners.

Note: In some cases, the file size of the traced bitmap can exceed the file size of the original 
if the imported bitmap is complex and many vectors are created to match the bitmap. 

Painting with a bitmap’s image
You can use the brush and paint bucket tools to paint with the image in a bitmap. 
This lets you create patterns using the image in a bitmap. You first break apart a 
bitmap into discrete areas of color, and then you sample the bitmap with the 
dropper tool. Once you’ve broken apart a bitmap, you can select ranges of color in 
the bitmap with the magic wand tool. After you select the areas, you can change 
their fill color or delete them.

Once you’ve painted an area or shape with a bitmap image, you can use the paint 
bucket tool to rotate, skew, or scale the bitmap image. See “Using the paint bucket 
tool” on page 85.
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To paint with a bitmap’s image:

1 Select a bitmap in the current scene.

2 Choose Modify > Break Apart. 

The bitmap is now a collection of discrete areas of color. 

3 Select the dropper tool and then click the bitmap.

The dropper tool sets the current fill to the bitmap and changes the active tool 
to the paint bucket.

4 Paint with the brush or paint bucket tool. 

To select ranges of color in a broken apart bitmap with the magic wand tool:

1 Select the bitmap in the scene.

2 Select the lasso tool and click the Magic Wand modifier.

3 Set the magic wand options:

 þ Threshold defines how close the color value of adjacent pixels must be to be 
included in the selection. The higher the number, the more lenient the 
selection. If you enter 0, only pixels of the exact same color as the first pixel 
you click are selected.

 þ Smoothing defines how much to smooth the edges of a bitmap. Options are 
Smooth, Pixels, Rough, and Normal.

4 Click anywhere on the bitmap.

The wand selects areas of color that match the area you click.
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Setting bitmap properties
Use the Bitmap Properties dialog box to enable smoothing of the bitmap and to 
set the export format. To open the Bitmap Properties dialog box, select a bitmap 
in the Library window and click the Propeties button, or choose Properties from 
the Library window’s Options menu. Choose from the following options:

 þ Bitmap information displays the name, location, date, and size of the bitmap.

 þ Preview displays a picture of the bitmap.

 þ Allow smoothing smooths the edges of the bitmap with anti-aliasing.

 þ Update reimports the bitmap file in a movie if changes have been made to 
it externally.

 þ Import opens the Import Bitmap dialog box. Use this dialog box to import a 
new bitmap.

 þ Test shows the results of the file compression. You can compare the original 
file size to the compressed file size.

Choose Export As to set one of the following:

 þ Default exports the file using the default format. Click Test to determine the 
default format.

 þ Lossless exports the file in a compressed format without sacrificing any data 
in the image. 

 þ JPEG exports the file in a compressed JPEG format. JPEG compression can 
vary from high quality (saving a document at low compression, such as 2:1) to 
low quality (saving a document at high compression, such as 100:1). With 
high levels of compression, image quality can suffer. When you Export as 
JPEG, the dialog box prompts you to specify the quality of the compression 
on a scale of 1 to 100.
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Using Layers

Layers overview
You can think of layers as transparent sheets of acetate stacked on top of each 
other. Where there is nothing on a layer, you can see through it to the layers 
below. See “Changing the order of layers” on page 136.

When you create a new Flash movie, it contains one layer. You can add more 
layers to organize the artwork and animation in your movie. The number of layers 
you can create is only limited by your computer’s memory, and layers do not 
increase the file size of your published movie. 

You can draw and edit objects on one layer without affecting objects on another 
layer. In addition, you can use special guide layers to make drawing and editing 
easier, and mask layers to help you create sophisticated effects. 

Use separate layers for sound files and actions. This helps you find all your actions 
and sounds quickly when you need to edit them.

For an interactive introduction to layers, choose Help > Lessons > 4 Layers.

Creating layers
When you create a new layer, it appears above the selected layer. Newly added 
layers become the active layer. 

To create a layer:

Do one of the following:

 þ Choose Insert > Layer.

 þ Click the New Layer button at the bottom of the Timeline. 
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Editing layers
You draw and paint on the active layer. You select a layer to make it active. A 
pencil icon next to a layer’s name indicates the active layer. Only one layer can be 
active at a time.

You can edit objects on any visible, unlocked layer. You can lock layers to protect 
them from changes, and you can hide layers to keep the work area uncluttered. 
You can view objects as outlines in any layer, determine the outline color, and 
change the height of a layer.

To select a layer:

Do one of the following:

 þ Click a layer’s name in the Timeline.

 þ Click a frame in the Timeline.

 þ Select an object on the Stage. 

To select multiple layers:

Shift-click layer names in the Timeline.

To delete a layer:

1 Select a layer.

2 Do one of the following:

 þ Click the Trash button in the Timeline.

 þ Drag the layer to the Trash button.

To copy a layer:

1 Click the layer name to select the entire layer.

2 Choose Edit > Copy Frames.

3 Click the New Layer button to create a new layer.

4 Click the new layer and choose Edit > Paste Frames.

Hidden layer

Objects on layer displayed 
as outlines

Active layer

Locked layer
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To lock or unlock a layer:

Do one of the following:

 þ Click in the Lock column to the right of the layer’s name to lock that layer. 
Click it again to unlock the layer.

 þ Click the padlock icon to lock all layers. Click it again to unlock all layers.

 þ Drag through the Lock column to lock or unlock multiple layers.

 þ Alt-click (Windows) or Option-click (Macintosh) in the Lock column to the 
right of the layer’s name to lock all other layers. Alt-click or Option-click in it 
again to unlock all layers.

Viewing layers

You can show or hide layers as you work. Hidden layers are exported but they 
cannot be edited. You can also display all objects on a layer as colored outlines 
to help you distinguish to which layer objects belong. A red X indicates a 
hidden layer.

The layer containing the logo has a red outline.

To show or hide a layer:

Do one of the following:

 þ Click in the eye column to the right of the layer’s name to hide that layer. 
Click in it again to show the layer.

 þ Click the eye icon to hide all the layers. Click it again to show all layers.

 þ Drag through the Eye column to show or hide multiple layers.

 þ Alt-click (Windows) or Option-click (Macintosh) in the Eye column to the 
right of the layer’s name to hide all other layers. Alt-click or Option-click it 
again to show all layers.
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To view the content of a layer as outlines:

Do one of the following:

 þ Click in the Outline column to the right of the layer’s name to display all 
objects on that layer as outlines. Click in it again to turn off outline display.

 þ Click the outline icon to display objects on all layers as outlines. Click it again 
to turn off outline display on all layers.

 þ Alt-click (Windows) or Option-click (Macintosh) in the Outline column to 
the right of the layer’s name to display objects on all other layers as outlines. 
Alt-click or Option-click in it again to turn off outline display.

Renaming layers

By default, new layers are named by the order in which they are created. Rename 
layers to better reflect their contents.

To rename a layer:

Double-click the layer name and enter a new name.

Changing the order of layers
The order of layers in the Timeline determines how objects overlap on the Stage. 
Objects on layers at the top of the Timeline appear in front of objects on layers 
below them. See also “Stacking objects” on page 106.

To change the order of layers:

Drag layers in the Timeline. 

Using guide layers
For help when drawing, you can use guide layers. You can display a square 
background grid in all scenes or you can create your own aids on any layer and 
designate that layer as a guide layer. Guide layers are indicated by a guide emblem 
that is displayed before the layer name. Guide layers do not appear in a published 
Flash Player movie.

For information on adding a motion guide, see “Tweening motion along a path” 
on page 161.

Guide layer
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To designate a layer as a guide layer: 

Right-click (Windows) or Control-click (Macintosh) and choose Guide from the 
context menu. 

To change a guide layer back to a normal layer:

Select the layer and choose Guide from the context menu for that layer.

Note: Place all guide layers at the bottom of your layer order. This can prevent you from 
accidently dragging a normal layer onto the guide layer thereby turning it into a motion 
guide layer.

Using mask layers
For spotlight effects and transitions, you can create a hole through which the 
content of a layer underneath shows using a mask layer. You can group multiple 
layers together under a single mask layer to create sophisticated effects. You can 
also use any type of animation, except motion paths, to make the mask move. You 
cannot mask layers inside of buttons. 

A mask layer hides everything on the layers linked to the mask layer, except where 
you place a filled object. A filled shape or type object on the mask layer creates a 
hole through which the contents of layers underneath are visible. Mask layers can 
contain only a single shape, instance, or type object. Mask layers provide similar 
functionality to the Paste Inside command in FreeHand.
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To create a mask layer:

1 Create a layer containing the content you want to show through the holes in 
the mask.

2 Make sure that the layer you created is selected and choose Insert > Layer to 
create a new layer above it. 

A mask layer always masks the layer immediately below it, so be sure to create 
the layer in the proper place. 

3 Draw a filled shape, place type, or create an instance of a symbol on the mask 
layer. Flash ignores bitmaps, gradients, transparency, colors, and line styles in a 
mask layer. Any filled area will be completely transparent in the mask; any 
non-filled area will be opaque.

4 Right-click (Windows) or Control-click (Macintosh) the mask layer’s name in 
the Timeline and choose Mask from the context menu.

Flash locks the mask layer and the layer being masked. To edit the mask or 
masked layer, unlock the layer. This turns off the display of the mask. To 
redisplay the mask effect, lock the mask or masked layer.
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To link layers to a mask layer:

Do one of the following:

 þ Drag an existing layer below the mask layer. The layer is indented under the 
mask layer.

 þ Create a new layer under the mask layer. 

 þ Choose Modify > Layer and select Masked in the Layer Properties dialog.

 þ Alt-click (Windows) or Option-click (Macintosh) the layer.

To unlink layers from a mask layer:

Select the layer you want to unlink, and do one of the following:

 þ Drag the layer above the mask layer.

 þ Choose Modify > Layer and select Normal.

 þ Alt-click (Windows) or Option-click (Macintosh) the layer.
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Using Symbols and Instances

Using symbols and instances overview
A symbol is a reusable image, animation, or button. An instance is an occurrence of 
a symbol on the Stage or nested inside another symbol. Symbols can make editing 
a movie simpler as changes to repeating elements need only be made to the 
symbol and Flash updates all instances. 

Using symbols in your movies dramatically reduces file size; saving several 
references to a symbol requires less storage space than saving a complete 
description of the element for each occurrence. For example, you can reduce the 
file size of your movies if you convert static graphics such as background images 
into symbols. Using symbols can also speed movie playback because a symbol 
needs to be downloaded to a browser only once.

For an interactive introduction to using symbols and instances, choose Help > 
Lessons > 3 Symbols. 

A symbol in the library and two instances on the Stage
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Determining which type of symbol to use
Whenever you create a symbol, you must decide how you want to use it in 
the movie. 

 þ Use graphic symbols for static images and to create reusable pieces of 
animation that are tied to the Timeline of the main movie. Interactive controls 
and sounds won’t work in a graphic symbol’s animation sequence.

 þ Use movie clip symbols to create reusable pieces of animation that play 
independently of the main movie’s Timeline. Movie clips are like mini-movies 
inside a main movie that can contain interactive controls, sounds, and even 
other movie clip instances. You can also place movie clip instances inside the 
Timeline of a button symbol to create animated buttons.

 þ Use button symbols to create interactive buttons in the movie that respond to 
standard mouse events (such as clicking and rollovers). Define the graphics 
associated with various button states, then assign actions to an instance of the 
button symbol. See “Assigning actions to buttons” on page 173.

Once you create a symbol, you can make instances of it behave as if they were of 
another type. See “Changing an instance type” on page 152. 

Note: Interactivity and animation in movie clip symbols do not work when you play a movie 
in the Flash authoring environment. To see movie clip animation and interactivity, choose 
Control > Test Movie or Control > Test Scene. See “Previewing and testing movies” on 
page 57.

Creating symbols
You can create a symbol from selected objects on the Stage, or you can create an 
empty symbol and make the content in symbol-editing mode. Symbols can have 
all the functionality that you can create with Flash, including animation. 

Using symbols that have animation, you can create movies with lots of 
movement while minimizing file size. Consider creating animation in a symbol 
when there is a repetitive or cyclic action—the up-and-down motion of a bird’s 
wings, for example. 

To create a new symbol with selected elements:

1 Select elements on the Stage and choose Insert > Create Symbol. 

2 In the Symbol Properties dialog box, type the name of the symbol and choose 
either Graphic, Button, or Movie Clip as the behavior. 

The selected elements become a single object that is an instance of the symbol. 
The elements are also copied to a new symbol in the Library. To edit the 
symbol itself, open it as described in “Editing symbols” on page 148. 
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To create a new empty symbol:

1 Make sure that nothing is selected on the Stage and do one of the following:

 þ Choose Insert > Create Symbol. 

 þ Click the New Symbol button at the bottom of the Library window. 

 þ Choose New Symbol from the Options menu in the Library window.

2 In the Symbol Properties dialog box, type the name of the symbol and choose 
either Graphic, Button, or Movie Clip as the behavior. 

Flash switches to symbol-editing mode. The name of the symbol appears 
above the top left corner of the Stage. The window contains a crosshair that 
represents the symbol’s registration point. If you don’t see the registration 
point, choose View > Show Frame.

3 To create the symbol content, use the Timeline, draw with the drawing tools, 
import media, or create instances of other symbols. 

4 When you have finished creating the symbol content, choose Edit > Edit 
Movie to exit symbol-editing mode. 

Converting animation on the Stage into a movie clip

If you’ve created an animated sequence on the Stage and want to reuse it elsewhere 
in the movie, or if you want to manipulate it as an instance, you can select it and 
save it as a movie clip symbol. 

To convert animation on the Stage into a movie clip:

1 Select every frame in every layer of the animation on the Stage.

2 Right-click (Windows) or Control-click (Macintosh) and choose Copy frames 
from the context menu, or choose Edit > Copy Frames. 

3 Make sure nothing on the Stage is selected and choose Insert > Create Symbol.

4 Name the symbol, select Movie Clip in the Symbol Properties dialog box, and 
click OK.

Flash opens a new symbol for editing in symbol-editing mode.

5 Click the first frame of the Timeline and choose Edit > Paste Frames.

6 Choose Edit > Edit Movie to return to the main movie Stage.

7 Delete the animation from the main movie Timeline by selecting every frame 
in every layer of the animation and choosing Insert > Delete Frame.
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Duplicating symbols

Duplicate a symbol when you want to create a new symbol that contains some or 
all of the content of an existing symbol. 

To duplicate a symbol:

1 Select a symbol in the Library window.

2 Choose Duplicate from the Options menu in the Library window. 

Creating instances
After creating a symbol, you can create instances of the symbol wherever you like 
throughout the movie, including inside other symbols.

Creating movie clip instances is different than creating graphic instances. Movie 
clips need only a single keyframe to play. Graphic instances must be placed in 
every frame where you want them to appear. 

To create a new instance of a symbol:

1 Select a layer in the Timeline. 

Flash can only place instances in keyframes, always on the current layer. If you 
don’t select a keyframe, the instance will be added to the first keyframe to the 
left of the current frame. 

2 Choose Window > Library to open the Library. 

3 Drag the symbol to the Stage.

4 If you created an instance of a graphic symbol, choose Insert > Frame to add 
the amount of frames that correspond to the length of the graphic symbol.

After creating an instance of a symbol, use Instance Properties to specify color 
effects, assign actions, set the graphic display mode, or change the behavior of the 
instance. The behavior of the instance is the same as the default behavior of the 
symbol unless you specify otherwise. These modifications affect only the instance 
and not the symbol. See “Changing the color and transparency of an instance” on 
page 150. See also “Creating interactive movies overview” on page 173.

Note: If a graphic symbol animation appears choppy, you may have to adjust the instance so 
that the animation plays in a smooth loop. See “Synchronizing graphic instances” on 
page 160. 
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Identifying instances on the Stage
As you create a movie, it can be difficult to identify a particular instance of a 
symbol on the Stage, particularly if you are working with multiple instances of the 
same symbol. You can identify instances with the Object inspector (Window > 
Inspectors > Object).

When an instance is selected, the Object inspector displays its location, size, and 
the name of the symbol. For movie clips, it displays the instance name and the 
length of the movie clip. For graphics, it displays the loop mode and the length of 
the symbol in frames. For buttons, it displays the tracking option and any actions 
assigned to the button instance.

A selected button instance and the Object inspector

Creating buttons 
A button is a type of symbol that can display a different image for each of the 
button’s possible states and carry out a specific action when your audience 
interacts with the button using the mouse. You specify the different states of a 
button by creating keyframes in a four-frame Timeline. 

For an interactive lesson on creating buttons in Flash, choose Help > Lessons > 
6 Buttons.

To make a button interactive in a movie, place an instance of the button symbol 
on the Stage and assign actions to the instance. 
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Each frame in the Timeline of a button symbol has a specific function:

 þ The first frame—the Up state—represents the button whenever the pointer is 
not over the button. 

 þ The second frame—the Over state—represents the button’s appearance when 
the pointer is over it. 

 þ The third frame—the Down state—represents the button’s appearance as it 
is clicked.

 þ The fourth frame—the Hit state—defines the area that will respond to the 
mouse. This area is invisible in the movie.

Typical contents of the Up, Over, Down, and Hit frames
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To create a button:

1 Make sure that nothing is selected on the Stage and choose 
Insert > New Symbol, or press Control+F8 (Windows) or Command+F8 
(Macintosh).

2 In the Symbol Properties dialog box, enter a name for the new button symbol 
and choose Button as the Behavior option.

Flash switches to symbol-editing mode. The Timeline header changes to 
display four consecutive frames labeled Up, Over, Down, and Hit. The first 
frame, Up, is a blank keyframe.

3 To create the Up state button image, use the drawing tools, import a graphic, 
or place an instance of another symbol on the Stage.

You can use either a movie clip or graphic symbol in a button, but you cannot 
use another button in a button. Use movie clip symbols if you want to create 
an animated button. 

4 Click the second frame, labeled Over, and choose Insert > Keyframe.

The button image from the first frame appears on the Stage.

5 Change the button image for the Over state; repeat steps 4 and 5 for the 
Down frame and the Hit frame. 

The Hit frame is not visible on the Stage, but it defines the area of the button 
that responds when clicked. Make sure that the graphic for the Hit frame is a 
solid area large enough to encompass all the graphic elements of the Up, 
Down, and Over frames. It can also be larger than the visible button. If you do 
not specify a hit frame, the objects in the Up state are used as the hit frame. 

6 To assign a sound to the Down state of the button, select the Down frame in 
the Timeline, choose Modify > Frame, and then click the Sound tab in the 
Frame Properties dialog box. See “Adding sounds to buttons” on page 218. 

7 When you’ve finished, choose Edit > Edit Movie, and then drag the button 
symbol out of the Library to create an instance of it in the movie.

Enabling, selecting, and testing buttons
Flash lets you control whether buttons are enabled while you author. When a 
button is enabled, it responds to the mouse events that you’ve specified as if the 
movie were playing. When a button is disabled, clicking the button selects it. You 
can still select enabled buttons, however. In general, work with buttons disabled. 
Enable buttons to quickly test their behavior.
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To enable and disable buttons:

Choose Control > Enable Buttons. A check mark appears next to the command to 
indicate buttons are enabled. Choose it again to disable buttons. 

To select an enabled button:

Use the arrow tool to drag a selection rectangle around the button. Use the arrow 
keys to move the button. Choose Modify > Instance to open the Instance 
Properties dialog box and edit the button. 

To test a button: 

Choose Control > Enable Buttons and play the movie. 

Movie clips in buttons are not visible in the Flash authoring environment. See 
“Previewing and testing movies” on page 57. 

Editing symbols
When you edit a symbol, Flash updates all the instances in the movie. You edit 
symbols in symbol-editing mode. You can edit such that the symbol you are 
editing is all that you see, or you can use the Edit in Place command to edit the 
symbol in context with the other objects on the Stage. Other objects appear 
grayed out to distinguish them from the symbol you are editing. 

To edit a symbol in place:

 þ Select an instance of the symbol on the Stage and right-click (Windows) or 
Control-click (Macintosh) and choose Edit in Place.
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To edit a symbol in a new window:

 þ Select an instance of the symbol on the Stage and right-click (Windows) or 
Control-click (Macintosh) and choose Edit in New Window.

 þ Double-click a symbol’s icon in the Library window. 

To edit a symbol in symbol-editing mode:

 þ Select an instance of the symbol on the Stage and choose Edit > Edit Symbol, 
or right-click (Windows) or Control-click (Macintosh) and choose Edit.

 þ Select the symbol in the Library window and choose Edit from the Options 
menu in the Library window.

The symbol attached to the instance opens in symbol-editing mode. You can now 
edit the symbol. All instances of the symbol throughout the movie are updated to 
reflect your edits.

While editing a symbol, use any of the drawing tools, import media, or create 
instances of other symbols.

Return to scene
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To finish editing a symbol and return to editing the movie:

Do one of the following:

 þ Choose Edit > Edit Movie. 

 þ Click the scene name in the left corner of the Timeline.

Changing instance properties
Each instance has its own properties that are separate from the symbol. You can 
change the tint, transparency, and brightness of an instance; redefine the instance 
type (for example, change a graphic to a movie clip); and set the play mode of the 
animation inside a graphic instance. You can also skew, rotate, or scale an instance 
without affecting the symbol.

The properties of an instance are saved with it. If you edit the symbol or relink the 
instance to a different symbol, any instance properties you’ve changed still apply 
to the instance.

The original symbol, a modified instance, and the instance linked to another symbol

Changing the color and transparency of an instance

Use the Color Effect tab in the Instance Properties dialog box to set color and 
transparency options for instances. Settings on the Color Effect tab also affect 
bitmaps placed within symbols. 

Each instance of a symbol can have its own color effect.
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When you change the color and transparency for an instance in a certain frame, 
Flash makes the change as soon as it displays that frame. To make gradual color 
changes, you must tween the color change. When tweening color, you enter 
different effect settings in starting and ending keyframes of an instance, and then 
tween the settings to make the instance’s colors shift over time. See “Tweening 
instances, groups, and type” on page 159.

Note: If you apply a color effect to a movie clip that includes multiple frames, Flash applies 
the effect to every frame in the movie clip. 

To change the color and transparency of an instance:

1 Do one of the following:

 þ Select an instance on the Stage and choose Modify > Instance.

 þ Double-click an instance on the Stage.

2 Click the Color Effect tab.

3 Choose one of the following options from the Color Effect pop-up menu:

 þ Brightness adjusts the relative lightness or darkness of the image, measured on 
a scale from black (-100%) to white (100%). 

 þ Tint colors the instance with the same hue. Use the color picker, or enter red, 
green, and blue values. Use the slider to set the tint percentage. A 100% tint 
means that the instance will be completely saturated with the color. 

 þ Alpha adjusts the transparency of the instance.

 þ Special adjusts separately the red, green, blue, and transparency values in 
an instance. This is most useful when you want to create and animate subtle 
color effects on objects such as bitmaps. The controls on the left let you 
reduce the color or transparency values by a specified percentage. The controls 
on the right let you reduce or increase the color or transparency values by a 
constant value. 

The current red, green, blue, and alpha values are multiplied by the percentage 
values, and then added to the constant values in the right column, producing 
the new color values. For example, if the current red value is 100, setting the 
left slider to 50% and the right slider to 100 produces a new red value of 150 
((100 x .5) + 100 = 150). 

The preview in the upper left corner shows the effect of the changes you make. 
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Replacing an instance with another symbol

Assigning a different symbol to an instance displays a different instance on the 
Stage while leaving all the original instance properties (such as color effects and 
button actions) intact.

To assign a different symbol to an instance:

1 Do one of the following:

 þ Select an instance on the Stage and choose Modify > Instance.

 þ Double-click an instance on the Stage.

2 Click the Definition tab.

3 Select a symbol from the list and click the switch symbol icon.

To duplicate a selected symbol, click the duplicate symbol icon.

4 Close the Instance Properties dialog box to apply the changes.

Changing an instance type

You can change the type of a instance to redefine its behavior in the movie. For 
example, if a graphic instance contains animation that you decide you want to 
play independently of the main movie’s Timeline, you could redefine it as a movie 
clip instance.

To change the type of an instance:

1 Do one of the following:

 þ Select an instance on the Stage and choose Modify > Instance.

 þ Double-click an instance on the Stage.

2 Click the Definition tab.

3 In the Behavior area, select a different behavior.

4 Close the Instance Properties dialog box to apply the changes.
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Setting the play mode of an animated graphic instance

Set play mode options to determine how animation sequences inside a graphic 
instance play during the movie.

To set the play mode of a graphic instance:

1 Do one of the following:

 þ Select a graphic instance on the Stage and choose Modify > Instance.

 þ Double-click a graphic instance on the Stage.

2 Click the Definition tab.

3 Choose a play mode:

 þ Loop loops all the animation sequences contained in the current instance for 
as many frames as the instance occupies.

 þ Play Once plays the animation sequence beginning from the frame 
you specify. 

 þ Single Frame displays one of any frame of the animation sequence.

4 Enter a frame number in the First Frame field to set the first frame of the 
animation sequence for all three play modes.

5 Close the Instance Properties dialog box to apply the changes.

Breaking apart instances
Break apart an instance to sever its link to its symbol and make it into a 
collection of ungrouped shapes and lines. This is useful if you want to 
substantially change the instance, but you don’t want to affect the symbol itself or 
any of its other instances.

To break apart an instance of a symbol:

1 Select the instance.

2 Choose Modify > Break Apart.

This breaks the instance into its component graphic elements.

3 Use the painting and drawing tools to modify these elements.

Breaking apart an instance changes only that instance without affecting other 
instances of that symbol. If you modify the source symbol after breaking apart 
the instance, the instance is not updated with the changes. 
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Using symbols from other movies
You can display the Library of another movie without opening that movie, 
and you can use symbols from any other movie library in the current movie. 
Sometimes it’s useful to replace a symbol in the current movie with an 
updated version from another movie without having to reposition all its 
instances on the Stage. 

To use a symbol from another movie in the current movie:

1 Choose File > Open as Library and select a movie. 

The movie’s library appears in its own Library window. Commands on the 
Options menu and the icons in the left corner are grayed-out indicating that 
they are unavailable.

2 Drag the symbol from the Preview window into the current scene.

Flash creates an instance of the symbol on the Stage and copies the symbol 
itself into the library of the current movie. It is also still available as a symbol 
in the Library of its original movie.
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Creating Animation

Creating animation overview
You create animation by changing the content of successive frames. You can make 
an object move across the Stage, increase or decrease in size, rotate, change color, 
fade in or out, or change shape. Changes can occur independent of, or in concert 
with other changes. For example, you can make an object rotate and fade in as it 
moves across the Stage. 

There are two methods for creating an animation sequence in Flash: frame-by-
frame animation and tweened animation. In frame-by-frame animation you create 
the image in every frame. In tweened animation, you create starting and ending 
frames and let Flash create the frames in between. Every frame where something 
on the Stage changes is a keyframe. Frame-by-frame animation increases file size 
much more rapidly than tweened animation. 

For an interactive introduction to animation, choose Help > Lessons > Lesson 7 
Animation.

Creating keyframes
A keyframe is a frame where you define changes in the animation. When you 
create frame-by-frame animation, every frame is a keyframe. In tweened 
animation, you define keyframes at important points in the animation and let 
Flash create the content of frames in between. Flash displays the interpolated 
frames of a tweened animation as light blue or green with an arrow drawn 
between keyframes. 

Keyframes appear within a frame as a solid circle. Empty keyframes appear as 
hollow circles. The first frame in every layer is automatically a keyframe. The 
contents of a keyframe appear in new frames that you add to a layer. 
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To create a keyframe: 

Do one of the following:

 þ Select a frame and choose Insert > Keyframe.

 þ Right-click (Windows) or Control-click (Macintosh) a frame in the Timeline 
window and choose Insert Keyframe.

To create a series of keyframes:

Select a range of frames and choose Insert > Keyframe.

Distinguishing animations in the Timeline

Flash distinguishes tweened animation from frame-by-frame animation in the 
Timeline as follows:

 þ Motion-tweened keyframes have a black dot and intermediate tweened frames 
have a black arrow with a light blue background.

 þ Shape-tweened keyframes have a black dot and intermediate frames have a 
black arrow with a light green background.

 þ A dashed line indicates a problem with a tween.

 þ Single keyframes have black dots. Light-gray frames after a single keyframe 
contain the same content with no changes.

 þ An empty keyframe has a hollow black dot. 

 þ A small a indicates that the frame has been assigned a frame action with the 
Frame Properties dialog box. 

 þ A red flag indicates that the frame contains a label or comment.
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Animating with layers
Each scene in a Flash movie can consist of any number of layers. As you animate, 
use layers to organize the components of an animation sequence and to separate 
animated objects so they don’t erase, connect, or segment each other. If you want 
Flash to tween the movement of several groups or symbols at once, each must be 
on a separate layer. Typically, the background layer contains static artwork. 
Additional layers contain one separate animated object each.

Layers appear as rows in the Timeline.

When a movie has several layers, tracking and editing the objects on one or two of 
them can be difficult. This task is easier if you work with the content layer by 
layer. See “Layers overview” on page 133.

Setting a frame rate
A frame rate that’s too slow makes the animation appear to stop and start; a frame 
rate that’s too fast blurs the details of the animation. Choose a frame rate of 12 
frames per second (fps) for the best results on the web. QuickTime and AVI 
movies are generally 12 fps, while the standard motion-picture rate is 24 fps. 

The complexity of the animation and the speed of the computer on which the 
animation is being played affect the smoothness of the playback. Test your 
animations on a variety of machines to determine optimum frame rates.

Because you specify only one frame rate for the entire Flash movie, it is a good 
idea to set this rate before you begin creating animation. See “Creating a new 
movie and setting its properties” on page 56.

Extending still images
When creating a background for animation, it’s often necessary to make a still 
image span several frames. Adding new frames (not keyframes) to a layer 
duplicates the contents of the last keyframe in all the new frames. 
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To extend a still image through multiple frames:

1 Create an image in the first keyframe of the sequence.

2 Select a frame as many frames to the right as you want to add. 

3 Choose Insert > Frame.

To use a shortcut to extend still images:

1 Create an image in the first keyframe.

2 Control-drag (Windows) or Command-drag (Macintosh) the frame to the 
right for as many frames as you need. Each time you drag to the right, a 
keyframe is added at the end of the new frames.

About tweened animation
Flash can create two types of tweened animation. In the first, called motion 
tweening, you define properties such as position, size, and rotation for an instance, 
group, or type block at one point in time, and then you change those properties at 
another point in time. In the second, called shape tweening, you draw a shape at 
one point in time, and then you change that shape or draw another shape at 
another point in time. Flash interpolates the values or shapes for the frames in 
between, creating the animation. 

Tweened animation is an effective way to create movement and changes over time 
while minimizing file size. Unlike frame-by-frame animation, Flash only needs to 
store the values for the changes between frames, not the entire frame.
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Tweening instances, groups, and type
Use motion tweening to tween the changes in properties of instances, groups, and 
type. Flash can tween position, size, rotation, and skew of instances, groups, and 
type. Additionally, Flash can also tween the color of instances and type creating 
gradual color shifts or making an instance fade in or out. To tween the color of 
groups or type, make them into symbols. If you tween an object that is not a 
symbol, Flash automatically converts it to a symbol and names it tween1, tween2, 
tween3, and so on. See “Creating instances” on page 144.

When tweening position, you can make the object move along a non-linear path. 
See “Tweening motion along a path” on page 161.

The position and size of the spacecraft in the three tween frames was tweened 
from the first and last keyframes.

To motion tween an instance, group, or type block:

1 Select an empty keyframe, draw an object on the Stage, or drag an instance of 
a symbol from the Library window.

2 Choose Insert > Create Motion Tween. If you drew the object, Flash 
automatically converts it to a symbol and names it tween1, tween2, and so on. 

3 Insert a range of frames over which you want the animation to occur by 
choosing Insert > Frame where you want the animation to end.

4 Move the object, instance, or type block on the Stage to the desired position. 
A keyframe is automatically added to the end of the frame range.

5 To set motion tweening properties, double-click the keyframe at the end of the 
motion tween:

 þ To tween the size of a group or symbol, turn on Tween Scaling.
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 þ To make the group or symbol rotate, choose an option from the Rotate list 
and enter the number of rotations in the box on the right. If you don’t enter a 
number, no rotation occurs. Automatic rotates the object in the direction 
requiring the least motion. Clockwise or Counterclockwise make the object 
rotate as indicated, as many times as you specify.

 þ To orient the base line of the group or symbol to a path, turn on Orient to 
Path Direction. See “Tweening motion along a path” on page 161.

 þ To change the Easing settings, drag the Easing slider toward Ease In to 
slow the beginning of a transition, or toward Ease Out to slow the end of 
the transition. 

The closer the slider is to the end of its range in either direction, the more 
pronounced the acceleration or deceleration. When the slider is closer to In, 
the change begins slowly and gets faster at the end. With easing left in the 
middle, tweening occurs at a regular rate through all frames. By default, the 
rate of change through tweened frames is constant. Easing creates a more 
natural appearance of acceleration or deceleration in motion by decreasing the 
rate of change toward the beginning or ending frames of the tween.

 þ To ensure that the instance loops properly in the main movie, select 
Synchronize Symbols. For more information, see “Synchronizing graphic 
instances” on page 160.

 þ To automatically snap the instance you are animating to a motion guide, select 
Snap to Guide.

6 To tween the colors of an instance, double-click the instance and modify color 
properties as described in “Changing the color and transparency of an 
instance” on page 150. Flash automatically adds a new keyframe each time 
you double-click the instance at tweened frames.

If you change the number of frames between the two keyframes, or move 
the group or symbol in either keyframe, Flash automatically tweens the 
frames again.

Synchronizing graphic instances

If the number of frames in the animation sequence inside the symbol is not 
an even multiple of the number of frames the graphic instance occupies in the 
movie, you may have to synchronize the instance so that it loops properly in the 
main movie. 
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To synchronize a graphic instance:

1 Select all frames (including the start and end keyframes) containing the 
animation in the main movie Timeline.

2 Do one of the following:

 þ Right-click (Windows) or Control-click (Macintosh) and choose 
Synchronize Symbols. 

 þ Choose Modify > Frame. In the Frame Properties dialog box, click the 
Tweening tab and select Synchronize Symbols.

Tweening motion along a path
Motion guide layers let you draw paths along which tweened instances, groups, or 
type blocks can be animated. You can link multiple layers to a motion guide layer 
to have multiple objects follow the same path. A normal layer that is linked to a 
motion guide layer becomes a guided layer type.
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To create a motion path for a tweened animation:

1 Create a tweened animation sequence as described in “Tweening instances, 
groups, and type” on page 159.

2 Do one of the following:

 þ Choose Insert > Motion Guide.

 þ Right-click (Windows) or Control-click (Macintosh) and choose Add Motion 
Guide from the context menu.

Flash creates a new layer above the selected layer with a motion guide icon to 
the left of the layer name.

3 Use the pencil, line, circle, rectangle, or brush tool to draw the desired path.

If you have Snap to Guide selected on the Tweening tab of the Frame 
Properties dialog, the group or symbol is automatically attached to the path by 
its registration point. 

Snap the center to beginning of the line in the first frame, and the end of the line in 
the last frame.

4 To hide the motion guide layer and the line so that only the object’s 
movement is visible when the animation is played, click in the Eye column on 
the motion guide layer.

The group or symbol follows the motion path when you play the animation. 

5 To change the orientation of the group’s or symbol’s baseline so that it remains 
parallel with the motion path, double-click the first keyframe of the tweened 
sequence, click the Tweening tab in the Frame Properties dialog box, and then 
select Orient to Path Direction. 
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To link layers to a motion guide layer:

Do one of the following:

 þ Drag an existing layer below the motion guide layer. The layer is indented 
under the motion guide layer. All objects on this layer automatically snap to 
the motion path.

 þ Create a new layer under the motion guide layer. Objects you tween on this 
layer are automatically tweened along the motion path.

 þ Choose Modify > Layer and select Guided in the Layer Properties dialog.

 þ Alt-click (Windows) or Option-click (Macintosh) the layer.

To unlink layers from a motion guide layer:

Select the layer you want to unlink, and do one of the following:

 þ Drag the layer above the motion guide layer.

 þ Choose Modify > Layer and select Normal as the layer type.

 þ Alt-click (Windows) or Option-click (Macintosh) the layer.

Tweening shapes
By tweening shapes you can create an effect similar to morphing, making one 
shape appear to change into another shape over time. Flash can also tween the 
location, size, and color of shapes. 

Flash can shape-tween as many shapes as you place on a layer, but placing a single 
shape on each layer usually produces the best results. Use shape hints to control 
more complex or improbable shape changes. Shape Hints control how parts of the 
original shape move into the new shape. See “Using shape hints” on page 165.
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To tween a shape:

1 Click a layer name to make it the current layer and select an empty keyframe 
in the layer where you want the animation to start. 

2 Create the image for the first frame of the sequence.

Use any of the drawing tools to create a shape. The shapes you want to tween 
must be on the same layer. Flash cannot tween the shape of groups, symbols, 
text blocks, or bitmap images.

3 Create a second keyframe the desired number of frames after the first frame.

4 Create the image for the last frame of the sequence.

In addition to changing the shape, you can also change the color and position.

5 Double-click the first keyframe in the sequence to open the Frame Properties 
dialog box. Or select the keyframe at the beginning of the sequence and 
choose Modify > Frame.

6 Click the Tweening tab in the Frame Properties dialog box and choose Shape 
from the Tweening pop-up menu.

7 Choose an option for Blend Type:

 þ Distributive creates an animation in which the intermediate shapes are 
smoother and more irregular.

 þ Angular creates an animation that preserves apparent corners and straight lines 
in the intermediate shapes. Angular is appropriate only for blending shapes 
with sharp corners and straight lines. If the shapes you choose do not have 
corners, Flash reverts to Distributive shape tweening.

8 Set the Easing slider.

Drag the Easing slider toward Ease In to slow the beginning of a transition, or 
toward Ease Out to slow the end of the transition. The closer the slider is to 
the end of its range in either direction, the more pronounced the acceleration 
or deceleration. When the slider is closer to In, the change begins slowly and 
gets faster at the end. With easing left in the middle, shape tweening occurs at 
a regular rate through all frames. By default, the rate of change through 
tweened frames is constant. Easing creates a more natural appearance of 
acceleration or deceleration in motion by decreasing the rate of change toward 
the beginning or ending frames of the tween.
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Using shape hints

Use shape hints to control more complex or improbable shape changes. Shape 
hints identify points that should correspond in starting and ending shapes. For 
example, if you were tweening a drawing of a face as it changes expression, you 
could use a shape hint to mark each eye. Then, instead of turning the face into an 
amorphous tangle while the shape change takes place, each eye remains 
recognizable and changes separately during the shift. 

Shape hints contain letters (a through z) for identifying which ones correspond in 
the starting and ending shape. You can have up to 26 shape hints.

Shape hints are yellow in a starting keyframe, and green in an ending keyframe. 
Also, they are red when not on a curve.

For best results when tweening shapes, follow these guidelines:

 þ In complex shape tweening, create intermediate shapes and tween them 
instead of just defining a start and end shape. 

 þ Make sure that shape hints are logical. For example if, three shape hints are 
along a line, they must be in the same order on both lines. They cannot be 
ABC in the first keyframe and ACB in the second. 

 þ Shape hints work best if you place them in counter-clockwise order beginning 
at the top left corner of the shape. 
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To use shape hints:

1 Select the first keyframe in a shape tweened sequence. 

2 Choose Modify > Transform > Add Shape Hint, or press Control+H 
(Windows) or Command+H (Macintosh). 

The beginning shape hint appears as a red circle with the letter a somewhere 
on the shape.

3 Move the shape hint to a point that you want to mark.

4 Select the last keyframe in the tweening sequence. 

The ending shape hint appears somewhere on the shape as a green circle with 
the letter a.

5 Move the shape hint to the point in the ending shape that should correspond 
to the first point you marked.

6 Run the movie again to see how the shape hints change the shape tweening. 
Move the shape hints to fine-tune the tweening. 

7 Repeat this process to add additional shape hints. New hints appear with the 
letters that follow (b, c, and so on). 

8 While working with shape hints, you can also do the following:

 þ To see all shape hints, choose View > Show Shape Hints. The layer and 
keyframe that contains shape hints must be current for Show Shape Hints to 
be available. 

 þ To remove a shape hint, drag it off the Stage. 

 þ To remove all shape hints, choose Modify > Transform > Remove All Hints.

Creating frame-by-frame animations
Frame-by-frame animation changes the contents of the Stage in every frame and is 
best suited to complex animation in which an image changes in every frame 
instead of simply moving. Frame-by-frame animation increases file size more 
rapidly than tweened animation. 

Use frame-by-frame animation when you need to change an image in each frame.
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To create frame-by-frame animation:

1 Click a layer name to make it the current layer and select a frame in the layer 
where you want the animation to start. 

2 If the frame isn’t already a keyframe, choose Insert > Keyframe to make it one.

3 Create the image for the first frame of the sequence.

You can use the drawing tools, paste graphics from the Clipboard, or 
import a file. 

4 Click the next frame to the right in the same row and choose Insert > 
Keyframe, or right-click (Windows) or Control-click (Macintosh) and choose 
Insert Keyframe from the Frame pop-up menu.

This adds a new keyframe whose contents are the same as the first keyframe.

5 Alter the contents of this frame on the Stage to develop the next increment of 
the animation.
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6 To complete your frame-by-frame animation sequence, repeat steps 4 and 5 
until you have built the motion you want. It is often useful to play back 
animation occasionally as you go.

7 To test the animation sequence, choose Control > Play or click the Play button 
on the Controller.

Editing animation
After you create a frame or a keyframe, you can move it elsewhere in the current 
layer or to another layer, remove it, and make other changes. Only keyframes are 
editable. You can view tweened frames, but you can’t edit them directly. Edit 
tweened frames by changing one of the defining keyframes or by inserting a new 
keyframe between the beginning and ending keyframes. You use onion-skinning 
to display and edit more than one frame at a time. 

To edit a frame or keyframe:

Do one of the following:

 þ To copy frames and their contents, select a frame or sequence of frames and 
choose Edit > Copy Frames.

 þ To place copied frames elsewhere in the animation, select the frame where the 
frames will be pasted or highlight a sequence of frames that the pasted frames 
will replace, and choose Edit > Paste Frames.

 þ To move frames and their contents, select the entire sequence of frames on a 
layer, and drag them to the desired location. 

 þ To change the length of a tweened sequence, drag any keyframe left or right. 
To change the length of a frame-by-frame sequence, see “Creating frame-by-
frame animations” on page 166.

 þ To insert new frames in an animation, choose Insert > Frame.

 þ To delete frames, select a sequence of frames and then right-click (Windows) 
or Control-click (Macintosh) within the selected frames, and choose Delete 
Frame from the context menu. 

 þ To create a new empty keyframe, choose Insert > Blank Keyframe. 

 þ To reverse an animation sequence, select the appropriate frames in one 
or more layers and choose Modify > Frames > Reverse. There must be 
keyframes at the beginning and end of the sequence.

 þ To convert a keyframe back into a frame, select the keyframe and choose 
Edit > Clear Keyframe. The existing contents of the frame are replaced by 
copies of the previous keyframe.
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Onion-skinning

Normally, Flash displays one frame of the animation sequence at a time on the 
Stage. To help you position and edit a frame-by-frame animation, you can see 
multiple frames on the Stage at once. The frame under the playhead appears in 
full color, while surrounding frames are dimmed, making it appear as if each 
frame were drawn on a sheet of translucent onion-skin paper and the sheets were 
stacked one on top of another. Dimmed frames cannot be edited.

To simultaneously see several frames of an animation on the Stage:

Click the Onion Skin button. All frames between the Start Onion Skin and End 
Onion Skin markers (in the Timeline header) are superimposed as one frame in 
the Movie window. 
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To use onion skinning:

Use the following controls:

 þ To display onion skinned frames as outlines, click Onion Skin Outlines.

 þ To change the position of either onion skin marker, drag its pointer to a new 
location. (Normally, the onion skin markers move in conjunction with the 
current frame pointer.)

 þ To enable editing of all frames between onion skin markers, click Edit 
Multiple Frames. Usually onion skinning lets you edit only the current frame. 
However, you can display the contents of each frame between the onion skin 
markers normally, and make each available for editing, regardless of which is 
the current frame.

Note: Locked layers (those with a Lock icon) aren’t displayed when onion skinning is turned 
on. To avoid a multitude of confusing images, you can lock or hide the layers you don’t want 
onion skinned.

To change the display of onion skin markers:

Choose an option from the Modify Onion Markers context menu:

 þ Always Show Markers displays the onion skin markers in the Timeline header 
whether or not onion skinning is on.

 þ Anchor Onion Marks locks the onion skin markers to their current position in 
the Timeline header. Normally, the Onion Skin range is relative to the current 
frame pointer and the Onion Skin markers. By anchoring the Onion Skin 
markers, you prevent the Onion Skin markers from moving with the current 
frame pointer.

 þ Onion 2 displays two frames on either side of the current frame.

 þ Onion 5 displays five frames on either side of the current frame.

 þ Onion All displays all frames on either side of the current frame.
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Moving an entire animation

If you need to move an entire animation on the Stage, you must move the 
graphics in all frames and layers at once to avoid realigning everything. 

To move the entire animation to another location on the Stage:

1 Unlock all layers.

To move everything on one layer but nothing on other layers, lock or hide all 
the layers you don’t want to move.

2 Click the Edit Multiple Frames button.

3 Drag the onion skin markers so that they enclose all the frames you want 
to select, or click Modify Onion Markers and choose Onion All.

4 Choose Edit > Select All.

5 Drag the entire animation to the new location on the Stage.
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Creating Interactive Movies

Creating interactive movies overview
An interactive movie involves your audience. Using the keyboard, the mouse, or 
both, your audience can jump to different parts of movies, move objects, enter 
information in forms, and perform many other interactive operations. 

You create interactive movies by setting up actions—sets of instructions that run 
when a specific event occurs. The events that can trigger an action are either when 
the playhead reaches a frame, or when the user clicks a button or presses keys on 
the keyboard. You create instructions that tell Flash what action to perform when 
the event occurs. 

Actions are set up in the Actions tab of the Properties dialog box for either a 
button or a frame (graphics and movie clips do not have the Actions tab available).

The instructions can be a single statement that tells a movie to stop playing or 
a series of statements that first evaluate a condition before performing an action. 
Many actions require little programming experience. Other actions require some 
familiarity with programming languages and are only for truly sophisticated 
development. 

Assigning actions to buttons
Assign an action to an instance of a button to have the action run when the user 
clicks or rolls over a button. Assigning an action to a button instance doesn’t affect 
other instances of the button. 

When assigning an action to a button, you specify the mouse events that trigger 
the action. You can also assign a keyboard key that triggers the action. 
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To assign an action to a button:

1 Select a button instance and choose Modify > Instance, or double-click the 
button instance. 

2 Click the Actions tab.

3 Click the + (plus) and choose a statement from the pop-up menu. 

If the Actions tab is not available, the selected instance is not a button. You 
can click the Definition tab and make the selected instance behave as a button, 
but the instance probably will not have the special button states associated 
with it. See “Creating buttons” on page 145.

When you choose a statement, Flash automatically inserts an On/End On 
statement and sets Release as the default button state. You can also select On 

MouseEvent to insert an On/End On statement. 
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4 In the Parameters pane, with the On (Release) statement highlighted, select 
which mouse and keyboard events trigger the action:

Press Occurs when the mouse button is pressed while the pointer is over 
the button.

Release Occurs when the mouse button is released while the pointer is over 
the button. This sets up standard clicking behavior. 

Release Outside Occurs when the mouse button is released while the pointer is 
outside the button. 

Roll Over Occurs when the pointer rolls over the button.

Roll Out Occurs when the pointer rolls outside the button.

Drag Over Occurs after the mouse button has been pressed while the pointer is 
over the button, rolled outside the button, and then the pointer is rolled back 
over the button.

Drag Out Occurs when the mouse button is pressed over the button and the 
pointer then rolls outside the button.

Key Press Occurs when the specified key is pressed. 

5 Click the + (plus) and choose a statement from the pop-up menu. 

Depending on the action you choose, the Parameters pane can offer additional 
parameters for the statement. For information about a specific statement, see 
the topics later in this chapter. You can also look up specific statements in 
the Index. 

If you are familiar with basic programming techniques, you can enter 
parameters that Flash can evaluate when the movie is playing. See “Writing 
expressions” on page 196.

6 Assign any additional statements that you want. 

Flash inserts the statement below the currently selected action. Use the up and 
down buttons to change the order of statements. 

To test a button:

Choose Control > Enable Buttons before playing the movie. 
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Assigning actions to a frame
Assign a frame action to a keyframe to make the movie do something when it 
reaches that frame. For example, to create a loop within a movie, you could add a 
frame action to frame 20 that specifies “go to frame 10 and play.” 

It’s a good idea to place frame actions in a separate layer. Frames with actions 
display a small a in the Timeline.

To assign an action to a keyframe:

1 Select a keyframe in the Timeline and choose Modify > Frame, or double-click 
a keyframe. 

If a keyframe is not selected, the action is assigned to the previous keyframe.

2 Click the Actions tab, and then click the + (plus) and then choose a statement 
from the pop-up menu.

Depending on the action you choose, the Parameters pane can offer additional 
parameters for the statement. For information about a specific statement, see 
the topics later in this chapter. You can also look up specific statements in 
the Index. 

If you are familiar with basic programming, you can specify parameters as 
expressions that Flash evaluates when the movie plays. See “Writing 
expressions” on page 196.

3 Assign additional statements to make more than one thing happen when the 
frame is displayed. 

Flash inserts a new statement below the currently selected statement. Flash 
executes statements in the order they appear. Use the up and down buttons to 
change the order of actions.

To test a frame action in a scene: 

Choose Control > Enable Frame Actions before playing the movie.
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Editing actions
Use the controls in the Actions pane of the Instance Properties dialog box 
to delete or change the order and parameters of statements. These controls 
are especially useful for managing frame or button actions that have several 
statements. 

To move the statement up or down the list:

Click the Up or Down arrow buttons.

To delete an action:

Click the - (minus) button.

To change the parameters of existing actions:

Enter new values in the Parameters pane.

Playing and stopping movies
Unless instructed otherwise, once a movie starts, it plays through every frame in 
the Timeline. Use the Play and Stop statements to stop or start a movie at specific 
intervals. For example, you can stop a movie at the end of a scene before 
proceeding to the next scene. Once stopped, a movie must be explicitly started 
again. You must use the Play statement to restart the movie.

Play and Stop are most commonly used to control movie clips with buttons. To do 
so, however, the movie clip must have an instance name and must be targeted 
with Tell Target. See “Controlling other movies and movie clips” on page 185.

Adjusting movie display quality
Use the Toggle High Quality statement to turn anti-aliasing for a movie on and off. 
With anti-aliasing off, the movie plays faster. Toggle High Quality affects all the 
movies playing back in the Flash Player. 

Delete a statement

Change the statement order

Add a statement
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A Toggle High Quality statement assigned to a button lets the audience adjust the 
playback quality of the movie. The following action turns anti-aliasing off with 
the first click, and turns it on with the second.

On(Press)
Toggle high quality

End On

You can also use the _highquality property as described in “Global properties” on 
page 202.

Stopping all sounds
Use the Stop All Sounds statement to stop the audio track without interrupting the 
movie Timeline (this does not simply suppress the volume). Stop All Sounds affects 
all the movies playing back in the Flash Player. 

Assign Stop All Sounds to a button to let your audience stop the sounds in a 
playing movie. 

Jumping to a frame or scene
Use the Go To statement to jump to a specific frame or scene in the movie. When 
the movie jumps to a frame, you have the option of stopping the movie at the new 
frame or playing from the frame. The default behavior is to jump to a frame and 
stop the movie. 

The Go To statement has the following parameters:

 þ Scene specifies a destination scene. If you select the current scene or a named 
scene, you can specify a frame within that scene. If you select the next or 
previous scene, the movie jumps to the first frame of the scene. 

 þ Frame specifies a frame within the current scene or a named scene specified 
with the Scene option. You can enter a frame by number, label, or an 
expression that evaluates to a frame number or label. You can also specify the 
next or previous frame. For example, this statement indicates the frame that is 
five frames ahead of the frame that contains the action:

Go to and Stop(_currentframe + 5)

For information on writing expressions, see “Writing expressions” on 
page 196.

 þ Go To and Play instructs the movie to continue playing from the specified 
frame. When this option is off, the movie stops at the specified frame.
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Jumping to a different URL
Use the Get URL statement to load a document from a specific URL into a specific 
window, or to pass variables to another application at a defined URL.

To test this action, the file to be loaded must be at the specified location. A 
network connection must exist for absolute URLs (for example, 
http://www.myserver.com/).

The Get URL action has the following parameters:

 þ URL specifies the URL from which to obtain the document.

 þ Window specifies the window or HTML frame that the document should be 
loaded into. You can enter the name of a specific window or frame or enter an 
expression. You can also choose from the following reserved target names: 

_self specifies the current frame in the current window. 

_blank specifies a new window. 

_parent specifies the parent of the current frame. 

_top specifies the top-level frame in the current window. 

 þ Variables determines whether to use GET or POST to send variables, or 
whether to pass no variables at all. The GET method appends the variables to 
the end of the URL, and is used when a small number of variables are 
involved. The POST method sends the variables in a separate header, and is 
capable of sending much longer strings. See “Setting and identifying variables” 
on page 191.

Checking whether a frame is loaded
Use the _framesloaded property (within an If statement) or the If Frame Is Loaded 
statement to check whether the contents of a specific frame are available locally. 
A common use for _framesloaded or If Frame Is Loaded is to start playing a simple 
animation while the rest of the movie downloads to the local computer. The main 
difference between the two approaches is that the If (_framesloaded) statement 
allows you to add an Else or Else If statement to your action, quickly. The 
If Frame Is Loaded statement allows you to specify a specific number of frames in a 
simple statement.
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To use the _framesloaded property in an action that plays a short animation loop 
while a movie finishes loading:

1 Create a short animation loop at the beginning of the movie. For example, you 
can create a loop that displays the message “Movie loading...”. 

2 Create a frame action with If Frame Is Loaded that jumps out of the animation 
loop after all the frames are loaded and continues playing the movie. For 
example, a movie that has a two-frame animation loop at the beginning would 
require the following action attached to Frame 2:

If (_framesloaded) 
Go to and Play (3) 

Else 
Go to and Play (1) 

End If 

To use the If Frame is Loaded statement in an action that plays a short animation 
while a movie finishes loading:

1 Create a short animation loop at the beginning of the movie. For example, you 
can create a loop that displays the message “Movie loading...”. 

2 Create a frame action with If Frame Is Loaded that jumps out of the animation 
loop when all the frames are loaded and continues playing the movie. For 
example, a 30 frame movie that has a two-frame animation loop at the 
beginning would require the following action attached to Frame 1:

If Frame Is Loaded (30)
Go to and play (3)

End If Frame Is Loaded

When you insert an If Frame is Loaded statement, Flash automatically inserts an 
End If Frame is Loaded statement at the end.

3 For Frame 2, attach the following action, which restarts the movie at frame 1:

Go to and play (1)

When the frame specified in the If Frame is Loaded statement is loaded, the 
movie skips the second frame and continues playing the movie from the 
third frame.

The If Frame is Loaded statement is also useful for a section in a movie that requires 
loading a large bitmap or sound file. 

Typically, If Frame Is Loaded is a condition for a frame action, but you can also use it 
as a button action. To test an If Frame Is Loaded condition, use the Streaming option 
with the Test Movie command. The frames load in the same way as they would if 
streaming from a web site. See “Testing movie download performance” on 
page 226.
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The If Frame Is Loaded statement has the following parameters:

 þ Frame specifies the frame number of the frame label you want loaded locally 
before the next statement is executed. 

 þ Scene is the scene containing the specified frame.

Loading and unloading additional movies
Use the Load Movie and Unload Movie statements to play additional movies without 
closing the Flash Player. Normally, the Flash Player displays a single Flash Player 
movie (SWF file). Load Movie lets you display several movies at once or switch 
between movies without loading another HTML document. Unload Movie removes 
a movie previously loaded by Load Movie. 

For example, you can use Load Movie in the following ways:

 þ To play a sequence of banner ads that are SWF files by placing a Load Movie 
statement at the end of each SWF file to load the next movie. 

 þ To develop a branching interface where the user can choose among several 
different SWF files. 

 þ To build a navigation interface where level 0 has navigation controls that load 
other levels. By loading levels, you can get smoother transitions than by 
loading new HTML pages in a browser.
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Load Movie and Unload Movie statements have the following parameters:

 þ Action identifies whether to load a movie, unload a movie, or load variables 
(from a remote text file) into an active movie. For more information see 
“Obtaining variables from a remote file” on page 183.

 þ URL specifies an absolute or relative URL for the SWF file to load. For use in 
the Flash Player or for testing in Flash, all the SWF files must be stored in the 
same folder and listed as file names without folder or disk drive specifications.

 þ Location specifies a level or target for the Load Movie or Unload Movie statement. 
In the Flash Player, movie files are assigned a number according to the order in 
which they were loaded. The movie that was loaded first is loaded at the 
bottom level, level 0. The movie in level 0 sets the frame rate, background 
color, and frame size for all other loaded movies. Movies are then “stacked” in 
higher numbered levels above the movie in level 0.

For more information about levels and targets, see “Understanding multiple 
Timelines” on page 185.

You can selectively load movies into levels that already have SWF files loaded. 
If you do, the new movie will replace the existing SWF file. If you use Load 

Variables, the active movie is not replaced, but the variables are updated with 
the new values. If you load a new movie into level 0, every level is unloaded, 
and level 0 is replaced with the new file.

 þ Target specifies a movie clip that you want the loaded movie to replace. If you 
use Target, the movie that you loaded inherits the position, rotation, and scale 
properties of the targeted movie clip. See also “Controlling other movies and 
movie clips” on page 185.

 þ Variables allows you to specify whether to send a set of the existing variables 
for the loaded movie to the location identified in the URL field. This can 
be used to send variables to a CGI script which generates a SWF file as its 
CGI output. Variables determines the whether to use GET or POST when 
downloading the URL’s content, or to pass no variables at all. See “Setting and 
identifying variables” on page 191 for more information about variables 
in Flash.

The Load Movie and Unload Movie statements do not function in the editing mode. 
Use Control > Test Movie to check whether they work. To test this statement, the 
movie you’re loading must be at the specified path. If the path is an absolute URL, 
use File > Publish Preview option (a network connection must exist, and must be 
active) to test the movie. 
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Obtaining variables from a remote file
Use the Load Variables statement, which is one of the parameters of Load Movie, to 
read data from a text file or text generated by a CGI script, and set the values for 
variables in a movie or movie clip. For example, if a user submits an order form, 
you might want a confirmation screen to display an order number gathered from a 
file on a remote server. 

With Load Variables, the text at the URL must be in the standard MIME format 
application/x-www-urlformencoded (a standard format used by CGI scripts). 
Any number of variables can be specified. For example, this phrase defines 
several variables:

company=Macromedia&address=600+Townsend&city=San+Francisco&zip=94103

 þ URL specifies an absolute or relative URL for the remote file. 

 þ Location specifies a level or target to receive the variables. In the Flash Player, 
movie files are assigned a number according to the order in which they were 
loaded. The movie that was loaded first is loaded at the bottom level, level 0. 
The movie in level 0 sets the frame rate, background color, and frame size for 
all other loaded movies. Movies are then stacked in higher numbered levels 
above the movie in level 0.

For more information about levels and targets, see “Understanding multiple 
Timelines” on page 185.

 þ Variables determines whether to use GET or POST to pass variables, or to 
pass no variables at all. This can be used to send variables to a CGI script that 
generates a SWF file as its CGI output. The GET method appends the 
variables to the end of the URL, and is used when a small number of variables 
are involved. The POST method sends the variables in a separate header, and 
is capable of sending much longer strings. See “Setting and identifying 
variables” on page 191.

If you specify either GET or POST with the Load Variables statement, Flash 
sends the variables to the web server, and then interprets the server’s response 
to update the variables in the movie.

Use the File > Publish Preview option to test the loading of variables. (An active 
network connection must exist for this to work.)

Sending messages to the movie’s host 
program
Use the FS Command statement to send a message to whichever program is hosting 
the Flash Player. If you are not familiar with JavaScript or building projectors, you 
probably have no need to use FS Command.
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FS Command has two parameters: Command and Argument. Enter the string you 
want to send in the Command box. If the string requires any arguments, enter 
them in the Arguments box. The Command and Arguments boxes let you use a 
literal value or an expression.

In a web browser, an FS Command statement invokes the JavaScript function 
moviename_DoFSCommand in the HTML page that embeds the Flash movie, where 
moviename is the name of the Flash player as assigned by the NAME attribute of the 
EMBED or OBJECT tag. If the Flash player is assigned the name theMovie, the 
JavaScript function invoked is theMovie_DoFSCommand.

The JavaScript function is passed the parameters Command and Arguments, which 
can be used for any purpose.

For example, to use the FS Command statement to open a message dialog box from 
a Flash movie in the HTML page through Javascript: 

1 In the HTML page that embeds the Flash movie, add the following 
Javascript code:

function theMovie_DoFSCommand(command, args) {
if (command == "messagebox") {

alert(args);
}

}

2 In the Flash movie, add the FS Command statement whenever you want to open 
a message dialog box:

FS Command ("messagebox", "This is a message box invoked from within Flash.")

You can also use expressions for the FS Command statement and arguments, as 
in the following example:

FS Command ("messagebox", "Hello, " & name & ", welcome to our website!")

You can set up the HTML page to support this by creating your own template 
and using the Publish and Preview commands. See “Flash publish settings” on 
page 229.

In Director, the FS Command statement can send messages that are interpreted as 
events by Lingo. You must write the Lingo code to receive the messages from FS 
Command and carry out an action in Director.

In Visual Basic, Visual C++, and other programs that can host ActiveX controls, 
FS Command sends a VB Event with two strings that can be handled in the 
environment’s programming language.
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The following special FS Command statements control a movie playing as 
a projector: 

Controlling other movies and movie clips
Use the Tell Target statement to control a different movie clip or another movie 
that was loaded with the Load Movie statement. 

The Tell Target statement is useful for navigation controls. Assign the Tell Target 
statement to buttons that stop or start movie clips elsewhere on the Stage. You can 
also make movie clips go to a particular frame in that clip. 

The Tell Target statement has the single parameter Target, which specifies the 
Timeline that is to be controlled. Any statements nested within the Begin Tell Target 
and End Tell Target statements are directed at the targeted Timeline.

Understanding multiple Timelines

When a movie plays back in the Flash Player, multiple Timelines may be present. 
Every Flash movie has a main Timeline. Each movie clip instance within a movie 
represents another Timeline. Additional Timelines may be present by loading 
movies with the Load Movie statement. 

For example, the following outline shows seven Timelines present within the 
Flash Player:

MovieX.swf (in level 0)
ClipA (Instance name: Jack)

ClipA1 (Instance name: Bert)
ClipA2(Instance name: Ernie)

ClipB (Instance name: Jill) 
MovieY.swf (in level 1)

ClipC (Instance name: Smith)

Command  Arguments  Function

quit none Closes the projector.

fullscreen True/False True sets the player to full-screen mode. False 
returns the player to normal menu view.

allowscale True/False False sets the player so that the movie is always 
drawn at 100% and the image is never scaled. 
True sets the player back to the default Show 
All mode.

showmenu True/False True enables the full set of right-click menu 
items. False hides the menu bar.

exec Path to 
application

Executes an application from within 
the projector.
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Each Timeline runs independently, and can control any of the other Timelines. 
For example, a button in the main Timeline of MovieX can start and stop ClipC 
in MovieY. Likewise, a frame action in ClipC can make the playhead in MovieX 
jump to another scene or frame. 

Specifying targets

The Expression Editor has a Target button for inserting target names. In some 
situations, once you click the Target button, the area above the Target field 
displays movie clips that can be targeted. If this is the case and one of these 
movie clips is to be targeted, double-click the movie clip’s name. The correct 
information is automatically entered in the Target field. At other times, the 
Timeline that you wish to target will not be in the window and the path will need 
to be entered manually.

Similar to the hierarchy of files and folders on a web server, Flash has a hierarchy 
of Timelines. To specify targets at different levels in the hierarchy, add a path to 
the target’s instance name using the same system as for file paths or URLs. Movies 
(SWF files) are at the top of the hierarchy with movie clips below them.

The syntax for identifying targets is similar to that for folders in a file system. For 
example, a leading “/” identifies a movie clip at the root of the current layer. 
Targets without the “/” are identified relative to the current movie clip.

The following Tell Target paths use the seven Timeline example from the 
previous section:

 þ /Jack targets the movie clip named ClipA from the main Timeline of MovieX.

 þ ../ targets the Timeline of MovieX from the movie clip named ClipA. 

 þ /Jack/Bert targets movie clip ClipA1 from any other movie clip.

 þ Bert targets movie clip ClipA1 from the Timeline of movie clip ClipA. 

 þ ../Ernie targets movie clip ClipA2 from the Timeline of ClipA1.

 þ _level1/Smith targets movie clip ClipC in MovieY from any other movie clip. 

 þ A blank target field name targets the current Timeline.

The same movie clip can be targeted using more detailed variations of the path 
name. For example, /Jack targets the movie clip named ClipA from the main 
Timeline of MovieX; so does _level0/Jack which merely includes more information. 
A more detailed path name might be useful if you copy buttons with Tell Target 
statements from one movie to the next, changing the context of the button.

You can also use an expression to specify a target. For example, the expression 
"/"&ButtonName in the Parameters pane has Tell Target send a message to the movie 
clip contained in the variable ButtonName. 
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A Timeline must currently be in the Flash Player in order to be targeted. A movie 
clip Timeline is present in the Player when the playback head is positioned within 
the movie clip’s frames. For example, if a movie clip is placed on the Timeline in 
frames 1 through 20, the movie clip can be targeted while the movie is playing or 
stopped at any frame between 1 and 20. After the movie reaches frame 21 the 
movie clip is no longer in the Player and cannot be targeted. See “Checking 
whether a frame is loaded” on page 179 to set up a statement to check for a frame 
before executing the Tell Target statement.

The following sample action is for a button on the main Timeline that, when 
pressed, stops the movie clip instance Jack from playing. When the button is 
released, the action starts frame 55 of the movie clip instance Bert:

On (Press) 
Begin Tell Target ("/Jack") 

Stop 
End Tell Target 

End On 
On (Release) 

Begin Tell Target ("/Jack/Bert") 
Go to and Play (55) 

End Tell Target 
Go to Next Frame 

End On 

Duplicating and removing movie clips
Use the Duplicate Movie Clip statement to create an instance of a movie clip while 
the movie is playing. When you duplicate a movie clip, the new movie clip starts 
at frame 1 even if the original movie clip was on another frame when duplicated. 

Use the Remove Movie Clip statement to delete a movie clip instance that had been 
created with Duplicate Movie Clip. 
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Duplicate/Remove Movie Clip has the following parameters:

 þ Action sets the statement to duplicate or remove the movie clip.

 þ Target specifies the movie clip to duplicate or remove. Click the button 
labelled “abc” and choose Target Editor to specify a target visually, or enter a 
target path in the field. See “Specifying targets” on page 186.

 þ New Name is the instance name for the duplicated movie clip. Provide only 
the name, not a target path. Then, once named, the instance can be targeted 
from another action.

 þ Depth determines how the duplicated movie clip appears when overlapping 
other objects. Think of depth levels in terms of the stacking order with level 0 
the initial level. Each successive duplicate movie clip needs to be given a 
depth, otherwise each duplicate will replace the previous clip at level 0. 
Duplicate movie clips are always on top of the original movie clip.

 þ Remove duplicate movie clip changes the statement to Remove Movie Clip. 
Duplicated movie clips do not disappear unless the parent movie clip 
disappears, or you use the Remove Movie Clip statement. 

Note: Variables are not copied into the new movie clip, and the duplicate movie clip starts at 
the first frame.

Making movie clips draggable
Use the Drag Movie Clip statement to move a movie clip while the movie is running. 
The statement can be set to start or stop a drag operation. A movie clip remains 
draggable until explicitly stopped by Stop Drag or until another movie clips is made 
draggable. Only one movie clip is draggable at a time.

Drag Movie Clip has the following parameters:

 þ Start Drag Operation begins dragging the movie clip.

 þ Target specifies the movie clip to drag. Click the button labelled “abc” and 
choose Target Editor to specify a target visually, or enter a target path in the 
field. See “Specifying targets” on page 186.

 þ Constrain to Rectangle lets you specify a rectangular area beyond which the 
movie clip cannot be moved. The left, top, right, and bottom values are 
relative to the coordinates of the movie clip’s parent. 

 þ Lock Mouse to Center makes the center of the movie clip appear directly 
under the mouse pointer as the user moves the pointer. When this option is 
not selected, the movie clip maintains a position relative to the pointer when 
the drag operation started. 
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For example, this action constrains the movie clip named target_item within a 
200 x 200 pixel box (offset to the specified coordinates):

On (Press, Release, Outside)
Start Drag ("target_item", L=100, T=100, R=300, B=300, lockcenter)

End On

Drag-and-drop movie clips

For a movie clip that the user can position in any location, use the Start Drag and 
Stop Drag statements as follows:

On (Press) 
Start Drag ("movie") 

End On 
On (Release) 

Stop Drag 
End On 

To create more complicated drag-and-drop behavior, you can evaluate the 
_droptarget property of the movie clip being dragged. For example, you might 
examine the _droptarget property to see if the movie was dragged to a specific 
movie clip (such as a “trash can” movie clip), and then trigger another action. See 
“Creating conditional actions” on page 192 and “Writing expressions” on 
page 196. 

Changing movie clip position and appearance
Use the Set Property statement to change the position, scale, transparency, visibility, 
and rotation of a movie clip as the movie plays. 
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Set Property has the following parameters:

 þ Set specifies the property to change.

X Position and Y Position set the movie clip’s horizontal and vertical position, 
respectively. The position is relative to the local coordinates of the parent 
movie clip.

X Scale and Y Scale scale the movie clip horizontally or vertically, respectively. 
Values for the property are percentages; the default value is 100.

Alpha specifies the movie clip’s transparency. Values can be from 0 (fully 
transparent) to 100 (fully opaque). Objects in a movie clip with Alpha set 
to 0 are active, even though they are invisible. For example, a button in a 
movie clip with Alpha property set to 0 can still be clicked.

Visibility specifies whether the movie clip is visible. Values for this property are 
either True (visible) or False (not visible). The movie clip is visible if the value is 
any nonzero value; the movie clip is invisible if the value is zero. Objects in a 
movie clip with Visibility set to false are disabled. For example, a button in a 
movie clip with the Visibility property set to false can not be clicked. 

Rotation specifies a movie clip’s rotation. The value is in degrees.

 þ Target specifies the movie clip whose property you want to set. Click the 
button labelled “abc” and choose Target Editor to specify a target visually, or 
enter a target path in the field. See “Specifying targets” on page 186.

 þ Value specifies the value to assign the property. 

For example, this statement sets the Y position property of a movie clip named 
target_item to 150:

On (Release)
Set Property ("target_item", Y Position) = 150

End On

Commenting actions
Use the Comment statement to add notes to a frame or button action to help you 
keep track of what you intended an action or part of an action to do. Comments 
are also useful for passing information to other developers if you work in a 
collaborative environment or are providing samples. 
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Setting and identifying variables
A variable is a container that holds information. The container itself is always the 
same, but the contents can change. By changing the value of a variable as the 
movie plays, you can record and save information about what the user has done, 
record values that change as the movie plays, or evaluate whether some condition 
is true or false. 

Variables can hold either numbers or strings of characters. Typical types of 
information you can store in a variable include a URL, a user’s name, the result of 
a mathematical operation, the number of times that something occurred, or 
whether a button has been clicked. Each movie and movie clip has its own set of 
variables, with each variable having its own value independent of variables in other 
movies or movie clips. 

Variables in Flash do not have to be explicitly defined as holding either a number 
or a string. It interprets the data type as an integer or string accordingly. See also 
“Emulating arrays” on page 194.

Assigning values to variables

Use the Set Variable statement to assign a value to a variable. If a variable doesn’t 
exist in the movie or a movie clip, Flash creates the variable when you first assign a 
value to it.

Set Variable has the following parameters:

 þ The Variable field specifies the name of the variable. It’s a good habit to use 
variable names that indicate what the variable represents. For example, the 
variable name password indicates that the variable contains a password. 

 þ The Value field specifies the value to assign the variable. 

You can use numerical operations and string operators to change the content of a 
variable. For example, this statement modifies the existing value of the variable 
totalSum by adding 3 to its current value:

Set Variable: "totalSum" = totalSum + 3

Identifying a variable in a specific movie or movie clip

To identify a variable in a specific movie or movie clip, prefix the variable name 
with the path to the movie or movie clip.Use a colon to separate the path from the 
variable name. For example, this phrase specifies the variable Timer in the movie 
clip Explosion:

/Explosion:Timer
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Creating conditional actions
Use the If statement to set up statements that run only when a certain condition 
exists. For example, you can check the value a user entered in a text field and 
display a message if the value is too high or too low. To use the If statement 
effectively, you should be familiar with creating expressions that evaluate 
conditions. See “Writing expressions” on page 196.

For every If statement, the statement End If marks the end of the statements that 
run if the condition is still true. If you want an action to respond to one of several 
possibilities, use a series of If statements. An If statement can also contain an Else 
statement that designates an alternate series of statements to run if the condition is 
false (zero).

Statements within the If and End if statements are indented. The indented 
statements run only if the condition is true. Otherwise, Flash ignores the 
indented statements.

For each Else statement, select the original If statement, and then click the “Add 
Else/Else if clause” button. Each click adds another Else clause. Set the Else if clause 
by selecting an individual Else clause and clicking the Else if radio button in the 
Parameters pane.

For example, this action uses If with Else if and Else to direct different users to 
different scenes in a movie. If the variable name doesn’t equal any of the names 
mentioned, then a standard welcome scene starts:

If (name eq "Gary")
Go to and Play ("Gary’s World", 1)

Else if (name eq "David")
Go to and Play ("David’s World", 1)

Else if (name eq "Peter")
Go to and Play ("Peter’s World", 1)

Else 
Go to and Play ("Welcome", 1)

End If

Looping actions
Use the Loop statement to set up a series of statements that run repeatedly while a 
specific condition remains true. A common use of looping is to use a variable as a 
counter and perform an action while the counter is less than a specified value. At 
the end of each loop, you increment the counter. To use the Loop statement 
effectively, you should be familiar with creating expressions that evaluate 
conditions. See “Writing expressions” on page 196.

For every Loop statement, an End Loop statement marks the end of the statements 
that run when the condition remains. Upon reaching the End Loop statement, 
Flash starts the loop over by testing the condition. If the condition is false or equal 
to zero, Flash skips to the first statement following End Loop.
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For example, these statements form a sample loop that runs ten times. Each 
time the loop runs, the Index variable is increased by 1. When Index equals 
11, the expression Index <= 10 is false, so Flash skips past the loop to any 
subsequent statements.

Set Variable: "Index" = 1 
Loop While (Index <= 10) 

Set Property (“target_item”, Y position) = 150
Set Variable: "Index" = Index +1 

End Loop 

The screen is not updated until the loop finishes.

Reusing actions
You may want multiple buttons or frames to use the same action. Rather than 
copy and paste all the statements between the buttons and frames, assign the 
action to a different frame and then use the Call statement to run that action. 

Specify the frame to call by using any of the ways that identify frames for the Go To 
statement. (See “Jumping to a frame or scene” on page 178.) If the frame cannot 
be located due to a naming error or because it hasn’t streamed to the local 
computer, Flash ignores the Call statement. (You can use the _framesloaded 
property to check whether a frame is available.)

After the specified frame’s actions run, control returns to the action that issued the 
Call statement. 

To create a library of actions, create a movie and assign each action to a separate 
frame in the Timeline. Label each frame with the script’s name to make it easy 
to call. 

Flash provides no special way to pass or return values when using the Call 
statement. In fact, when you use the Call statement, the context is switched to the 
move clip being called, including the known variables. To pass values into a 
another movie clip, pass them in Flash variables. Similarly, the targeted movie clip 
should store any return values in variables. Basically, separate Set Variable 
statements should be used in conjunction with the Call statement to pass or 
return values.

For example, this statement sets the variables in Database before running the 
action AddDatabaseRecord:

Set Variable: "/Database:Name" = "Franz Schubert"
Set Variable: "/Database:Occupation" = "Musician"
Call ("/Database:AddDatabaseRecord")
If (/Database:Result eq "OK") 

Go to And Stop ("OK")
Else

Go To And Stop ("Error")
End If
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Types of values
Values in Flash can be numbers or strings. These values can be literal values 
(“auto”) or represented by expressions (Substring (automobile, 1, 4)).

Action scripting is not a “typed” language: a variable’s type (string, integer, and so 
on) depends on the type of values assigned to the variable. 

True and false/nonzero and zero

The terms True and False indicate whether a condition exists: The term False 
indicates that a condition does not exist. Flash also uses the number 0 as a 
numerical equivalent to False. Flash treats any nonzero number as true.

Strings

Flash treats any characters enclosed within quotation marks as strings instead 
of variables. 

Obtaining a property’s value

The method for obtaining a property’s value depends on the context of the 
property relative to the current movie clip. For example, using the statement ( _x) 
in the current movie clip returns the x position of the current movie clip. 

For a property of another movie clip, use a pathname to target the movie clip. 
For example, the target and property name /Foo: _x returns x of movie clip Foo 
as a value. 

Using GetProperty

When the target is an expression, use the GetProperty() statement to return the 
value of a movie clip property. For example, to return the x-position of each 
spaceship in a video game with many spaceships, each in a movie clip numbered 
sequentially (/spaceship_1, /spaceship_2, ...), use the statement:

GetProperty(“/spaceship_”&ShipNumber, _x)

Emulating arrays
Flash can construct variable names dynamically because the variable assignment 
and retrieval operations can evaluate an expression to get the variable name. This 
makes it possible to emulate arrays, dictionaries, and other data structures. For 
example, a 10-element array could be emulated by ten variables with the names

A_1
A_2
...
A_10
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For example, the array:

Set Variable "name" & namecount = newname
Set Variable "namecount" = namecount + 1

creates an array that looks like this:

name1 -> Gary
name2 -> another name
name3 -> someone else
namecount -> 3

To find a particular name, you can use the following action:

Set Variable "index" = 1
Set Variable "found" = false
Loop While (index <= namecount and not found)

If (Eval("name" & index) eq nametofind)
Set Variable "found" = true

Else
Set Variable "index" = index + 1

End If
End Loop

In this action, when found is true, index contains the array index of the 
located name.

You can also emulate a two-dimensional array, such as this:

A_1_1
A_2_1
...
A_3_3

Obtaining the value of a dynamically named variable

Use the eval function to obtain the value of a variable named by an expression. For 
example, the expression eval("Name") is exactly the same as the expression Name.

By specifying the name as an expression, the name of the variable to be obtained 
can be decided while the Flash movie is playing. 

For example, the statement eval("Name"&Index) lets you manage 10 names, where 
Index is a variable that contains a number from 1 to 10. This expression obtains 
one of the variables Name1, Name2, Name3, ... depending on what the value of 
Index is. In a loop, Index can be updated each iteration to obtain all 10 names. 

Checking variable and property values

Because action scripting is not a typed language, variables may be misassigned as 
integers or strings. If an integer is entered for a string variable, then Flash assigns a 
“true” value to the integer. If a string is entered for an integer variable, then Flash 
assigns a number equaling the length of the string. (For example, entering Name 
returns 4).
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Writing expressions
An expression is any phrase that Flash can evaluate to a value. Flash has three types 
of expressions: string expressions, numerical expressions, and comparison 
expressions. You create an expression by combining operators and values.

Whether the expression’s initial value is a string or a number depends on the 
parameter’s default type. For example, the Frame Label parameter in the Go To 
statement is a string, so an expression that specifies the Frame Label parameter is a 
string by default.

Using the Expression Editor

An Expression Editor that helps you formulate the exact contents of certain 
statement parameters can be opened from the Actions tab. 

For some parameters, the parameter field has an “abc” button indicating that 
the statement expects a literal value. Simply type the literal value into the field. 
For other parameters, Flash presents a “=” button indicating that an expression 
is expected.

If you need to create an expression, click the button next to the field and choose 
Expression Editor.
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Double-click the operators and functions you want to use. Some functions 
contain generic information that you need to replace with the proper details for 
your statement. For example, to extract the value of the x coordinate of a movie 
clip location:

1 Double-click the Properties option GetProperty until it appears in the text box 
at the top of the dialog box.

2 Highlight the generic term “target” and click Target.

3 Select the desired movie clip from the list. If the target movie clip doesn’t 
appear in the list, type the name of the movie clip in the Target field and 
click OK.

4 Select the generic term “property,” and double-click the item in the Properties 
menu _x which refers to the X position.

5 Click OK in the Expression Editor.

If you haven’t provided enough information or have used improper syntax, the 
Expression Editor displays a warning message. Otherwise, the new expression 
appears in the statement.

Numerical expressions

Numerical expressions evaluate to numbers. They can combine numbers, variables 
that contain numbers, and operators such as +, -, =, logical operators, and 
comparison operators.

This is a simple numerical expression:

1+2

This statement uses the expression Score + 1, which combines numbers and 
variables:

Set Variable: “Score” = Score+1

The statement adds 1 to the current value of the variable Score.

String expressions

A string expression concatenates two or more strings to create a new string. The 
operands can be variables, literal strings enclosed in double-quotes, or functions 
that return strings.

For example, the string expression "Hello, " & "world." concatenates the strings 
“Hello, “and “world.” The result is “Hello, world.”
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Use the Substring function to extract part of a string. When using Substring, the 
first parameter is the string. The second parameter, the Index, is the number of 
the first character to extract. The third parameter is the number of characters to 
include after the Index. For example, Substring("Hello", 4, 2) returns “lo”. If the third 
parameter is omitted, the entire string from the Index to the end of the string 
is returned.

Numbers used in string expressions are automatically converted to strings when 
used with string operators. For example, "value_"&(index+1) evaluates the numerical 
expression index+1, after which the resulting number is concatenated to the end 
of the string value_.

Arithmetic operators

Flash operators follow basic mathematical principles. Multiplication and 
division occur before addition and subtraction. Terms within parentheses 
occur before multiplication and division. Attempting division by zero results 
in the string #ERROR#.

These are some examples of arithmetic expressions: 

(1+2)*3
Principal*Rate*Time
Subtotal*(1+(SalesTaxRate/100))
-Value (negative value of variable Value)
+Value (leaves value unchanged)

You can use the functions Int() and Length() in arithmetic expressions because these 
functions return numbers. 

Int(number) returns the integer value of a specific number. For example, INT(12.5) 
returns 12.

Length(string) returns the length of the specified string. For example, Length("Hello") 
returns 5.

Length(variableName) returns the length of variable name. For example, Random (5) 
returns 0, 1, 2, 3, or 4.

If you use a string in a Flash expression, the string is converted to numbers when 
used with numerical operators. For example, "1"+2 evaluates to 3. 

If the string cannot be converted to a number, the string evaluates to 0. For 
example, in the expression "ABC"+3, ABC evaluates to 0. The result is 0+3, 
which is 3. 
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String operators

Flash treats any sequence of characters surrounded by double quotation marks as a 
literal string.The following operations are useful for manipulating strings and 
specifying string contents.For example, this statement uses the string comparison 
operator eq to test whether the variable name contains the string Harold:

name eq "Harold"

Comparison operators

Comparison expressions compare two expressions to each other. These are usually 
used for If statements and Loop statements. For example, the statement Year = 2000 
tests whether the value of the variable Year is 2000.

The statement Age >= 18 tests whether the variable Age is greater than or 
equal to 18.

Logical expressions

Logical expressions are, like comparison expressions, usually used for If statements 
and Loop statements.

For example, the statement Index <= 10 and Done = 0 tests whether the variable 
Index is less than or equal to 10 and whether the variable Done equals 0.

The statement LotteryNumber >= 6 and LotteryNumber <= 49 tests whether the 
variable LotteryNumber is between 6 and 49.

The statement Index < 1 or Index > 10 tests whether the variable Index is out of the 
range 1 to 10.

The statement not (Index < 1 or Index > 10) tests whether the variable Index is in the 
range 1 to 10.

Measuring time

Use GetTimer to return the number of milliseconds elapsed since the movie started 
playing. For example, in a frame the statement 
Trace (Int(GetTimer / 1000) & " seconds have elapsed.") 
creates a message in an output window displaying each second as it elapses.

Converting ASCII code characters

Flash can convert ASCII code numbers into characters, and characters into ASCII 
code numbers.

The function Chr converts ASCII code numbers to characters. For example, the 
function Chr (65) = "A" converts the number 65 to the letter “A”.

The function Ord converts characters to ASCII code numbers. For example, the 
function Ord(a) = 97 converts the letter “a” to the number 97.
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Using properties
Movie clip properties are essentially variables that exist for every movie clip. You 
can set values for properties to modify the behavior of a movie clip, or retrieve 
property values to evaluate them and initiate statements based on the results. The 
Expression Editor contains a complete list of all available properties. Most 
property values are specific to individual movie clips. However, some properties 
are applied to the entire movie and are called global properties.

Movie clip properties

Most movie clip properties are self-explanatory. (For example, _width is the width 
of the movie clip in pixels). However, the following movie clip properties need to 
be clarified:

 þ The _x and _y properties are in pixels, with the upper left corner of the Stage 
being (0, 0).

The _x and _y properties are specified in the local coordinate system of the 
movie clip's parent. If a movie clip is in the main Timeline, then its coordinate 
system refers to the upper left corner of the Stage as 0, 0.

If the move clip is inside another movie clip that has transformations, the 
movie clip is in the local coordinate system of the enclosing movie clip. Thus, 
for a movie clip rotated 90 degrees counterclockwise, the movie clip’s children 
inherit a coordinate system that is rotated 90 degrees counterclockwise. 

For example, suppose that animated movie clip A sets the _x property for every 
frame in order to animate a circle moving from the left to the right. If you 
place movie clip A into movie clip B, which is rotated 90 degrees 
counterclockwise, the circle in movie clip A will travel from bottom to top 
instead of left to right, even though the _x property is being set. The rotation 
of the parent movie clip has rotated the coordinate system of the children.

 þ The movie clip’s coordinates refer to the registration point position. If Use 
Center Point is checked in the Object Properties dialog box, the center point 
location is the registration point. Otherwise, the center point location is the 
upper left corner of the object.

 þ _xscale and _yscale are measured in percentages with the default set to 100. 
Scaling is applied from the registration point of the movie clip.

Scaling of the local coordinate system affects what the _x and _y properties 
mean. At the top level, the _x and _y properties are values in whole pixels. In 
the example of a moving circle, if the parent movie clip is scaled to 50%, 
setting the _x property moves the circle half the number of pixels as when the 
scale was 100%.

 þ _rotation is set in degrees.
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 þ The _x, _y, _rotation, _xscale and _yscale properties are all cumulative. They 
transform not only the movie clip but any children the movie clip has. They 
are affected by the transformations on the movie clips’ parent.

 þ _url is the URL where the movie clip resides.

 þ _visible can be set to True (default) or False. If False, the movie hides the movie 
clip instance and it is not “hit”tested. The button or frame actions in that clip 
will not work.

Text field scrolling properties

If a scene contains a text field associated with a variable, there are two special 
properties associated with the display of that text field:

Use the scroll property to define where the text field begins displaying its content. 
This property can be particularly useful to direct an audience to a specific 
paragraph in a long passage.

variable_name.scroll The scroll value is the line number of the topmost visible 
line in the text field. 
The scroll value is initially set by you. The default is 1, and 
Flash updates this value as the audience scrolls up and 
down the text field.
The scroll value may be retrieved and modified.

variable_name.maxscroll The maxscroll value is the line number that is the maximum 
value that scroll can be based on the height of the 
text field. 
Flash sets the maxscroll value.
The maxscroll value may be retrieved, but not modified.
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For example, in a text field that is four lines in vertical size and identifying variable 
“speech” which is nine lines, vertically, then only part of the speech can be shown 
(identified by the solid outlined box):

speech.scroll equals 1 because the textfield starts displaying at the first line.

speech.maxscroll equals 6 because, as the audience scrolls down to see the last line, 
line 6 is the uppermost limit of the text field.

Note: These variables return unpredictable values if more than one text field displays the 
same variable at the same time. (This can occur when the audience can scroll through two 
fields displaying the same variable at the same time).

Global properties

Global properties impact the entire movie, not just specific movie clips. (The 
Target field is disabled for these properties because you cannot specify an 
individual level). The values of these properties can be read from anywhere in the 
main Timeline.

_highquality can have one of three values:
0 = low quality (no anti-aliasing)
1 = high quality (anti-aliasing and if the movie does not 
contain animation, bitmaps are smoothed. If the movie 
contains animation, bitmaps are not smoothed.)
2 = best quality (anti-aliasing and bitmaps are always 
smoothed)

_focusrect If true (nonzero), the audience sees a yellow rectangle around 
the currently focused button as they use the Tab key to 
navigate buttons. The default value is true. Set to false if you 
want your audience to see only the button “Over” state as they 
navigate.

_soundbuftime Establishes the number of seconds of streaming sound to pre-
buffer. The default is 5 seconds.

1

2

3

4

5

6

7

8

9
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Troubleshooting Interactivity
The level of sophistication of some actions, especially in combination with one 
another, can create complexity as well. Continually test your movie clips and keep 
some of the following tips in mind to help you with any unexpected results:

 þ Trace displays information in an output window. You can use trace to have 
programming notes or specific results appear when a button is pushed, or a 
frame is played while testing a movie or scene. You can write expressions in the 
trace statement parameters to check if a condition exists or not, and have the 
trace window display values while testing a movie.

 þ If a variable is attached to a frame that has not been loaded, then the value of 
that variable is null. 

 þ While testing a movie or scene, use the commands Control > List Objects and 
Control > List Variables.

For ease in reading actions that have long lines or contain many lines, use the 
Object inspector or Frame inspector to display the action’s entire text.
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Creating Interface Elements

Creating interface elements overview
You can use Flash’s interactivity features to assemble common interface elements 
such as pop-up menus, drop-down lists and command menus. Such elements are 
useful for collecting data in forms and for allowing users to interact with a movie 
as they would a stand-alone application.

Creating forms
Forms are an advanced type of interactivity—a combination of buttons, movies 
and fields that let you pass information to another application on a local or remote 
server. All common form elements (such as radio buttons, drop down lists, and 
check boxes) can be created as movies or buttons with the look and feel of your 
web site’s overall design.

Common types of forms that use such interface elements include surveys, order 
forms, and search interfaces. For example, a Flash form can collect and send 
address information to another application that compiles the information into an 
email or database file.

Forms require two components: the Flash elements that make up the form and 
either a server-side application or client-side script to process the information that 
the user enters. The following steps outline the general procedure for creating 
form elements in Flash. 
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To create a form:

1 Create a library of elements such as buttons and checkboxes.

2 Place a combination of editable text fields and symbol instances in the movie 
using the layout you want.

3 Name the variables within the Properties dialog box for each text field. Use 
unique and descriptive variable names.

4 Assign the button actions that send data to a Flash Player or web-based 
application via HTTP.

Creating forms that interact with a web server

Use the Get URL statement to send variables to databases, email, or other 
applications. (You can also use Get URL with mailto:username@company.com as the 
URL parameter to send an email directly from a browser.) Use the Load Variables 
statement to collect information from web servers. For example, you can use Load 
Variables to retrieve variables for a movie clip from a remote server, and then 
display the variables as current information from a news server. Both of these 
statements are described in more detail in “Jumping to a different URL” on 
page 179 and “Obtaining variables from a remote file” on page 183.

Using variables in forms

For better results, do the following when using variables in forms:

 þ Provide variable names that clearly indicate what the variables represent. For 
example, with multiple forms that ask for user names, item names, and 
location names, it’s a good ides to use variable names that indicate the context 
of the data.

 þ Make sure that the variable names correspond to the names expected by the 
application or script that receives the variables.

 þ Use variables in the Timeline or movie clip to record and track information. 
(This is also called maintaining state.) This acts as the equivalent of using 
a hidden field in an HTML form to make it possible for your users to reset 
a form. 

 þ If you have variables attached to particular frames, use the _framesloaded 
property or the If Frame is Loaded statement to ensure that the variables are 
identified before sending them. See “Checking whether a frame is loaded” on 
page 179.

 þ Evaluate variables before sending them to a web server. If a server-side 
application expects a number in a certain format, make sure the user has 
entered proper data. For more information, see “Verifying entered data” on 
page 208.
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Creating a dialog box

A dialog box is a typical short form and provides a good introduction to creating 
forms. The following example provides instructions for creating a search dialog 
box: a text field and a button using the Get URL statement. By entering the required 
information, users can pass a keyword to a search engine on a remote web server. 

You can use the steps in “Creating pop-up menus” on page 209 to make the 
password dialog box a pop-up menu.

To create a simple search dialog box:

1 Create a button that you can use to submit the entered data.

Do not include any text over the button. You can do this within each form to 
suit the specific needs of the instance.

2 Create a label, a blank text field, and an instance of the button on the Stage 
as follows:

3 Select the text field and choose Modify > Text Field.

4 Specify a name for the variable. (Individual search engines may require a 
specific variable. Contact the search engine’s provider for details.) Select Draw 
Border and Background, and Include All Font Outlines. Click OK.

5 On the Stage, select the button and choose Modify > Instance.

6 Click the Actions tab. Click the + (plus) and choose Get URL from the 
pop-up menu.

7 In the Parameters pane, set the following options:

 þ For URL, enter the URL for the search engine.

 þ For Window, select _blank. This will open a new window with the search 
results in it.

 þ For Variables, select Send Using GET.

8 On the Stage, create a text field over the button instance with the text 
you want.

9 To see the form work, choose File > Publish Preview > HTML. 
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For passwords and secure information

Flash relies on standard browser and HTTP security features. If you want to 
support secure passwords in Flash, you need to establish your password 
authentication with a request to a web server. Essentially, Flash offers the same 
security that is available with standard HTML. You should follow the same rules 
that you follow when building secure HTML web sites.

For a password, request a password from the user and then submit it to a sever by 
using a Load Variables statement, using the Send using POST parameter, via an 
HTTPS: URL. The web server could then verify whether the password is valid. 
This way, the password would never be available in the SWF file.

For more information, see “Obtaining variables from a remote file” on page 183.

Verifying entered data

For a form that passes variables to an application on a web server, you want to 
verify that the audience is entering proper information. For example, you don’t 
want your audience to enter text in a phone number field. Use a series of 
Set Variable statements in conjunction with Loop and If to evaluate entered data.
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The following sample action checks to see whether the data is a number, and that 
the number is in the format ###-###-####. If the data is valid, the message 
“Good, this is a valid phone number!” is displayed. If the data is not valid, the 
message “This phone number is invalid!” is displayed:

On (Release)
If (Length(PhoneNumber) = 12)

Set Variable: "Index" = 1
Set Variable: "Valid" = true
Loop While (Index <= 12 and Valid)

Set Variable: "Char" = Substring(PhoneNumber,Index,1)
If (Index = 4 or Index = 8)

If (Char ne "-")
Set Variable: "Valid" = false
End If

Else
If (not (Ord(Char) >= Ord("0") and Ord(Char) <= Ord("9")))
Set Variable: "Valid" = false
End If

End If
Set Variable: "Index" = Index+1

End Loop
Else

Set Variable: "Valid" = false
End If
If (Valid = true)

Set Variable: "Message" = "Good, this is a valid phone number!"
Else

Set Variable: "Message" = "This phone number is invalid!"
End If

End On

When the time comes to send the data, create a button that has an action similar 
to the following. (Replace the Get URL parameters with parameters appropriate for 
your movie.):

On (Release)
If (Valid = true)

Get URL ("www.webserver.com", window="_self", vars=GET)
End If

End On

Creating pop-up menus
Creating a pop-up menu requires two steps:

 þ Turning on the Track As Menu Item option in the Properties dialog box for all 
buttons in the pop-up menu. As a result, all other buttons in the menu can 
receive the mouse release events.

 þ Enclosing the pop-up menu with a large button that closes the menu if the 
user rolls the pointer off the menu and releases the mouse button.
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The following example explains how to create a very simple pop-up menu that can 
be used as the basis for something more complex. The instructions assume that 
you are familiar with creating button and movie clip symbols, and attaching 
actions to buttons and frames.

To create a button for use in a pop-up menu:

1 Create a new button symbol for the menu items.

2 Draw a filled white rectangle in the Up frame of the button symbol’s Timeline.

3 Create a keyframe in the Over frame.

4 Fill the rectangle with a different color for the highlight color of menu items. 
You don’t need to define the Down or Hit frames.

To create the pop-up menu movie clip:

1 Create a new movie clip symbol. 

2 Place an instance of the button symbol you just created in the first frame of 
the movie clip. 

3 Double-click the button, and then select the Actions tab in the Properties 
dialog box.

4 Click the + (plus), choose On MouseEvent from the pop-up menu, and select 
Press in the Parameters pane. With the On (Press) line selected, choose Go To 
from the pop-up menu. Specify Frame Number as the parameter and enter 1 
in the box.

This action makes the movie clip go to the next frame when the user clicks the 
button. The next frame will show the open menu. Use the On (Press) condition 
because pop-up menus respond instantly when clicked, not when the mouse is 
released as do normal buttons.

5 Double-click the first frame in the Timeline, and select the Actions tab in the 
Frame Properties dialog box. Click the + (plus) and choose Go To from the 
pop-up menu. Choose Frame Number 1 as the parameter.

This makes the movie loop on frame 1 until the user clicks the button. 
Clicking the button sends the movie to frame 2.

6 Create a keyframe in frame 2.

7 Create several instances of the button symbol you made earlier. Arrange the 
instances in a column below the button you created in frame 1.

8 Use Modify > Align to align and evenly space the instances. 

9 Add text labels to each button. 
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10 Double-click each button, including the top button you created in frame 1. 
Use the Instance Properties dialog box to do the following:

 þ Click the Definition tab and select Track as Menu Item. (When set to Track 
as Menu Item, a clicked button allows other buttons to receive the mouse 
release event.)

 þ Click the Actions tab and choose the statement that you want the menu item 
to run. Following this statement, choose a Go To statement that sends the 
movie clip back to the first frame. The action may look something like this: 

On (Release)
Toggle High Quality
Go To and Stop (1)

End On 

The Go To statement closes the menu after the user makes a selection. 

11 To test the pop-up menu, create an instance of the pop-up menu movie clip 
symbol and choose Control > Test Movie.

The pop-up menu works in most respects, except that it stays open when you 
open the menu and click somewhere off the menu. 

To make the pop-up menu close when the user clicks outside the menu:

1 Create a new button symbol that is a rectangle the same size and color as 
the Stage. 

Don’t define a Down, Over, or Hit state for the button because you don’t want 
the button to respond visibly to being clicked.

2 Open the movie in symbol-editing mode, and create a new layer underneath 
the layer you’ve been working in.

3 Create an instance of the large button you just made.

4 Double-click the button. 

5 Turn on the Track as Menu Item option in the Instance Properties dialog box, 
and then attach a Go To statement that sends the movie clip back to frame 1. 

To test the pop-up menu, create an instance of the pop-up menu symbol on the 
Stage and choose Control > Test Movie.
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Adding Sound

Adding sound overview
Flash offers a number of ways to use sounds. You can make sounds that play 
continuously, independent of the Timeline, or you can synchronize animation to a 
sound track. Attach sounds to buttons to make them more responsive. Make 
sounds fade in and out for a more polished sound track. 

There are two types of sounds in Flash, event sounds and stream sounds. An event 
sound must download completely before it begins playing and continues playing 
until explicitly stopped. Stream sounds begin playing as soon as enough data for 
the first few frames has been downloaded and synchronizes the sound to the 
Timeline for playing on a web site. 

Adding sounds to a movie involves creating a layer for the sound, assigning the 
sound, and setting options in the Sound panel of the Frame Properties dialog box.

The sampling rate and degree of compression significantly affect the quality and 
size of sounds in exported movies. Control the exported quality and size of 
individual sounds with the Sound Properties dialog box, or define settings for all 
sounds in the movie in the Publish Settings dialog box.

For an interactive introduction to using sound in Flash, choose Help > Lessons > 
6 Sound.

Importing sounds
Choose File > Import to bring either AIFF or WAV sounds into Flash, just as you 
would import any other file type. Flash stores sounds in the Library along with 
bitmaps and symbols.
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Sounds can use considerable amounts of disk space and RAM. Generally, it’s best 
to use 22 kHz 16-bit mono sounds (stereo uses twice as much data as mono), but 
Flash can import either 8- or 16-bit sounds at sample rates of 11 kHz, 22 kHz, or 
44 kHz. Flash can convert sounds to lower sample rates on export. See “Exporting 
movies with sound” on page 219.

Like symbols, you need only one copy of a sound file to use that sound in any 
number of ways in your movie. 

Note: Sounds recorded in formats that are not multiples of 11 kHz (such as 8, 32, or 96 kHz) 
are resampled when imported into Flash causing the sound to play lower or higher than 
originally recorded. 

To import a sound:

1 Choose File > Import. 

2 In the standard import dialog box, locate and open the desired AIFF or 
WAV file.

Note: If you want to add effects to sounds in Flash, it’s best to import 16-bit sounds. If 
you have limited RAM, keep your sound clips short or work with 8-bit sounds instead of 
16-bit sounds.

Adding sounds to a movie
Adding sounds to a movie involves creating a layer for the sound, assigning the 
sound, and setting options in the Sound panel of the Frame Properties dialog box.

To add sound to a movie:

1 Import the sound into the movie.

See “Importing sounds” on page 213.

2 Choose Insert > Layer to create a layer for sound.

You can place sounds on as many layers as you want. Each layer acts like a 
separate sound channel. The sounds on all layers are combined when you play 
back the movie.

3 Click the frame of the sound layer where you want the sound to start. 

4 Choose Modify > Frame and then click the Sound tab in the Frame Properties 
dialog box.
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5 From the Sound pop-up menu, choose the name of the sound file to associate 
with this sound layer.

If the sound doesn’t appear in the pop-up menu, you have to import it. See 
“Importing sounds” on page 213. 

6 Choose a synchronization option:

 þ Event synchronizes the sound to the occurrence of an event. An event sound 
plays when its starting keyframe is first displayed and plays in its entirety, 
independently of the Timeline, even if the movie stops. Event sounds are 
mixed when you play your published movie.

 þ Start is the same as Event, except that if the sound is already playing, a new 
instance of the sound is started.

 þ Stop silences the specified sound. 

 þ Stream synchronizes the sound for playing on a web site. Flash forces 
animation to keep pace with stream sounds. If Flash can’t draw animation 
frames quickly enough, it skips frames. Unlike event sounds, stream sounds 
stop if the animation stops. Also, a stream sound can never play longer than 
the length of the frames it occupies. Stream sounds are mixed when you 
publish your movie. 

7 Enter a value in Loop to specify the number of times the sound should loop; 
for continuous play, enter a very high number.
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8 Use the Sound window controls to edit the sound as needed. Choose from the 
following options.

 þ None applies no effects to the sound file. Choose this option to remove 
previously applied effects. 

 þ Left Channel/Right Channel plays sound only in the left or right channel.

 þ Fade Left to Right/Fade Right to Left shifts the sound from one channel to 
the other.

 þ Fade In gradually increases the amplitude of a sound over its duration.

 þ Fade Out gradually decreases the amplitude of a sound over its duration.

 þ Custom lets you create your own sound effects. Use the Sound window to 
customize the sound wave. See “Using the sound-editing controls” on 
page 216.

To use a shortcut for adding sounds:

1 Make the sound layer the current layer.

2 Drag a sound from the Library preview window directly to the Stage. 

Flash places the sound in the current frame with default sound settings.

Using the sound-editing controls
Use the sound-editing controls in the Sound panel of the Frame Properties dialog 
box to define the starting point of a sound or to control the volume of the sound 
as it plays. 

Flash can change the point at which a sound starts and stops playing. This is 
useful for making sounds smaller by removing unused sections. 
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To edit a sound with the sound editing controls:

1 Add a sound to a frame (see “Adding sounds to a movie” on page 214), or 
select a frame already containing a sound and choose Modify > Frame; then 
click Sound in the Frame Properties dialog box. 

2 Do any of the following:

 þ To change the start and end points of a sound, drag the Time In and Time 
Out controls in the Sound Frame Properties dialog box. 

 þ To change the sound envelope, drag the envelope handles on the envelope 
lines to change levels at different points in the sound. Envelope lines show the 
volume of the sound as it plays. Click on the lines to create up to eight 
envelope handles. To remove an envelope handle, drag it out of the window.

 þ To display more or less of the sound in the window, click the Zoom In/Out 
buttons. 

 þ To switch the time units between seconds and frames, click the Seconds and 
Frames buttons. 

Starting and stopping sounds at a keyframe
Starting and stopping sounds at keyframes in synchronization with animation is 
the most common sound-related task. 

Time In control Time Out control

Zoom In/Out

Seconds/Frames

Envelope linesEnvelope handles

Play

Stop
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To stop and start a sound at a keyframe:

1 Add a sound to a movie in a layer by itself. 

To synchronize this sound with an event in the scene, choose a beginning 
keyframe that corresponds to the keyframe of the event in the scene. You can 
choose any of the synchronization options. See “Adding sounds to a movie” on 
page 214.

2 Create a keyframe in the sound layer’s time strip at the frame where you want 
the sound to end.

A representation of the sound file appears in the time strip.

3 Double-click the ending keyframe and click the Sound tab in the Frame 
Properties dialog box. 

4 Choose the same sound from the Sound pop-up menu.

5 Choose Stop from the Synchronization pop-up menu.

When you play the movie, the sound stops playing when it reaches the 
ending keyframe. 

Shift-dragging the playback head repeats the streaming sound of the frame you 
are on. This is useful for aligning sounds to your animation.

Adding sounds to buttons
You can associate sounds with the different states of a button symbol. Because the 
sounds are stored with the symbol, they work for all instances of the symbol.

To add sounds to a button:

1 Select the button in the Library.

2 Choose Edit from the Symbol pop-up menu.

3 In the button’s Timeline, add a sound layer. 

4 In the sound layer, create one keyframe to correspond with each button state 
you want to have a sound. 

For example, to add a sound that plays when the button is clicked, create a 
keyframe in the frame labeled Down.

5 Add a sound to the new keyframe and choose Event from the Synchronization 
pop-up menu.

To associate a different sound with each of the button’s keyframes, use a 
different sound layer and sound file for each keyframe. You can also use the 
same sound file but create or use a different sound effect for each 
button frame.
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Exporting movies with sound
The sampling rate and degree of compression make a significant difference in the 
quality and size of sounds in exported movies. The more you compress a sound 
and the lower the sampling rate, the smaller the size and the lower the quality. You 
will have to experiment to get the best results.

Control the exported quality and size of individual sounds using the export 
settings in the Sound Properties dialog box. If there are no export settings defined 
for a sound, Flash exports the sound using the sound settings in the Publish 
Settings dialog box. See “Flash publish settings” on page 229. To override export 
settings for all the sounds in a movie, enter the sound settings in the Publish 
Settings dialog box. This option is useful if you want to create a larger high-
fidelity audio movie for local use, and a smaller low- fidelity version for the web.

Note: In Windows, you can also export all the sound from a movie as a WAV file using File > 
Export Movie. See “Using Export Movie and Export Image” on page 242.

To set export properties for an individual sound:

1 Right-click (Windows) or Control-click (Macintosh) a sound file in the 
Library window and choose Properties from the context menu. 

2 If the sound file has been edited externally, click Update.

3 Set export settings as described in “Specifying sound compression options” on 
page 220.

4 Click Test and Stop to play and stop the sound. 
Adding Sound 219



Specifying sound compression options

Use the options in the Export Settings area of the Sound Properties dialog box to 
choose sound compression options. The options available depend on the 
compression method you select. 

Default Uses the default compression settings in the Publish Settings dialog box 
when you export your movie. No additional options are available for this setting.

ADPCM Sets compression for 16-bit sound data. Use the ADPCM setting when 
you are exporting short event sounds such as button clicks. When you select 
ADPCM, Convert Stereo to Mono, Sample Rate, and ADPCM bits options 
are displayed. 

Convert Stereo to Mono Mixes stereo sounds to mono. Mono sounds are 
unaffected. 

Sample Rate Sets the export rate for the file. Higher rates yield better sound 
fidelity and larger sound files. Lower rates save disk space. Rate options, in either 
mono or stereo, are as follows: 5 kHz is barely acceptable for speech; 11 kHz is the 
lowest recommended quality for a short segment of music and is a quarter of the 
standard CD rate; 22 kHz is a popular choice for web playback and is half the 
standard CD rate; and 44 kHz is the standard compact disc (CD) audio rate. 
Flash cannot improve the quality of sounds. If a sound is recorded at 11 KHz 
mono, Flash continues to export it at 11KHz mono even if you change the 
sampling rate to 44Khz stereo.

ADPCM Bits Determines the number of bits used in ADPCM encoding. Greater 
compression rates yield smaller sound files but poorer sound fidelity. 2-bit is the 
smallest, lowest quality option; 5-bit is the largest, best quality option.

MP3 Lets you export sounds with MP3 compression. Use MP3 when you are 
exporting longer, stream sounds such as music soundtracks. When MP3 
compression is selected, Preprocessing, Bit Rate, and Quality options are available.

Bit Rate Determines the maximum bit rate of the sound produced by the MP3 
encoder. The MP3 Bit Rate parameter is only shown when you select MP3 
encoding as the compression option. When you are exporting music, set the bit 
rate to 16 Kbps or higher for the best results. The Convert Stereo to Mono option 
is not available at 16Kbps or lower. 

Quality Lets you choose between Fast, Medium, or Best. Use the Fast setting if you 
are publishing your movie on a web site. Use Medium or Best if you are running 
your movie on your hard drive, or on CD.

RAW Exports sounds with no sound compression. You can select the Convert 
Stereo to Mono option and sample rate when this setting is selected.
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Guidelines for exporting sound in movies

Aside from sampling rate and compression, there are several ways to use sound 
efficiently in a movie and keep file size down:

 þ Set the in and out point to prevent silent areas from being stored in the 
Shockwave Flash file and reduce the size of the sound.

 þ Get more out of the same sounds by applying different effects for sounds at 
different keyframes (such as volume envelopes, looping, and in/out points). 
You can get a number of sound effects using only one sound file.

 þ Use looping to extract the common part of the sound and play it repeatedly. 
Loop short sounds for background music.

Guidelines for exporting sound to video

Movies that you export as QuickTime or Windows AVI files use sound differently 
than Shockwave Flash movies; thus, file size considerations for Flash movies may 
not apply to QuickTime or AVI videos. Guidelines for exporting to video include:

 þ Use as many sounds and channels as you want without worrying about file 
size. The sounds are combined into a single sound track when you export as 
QuickTime or Windows AVI. The number of sounds you use has no effect on 
the final file size. 

 þ Use stream synchronization to keep the animation synchronized to your 
sound track when you preview your animation in the editor. If your computer 
is not fast enough to draw the animation frames so that they keep up with 
your sound track, Flash skips frames.
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Publishing and Exporting

Publishing and exporting overview
When you create a web site with Flash, you often need to include several other 
files. To open a Flash Player movie in a browser, you must first open an HTML 
document which in turn activates the Flash Player and runs the movie. In 
addition to this HTML document, you may also want to create an animated-GIF 
version of your movie, or a JPEG or GIF image to display if the Flash Player is 
not installed. 

The main file format for distributing Flash content is the Flash Player format 
(.swf ). The Flash Player format is the only one that supports all Flash interactive 
functionality. You can play a Flash Player movie in the following ways:

 þ In Internet browsers such as Netscape and Internet Explorer that are equipped 
with the Flash Player

 þ With the Flash Xtra in Director and Authorware

 þ With the Flash Active X control in Microsoft Office and other Active X hosts

 þ As part of a QuickTime movie

 þ As a type of stand-alone application called a projector

The Flash Player file format is an open standard and may be supported by other 
applications in the future. Consult the Macromedia web site for the latest 
information.

In addition to the Flash Player format, you can export moving and still images 
from Flash in a variety of formats, including GIF, JPEG, PNG, BMP, PICT, 
QuickTime, or AVI. 
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Use the Publish command to create the files you need for a Flash web application 
all at once with a single command. Publish generates not only a Flash Player file, 
but graphic files in many formats usable as alternate images, and an HTML 
document with all the settings required to play your movie. 

If you want to quickly export a single file of a certain type, use the Export 
command. Export options are oriented towards providing Flash content for 
modification in other applications. You can export an entire movie as a Flash 
Player file or as a series of bitmap images. You can also export a single frame or 
image as an image file. 

Instead of using Publish, you can also create your own HTML document with any 
HTML editor and include the tags required to display a Flash movie.

Before you complete the publishing process, you can test how a movie works with 
Test Movie and Test Scene. 

Note: To alter or update a Flash Player movie created with Publish, edit the original Flash 
movie and then use Publish again. Flash Player movies imported into Flash lose some of the 
authoring environment information. 
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Optimizing movies
As part of the publishing process, Flash automatically detects duplicate shapes on 
export and places them in the file only once, and converts nested groups into 
single groups.

You can further reduce a movie’s size before exporting it to minimize downloading 
time by doing any of the following:

 þ Use symbols, animated or otherwise, for every element that appears more 
than once. 

 þ Whenever possible, use tweened animations, which require less overhead than 
a series of keyframes.

 þ Limit the number of special line types such as dashed, dotted, ragged, and so 
on. Solid lines are smaller. Lines created with the pencil tool require less 
memory than brush strokes.

 þ Use layers to separate elements that change over the course of the animation 
from those that do not.

 þ Use Modify > Curves > Optimize to minimize the number of separate lines 
that are used to describe shapes.

 þ Limit the number of fonts and font styles. 

 þ When including text fields, use the Include Only Specified Font Outlines 
option in Text Field properties instead of Include All Font Outlines.

 þ MP3 is the smallest format for sound. Use it as much as possible.

 þ Embedded fonts increase file size. Use them sparingly.

 þ Avoid animating bitmap elements; use bitmap images as background or 
static elements.

 þ Limit the area of change in each keyframe; make the action take place in as 
small an area as possible.

 þ Group elements as much as possible.

 þ Use the Color Effects pop-up menu in the Instance Properties dialog box to 
create many different colored instances of a single symbol.

 þ Use the Colors window to match the color palette of the movie to a browser-
specific palette.

 þ Use gradients sparingly. Filling an area with gradient color requires about 50 
bytes more than filling it with solid color.

As you make changes, test your movie on a variety of different computers, 
operating systems, and Internet connections.
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Testing movie download performance
Test movies to find places where pauses may occur during downloading. If 
required data has not downloaded by the time the movie reaches a frame, the 
movie pauses until the data arrives. The Bandwidth Profiler graphically compares 
how much data must be sent for each frame in the movie according to the defined 
modem speed. 

In simulating the speed of downloading, the Bandwidth Profiler uses estimates of 
typical Internet performance, not the exact speed of the modem. For example, a 
28.8 Kbps modem can theoretically download data at 3.5 Kbytes/second, but 
when you choose 28.8 from the Control menu, Flash sets the actual rate to 2.3 
Kbytes/second in order to more accurately simulate typical Internet performance. 

You test either a single scene or an entire movie. Choose File > Publish Settings to 
change the settings for the Flash Player file created by Test Movie and Test Scene. 
See Previewing and testing movies.

To test downloading performance:

1 Choose Control > Test Scene or Control > Test Movie.

Flash exports the current scene or movie as an SWF file and opens the 
SWF file in a new window. It uses the export settings defined in the Publish 
Setting dialog box. See Publishing Flash movies. The movie begins playing 
immediately. 

2 Choose a downloading speed from the View menu to determine the 
downloading rate that Flash simulates: Choose 14.4 Kbps, 28.8 Kbps, or 56 
Kbps; or choose Customize and enter your own settings.
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3 Choose View > Bandwidth Profiler to see a graph of the downloading 
performance.

Each alternating light and dark block is an individual frame of the movie. The 
size of the block corresponds to that frame's size in bytes. If a block goes above 
the red line, the movie must wait for that frame to load. 

In streaming mode the header indicates the number of frames loaded along 
with the frame currently playing. 

4 Stop the movie and click the shaded bands in the graph to see settings for a 
particular frame in the area on the left.

5 While viewing the graph, adjust the view:

 þ Choose Control > Show Streaming to turn the streaming bar off or on.

 þ Choose View > Streaming Graph to see which frames will cause pauses. 

 þ Choose View > Frame by Frame to see the size of each frame.

6 Close the test window to return to the normal authoring environment.

You can also choose File > Open to test an existing SWF file. 

Streaming bar

Frames above this line 
cause loading delays
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Publishing Flash movies
Use the Publish command to prepare all the required files for a complete Flash 
application on the web. Publish prepares not only the Flash movie itself for the 
web, but creates alternate images in a variety of formats that display automatically 
if a Flash player is not available. Publish creates the supporting HTML document 
required to display a movie (or an alternate image) in a browser and control 
browser settings. Publish can also create stand-alone projectors for both Windows 
and Macintosh systems and QuickTime videos from Flash movies. 

Before publishing, use the Publish Settings command to choose formats and 
specify settings. Once you have entered all the necessary Publish Settings options, 
you can repeatedly export to all selected formats at once by simply choosing File > 
Publish. Flash stores the Publish Setting you specify with the movie file, so each 
file can have its own settings.

To publish a movie:

1 Choose File > Publish Settings.

2 Select the option for each file format you want to create. 

When you select a format for which Flash offers additional settings, a new tab 
appears above the current panel in the dialog box. Note that Windows and 
Macintosh projector options have no settings and therefore do not have their 
own tabs in the Publish Setting dialog box. When you choose an image format 
such as GIF, JPEG, or PNG, Flash automatically add the required HTML 
code to display the image if the Flash player is not available. 

3 Enter a unique name for file, or select Use Default Name to create each file 
using the Flash file’s name with the extension appropriate for that format.

4 Click the tab for the format options you want to change. Specify publish 
settings for each format as described in the following sections. Click Publish to 
generate all the specified files when you’re done, or click OK to close the 
dialog box without publishing.

Flash generates the files as specified in Publish Settings. Choose File > Publish 
to immediately publish files in all specified formats using the current 
publish settings.
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Flash publish settings
Use the Flash panel in the Publish Settings dialog box to set options for the Flash 
Player movie that is created in the Publish process. You can choose several options 
when exporting a Flash Player movie, including image and sound compression 
options, and an option to protect your movie from being imported.

Use the controls in the Flash panel of the Publish Settings dialog box to change 
the following settings:

Load Order Determines how layers are loaded for the first frame. Over a slow 
network or modem connection, Flash draws parts of the movie as they become 
available. Use this option to determine what will appear first when the movie 
downloads. Load order affects only the first frame.

Generate Size Report Produces a text file useful as a guide for minimizing the file 
size of the movie. This size report shows how many bytes various parts of your 
movie use in the final Flash Player file. The report has the same name as the 
exported movie, but with a .txt extension. 

Protect From Import Prevents the Flash Player movie from being downloaded 
from the web and imported back into Flash.

Omit Trace Actions Makes Flash ignore the Trace statement in the current movie. 
Trace causes Flash to open an output window to display certain content. 

JPEG Quality Determines the amount of JPEG file compression applied to any 
bitmaps contained in your file. Lower image quality produces smaller files, while 
higher image quality produces larger files. Experiment with different settings to 
determine the best trade-off between size and quality: 100 provides the highest 
quality and least compression. If the exported image contains no bitmaps, this 
setting has no effect.

Audio Stream and Audio Event Specify the rate and compression for exported 
stream and event sounds, respectively. (If you don’t understand the difference 
between stream and event sounds, see Adding sound overview.) These settings 
apply only if you have not specified settings for individual sounds in the Sound 
Properties dialog box, or if you have turned on the Override Sound Settings 
option. The settings are identical to the settings for individual sounds in the 
Sound Properties dialog box. See Exporting movies with sound. If the movie has 
no streamed sounds, this setting has no effect. 

Override Sound Settings Makes the settings in this dialog box override settings 
defined in the Sound Properties dialog box for individual sounds. This option is 
useful if you want to create a larger high fidelity audio movie for local use, and 
smaller low fidelity version for the web. See “Exporting movies with sound” on 
page 219. 

Version Specifies which version of the Flash Player the exported movie will play 
back on. Flash 4 features do not work in movies exported in earlier versions.
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HTML publish settings
To play a Flash movie in a web browser, you must create an HTML document 
that activates the movie and specifies browser settings. You can use Publish to 
generate the required HTML document automatically. 

There are HTML parameters that determine where the Flash movie appears in the 
window, the background color, the size of the movie, and so on. You can change 
these and other settings with the options in the HTML panel of the Publish 
Settings dialog box. 

Flash inserts the HTML parameters you specify in a template document. The 
template document can be any text file that contains the appropriate template 
variables. A template can be a plain HTML file, or one that also includes code for 
special interpreters such as Cold Fusion or ASP. You select a template to use from 
several included with Flash. There are basic templates that simply display the 
movie in a browser, and more advanced templates containing code for browser 
detection and other features. You can use included templates, or create your own. 
See “Creating templates for HTML publishing” on page 247.

Note: You can also manually enter HTML parameters for Flash using any HTML editor. See 
“About Flash HTML requirements” on page 251.

Many of the settings Flash modifies are parameters of the OBJECT and EMBED tags. 
OBJECT is the HTML tag that opens a Flash movie in Internet Explorer; EMBED is 
the Netscape equivalent. 

Use the controls in the HTML panel of the Publish Setting dialog box to change 
the following settings:

Template Specifies which of the installed templates to use. All of the template files 
in the HTML folder in the Flash application folder appear on the pop-up menu. 
For a description of each template, select a template from the pop-up menu and 
click the Info button to the right. If you don’t choose a template Flash uses a 
template named Default.html. If Default.html is not present, Flash uses the first 
template on the list. 

Flash saves the modified template using the file name of the Flash movie with the 
extension of the template. For example, if you select a template named 
Standard.asp for use with a Flash movie named MyMovie.swf, the resulting file 
would be named MyMovie.asp. 

Dimensions Sets the values of the WIDTH and HEIGHT attributes in the OBJECT 
and EMBED tags. There are three options on the pop-up menu.

 þ Match Movie sets the dimensions to the size of the movie. This is the 
default setting.

 þ Pixels lets you enter the number of pixels in the Width and Height field.

 þ Percent lets you set the movie dimensions relative to the browser window. 
Enter percentage values in the Width and Height fields.
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Playback Assigns values to the LOOP, PLAY, MENU, and DEVICE FONT parameters in 
the OBJECT and EMBED tags.

 þ Paused at Start sets the PLAY parameter to FALSE and pauses the movie until the 
visitor initiates play, either by clicking a button in the movie or by choosing 
Play from the shortcut menu. Paused at Start is off by default so that the 
movie begins to play as soon as it is loaded.

 þ Loop sets the LOOP parameter to TRUE and repeats the movie when it reaches 
the last frame. Deselect this option to stop the movie when it reaches the last 
frame. Loop is on by default.

 þ Display Menu sets the MENU parameter to TRUE, making a shortcut menu 
available to users when they right-click (Windows) or Command-click 
(Macintosh) on the movie. Display Menu is on by default. Deselect the 
Display Menu option if you want About Flash to be the only available option 
in the shortcut menu.

 þ Device Font (Windows only) sets the DEVICE FONT parameter to TRUE and 
substitutes anti-aliased system fonts for fonts that are not installed on the 
user’s system. Device Font is off by default.

Quality Sets the value of the QUALITY parameter in the OBJECT and EMBED tags and 
determines the level of anti-aliasing performed. Because anti-aliasing requires a 
faster processor to smooth each frame of the movie before it is rendered on the 
viewer’s screen, the QUALITY parameter assigns priorities to appearance and 
playback speed. 

 þ Low gives priority to playback speed over appearance. With this setting, anti-
aliasing is never used.

 þ Autolow emphasizes speed at first, but improves appearance whenever 
possible. Playback begins with anti-aliasing turned off. If the Flash player 
detects that the processor can handle it, anti-aliasing is turned on.

 þ Autohigh emphasizes playback speed and appearance equally at first, but 
sacrifices appearance for the sake of playback speed if necessary. Playback 
begins with anti-aliasing turned on. If the actual frame rate drops below the 
specified frame rate, anti-aliasing is turned off to improve playback speed. Use 
this setting to emulate the View > Antialias setting in Flash. 

 þ High gives priority to appearance over playback speed. With this setting, anti-
aliasing is always used. If the movie does not contain animation, bitmaps are 
smoothed; if there is animation, bitmaps are not smoothed. High is the 
default setting for Quality.

 þ Best provides the best display quality and does not consider playback speed. 
All output is antialiased and all bitmaps are always smoothed.
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Window Mode (Windows only) Sets the WMODE parameter of the OBJECT tag, 
which lets you take advantage of the transparent movie, absolute positioning, and 
layering capabilities available in Internet Explorer 4.0. This option works only in 
the Windows version of Internet Explorer with the Flash Active X control.

 þ Window sets the WMODE parameter value to WINDOW and plays a Flash Player 
movie in its own rectangular window on a web page. This setting normally 
provides the fastest animation performance.

 þ Opaque Windowless sets the WMODE parameter value to OPAQUE. Use 
this setting if you want to move elements behind Flash movies (for example, 
with dynamic HTML) and don’t want them to show through.

 þ Transparent Windowless sets the WMODE parameter to TRANSPARENT. 
Use this setting to make the background of the HTML page on which the 
movie is embedded show through all the transparent potions of the movie. 
Animation performance might be slower when you use this setting. 

Alignment Specifies the ALIGN attribute for the OBJECT, EMBED, and IMG 
tags and determines how the Flash movie window is positioned within the 
browser window. 

 þ Default centers the movie in the browser window and crops edges if the 
browser window is smaller than the movie.

 þ Left aligns the movie along the left edge of the browser window and crops the 
top, bottom, and right sides as necessary. 

 þ Right aligns the movie along the right edge of the browser window and crops 
the top, bottom, and left sides as necessary. 

 þ Top aligns the movie along the top edge of the browser window and crops the 
bottom, left, and right sides as necessary. 

 þ Bottom aligns the movie along the bottom edge of the browser window and 
crops the top, left, and right sides as necessary.

Scale Determines the value of the SCALE parameter in the OBJECT and EMBED tags 
and defines how the movie is placed within the boundaries you specify in the 
Width and Height fields. These settings apply only if you enter a width and height 
setting different from the movie’s original size.

 þ Default (Show all) makes the entire movie visible in the specified area while 
maintaining the original aspect ratio of the movie. No distortion occurs. 
Borders may appear on two sides of the movie.

 þ No Border scales the movie to fill the specified area while maintaining the 
original aspect ratio of the movie. No distortion occurs. Portions of the movie 
might be cropped.

 þ Exact Fit makes the entire movie visible in the specified area. However, no 
attempt is made to preserve the original aspect ratio, and distortion may occur.
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Flash Alignment Sets the SALIGN parameter of the OBJECT and EMBED tags. The 
settings you choose from the Horizontal and Vertical pop-up menu determine 
how the movie is placed within the movie window and, if it must be cropped 
to fit that window, how it is cropped. Choose Left, Center or Right from the 
Horizontal pop-up menu; and Top, Center, or Bottom from the Vertical 
pop-up menu. 

Show Warning Messages Determines if Flash displays error messages warning of 
conflicts in tag settings. For example, with this option on an error message would 
appear if a template includes code referring to an alternate image that you have 
not specified. 

GIF publish settings
GIF files provide an easy way to export drawings and simple animations for use in 
web pages. Standard GIF files are simply compressed bitmaps.

An animated GIF (sometimes referred to as a GIF89a) offers a simple way to 
export short animation sequences. Flash optimizes an animated GIF, storing only 
frame-to-frame changes. 

Flash exports the first frame in the movie as a GIF, unless you mark a different 
keyframe for export by entering the frame label #Static. Flash exports all the 
frames in the current movie to an animated GIF unless you specify a range 
of frames for export by entering the frame labels #First and #Last in the 
appropriate keyframes. 

Flash can generate an image map for a GIF so buttons that link to URLs in the 
original movie continue to function as links in the image. Place the frame label 
#Map in the keyframe in which you want to create the image map. If you don’t 
create a frame label, Flash creates an image map using the buttons in the last frame 
of the movie. To create an image map the $IM template variable must be present in 
the template you select. See “Creating an image map” on page 250. 

Use the controls in the GIF panel of the Publish Settings dialog box to change the 
following settings:

Dimensions Sets the size of the exported bitmap image to the number of pixels 
you enter in the Width and Height fields. If you turn on Match Movie, the entries 
in the Width and Height fields have no effect and Flash makes the GIF the same 
size as the movie. Flash ensures that the size you specify always has the same aspect 
ratio as your original image. 

Playback Determines if Flash creates a static image, or an animation. Click Static 
to export a still image. Click Animated to export an animated GIF. If you choose 
Animated, choose either Loop Continuously, or enter a number of repetitions. 
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Options Specify a range of appearance settings for the exported GIF. 

 þ Optimize Colors removes any unused colors from the color table of a GIF file. 
This can reduce the size of a GIF file by 1000-1500 bytes with no sacrifice in 
image quality. It does, however, cause a small increase in the memory 
requirements. Note that this option has no effect with an Adaptive palette. 

 þ Smooth enables or disables anti-aliasing in the exported bitmap. Smoothing 
produces a higher-quality bitmapped image. Text display quality is poor 
without anti-aliasing. However, a halo of gray pixels may appear around 
an anti-aliased image placed on a colored background. Export without 
smoothing if a halo appears, or if you are creating a transparent GIF that 
will be placed over a multicolored background. Turning this option off makes 
GIF files smaller. 

 þ Interlace makes the exported GIF display in a browser incrementally as it 
downloads. An interlaced GIF provides the user with basic graphic content 
before the file has completely downloaded and may download faster over a 
slow network connection. Do not interlace an animated GIF.

 þ Dither Solids applies dithering to solid colors as well as gradients and images. 
See the definition of dithering that follows.

 þ Remove Gradients converts all gradients fills in the movie to solid colors using 
the first color in the gradient. Gradients increase the size of a GIF and often 
are of poor quality. When using this option you must choose the first color of 
your gradients carefully to prevent unexpected results. The default is false.

Transparent Determines how the background of a movie and alpha (transparency) 
settings in Flash are converted to GIF. Choose one of the following options from 
the pop-up menu:

 þ Opaque makes the background of the movie opaque.

 þ Transparent makes the background transparent.

 þ Alpha makes all the colors below the threshold alpha value completely 
transparent (invisible). Colors with alpha values above the threshold are left as 
they are. Enter a value between 0 and 255 in the Threshold box to the right. A 
value of 128 corresponds to 50% alpha. 
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Dither Enables or disables dithering and specifies the method. Dithering displays 
pixels of a range of similar colors to simulate colors not available in the current 
palette. With dithering off, Flash replaces colors not in the basic color table with 
the solid color from the table that most closely approximates the specified color; 
not dithering can produce smaller files, but check the results to see if the colors are 
satisfactory. Dithering can help if a transparent image contains artifacts. Dithering 
increases the files size. Choose from the following dithering options:

 þ None disables dithering. 

 þ Ordered provides good quality dithering with the least possible file 
size increase. 

 þ Diffusion provides the best quality dithering but increases file size and 
processing time more than Ordered dithering. It also only works with the Web 
216 color palette selected.

Palette Type Defines the color palette to use for the image. Choose from the 
following options:

 þ Web 216 uses the standard 216 color browser-safe color palette to create 
the GIF image. This provides good image quality and the fastest processing 
on the server. 

 þ Adaptive analyzes the colors in the image and creates a unique color table for 
the particular GIF. This creates the most accurate color for the image but the 
resulting file size is larger than a GIF created with the Web 216 palette. You 
can reduce the size of a GIF created with an adaptive palette by decreasing 
the number of colors in the palette (see the Max Colors option that follows). 
An adaptive palette works best for systems displaying thousands or millions 
of colors. 

 þ Web Snap Adaptive is the same as the Adaptive palette option except that it 
converts close colors to the Web 216 color palette. The resulting color palette 
is optimized for the image, but when possible, Flash uses colors from Web 
216. This produces better colors for the image when the Web 216 palette is 
active on a 256-color system. 

 þ Custom lets you specify a palette that you have optimized for the current 
image. This provides the same processing speed as the Web 216 palette. To use 
this option you must be familiar with creating and using custom palettes. To 
choose a custom palette, click the button labeled with the ellipsis (...) to the 
right of the Palette box at the bottom of the dialog box and select a palette file. 
Flash supports palettes saved in the ACT format. This is the same format 
exported by Macromedia Fireworks and other leading graphics applications.

Max Colors Sets the number of colors used in the GIF image. Choosing a smaller 
number of colors can produce a smaller file, but may degrade the colors in the 
image. You can specify a value for the maximum colors only when you have 
selected Adaptive or Web Snap as the Palette Type option.
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JPEG publish settings
Use the JPEG format to save an image as highly compressed, 24-bit bitmap. 
Generally, GIF is better for exporting line art, while JPEG may be better for 
images that include a number of gradients, or embedded bitmaps.

Flash exports the first frame in the movie as a JPEG, unless you mark a different 
keyframe for export by entering the frame label #Static. 

Use the controls in the JPEG panel of the Publish Setting dialog box to change the 
following settings:

Dimensions Sets the size of the exported bitmap image to the number of pixels 
you enter in the Width and Height fields. If you turn on Match Movie, the entries 
in the Width and Height fields have no effect and Flash makes the JPEG the same 
size as the movie. Flash ensures that the size you specify always has the same aspect 
ratio as your original image. 

Quality Controls the amount of JPEG file compression used. Lower image quality 
produces smaller files, while higher image quality produces larger files. Try 
different settings to determine the best trade-off between size and quality.

Progressive Displays Progressive JPEG images. These images are displayed 
incrementally by a web browser and may appear faster when loaded over a 
slow network connection. This option is similar to interlacing in GIF and 
PNG images.

PNG publish settings
PNG is the only cross-platform bitmap format that supports transparency (alpha 
channel). It is also the native file format for Macromedia Fireworks. 

Flash exports the first frame in the movie as a PNG, unless you mark a different 
keyframe for export by entering the frame label #Static. 

Use the controls in the PNG panel of the Publish Settings dialog box to change 
the following settings:

Dimensions Sets the size of the exported bitmap image to the number of pixels 
you enter in the Width and Height fields. If you turn on Match Movie, the entries 
in the Width and Height fields have no effect and Flash makes the PNG the same 
size as the movie. Flash ensures that the size you specify always has the same aspect 
ratio as your original image. 

Bit Depth Specifies the number of bits per pixel to use in creating the image. The 
bit depth determines the number of colors to be used in the image. For a 256-
color image, choose 8-bit; for thousands of colors, choose 24-bit; for thousands of 
colors with transparency (32 bits) choose 24-bit with Alpha. The higher the bit 
depth, the larger the file. 
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Options Specify a range of appearance settings for the exported PNG. 

 þ Optimize Colors removes any unused colors from the color table of a PNG 
file. This can reduce the size of a PNG file by 1000-1500 bytes with no 
sacrifice in image quality. It does, however, cause a small increase in the 
memory requirements and processing required on the server. Note that this 
option has no effect with an adaptive palette. 

 þ Smooth enables or disables anti-aliasing in the exported bitmap. Smoothing 
produces a higher quality bitmapped image. Text display quality is poor 
without anti-aliasing. However, a halo of gray pixels may appear around an 
image placed on a colored background. Export without smoothing if a halo 
appears, or if you are creating a transparent PNG that will be placed over a 
multicolored background. Turning this option off makes PNG files smaller. 

 þ Interlace makes the exported PNG display in a browser incrementally as it 
downloads. An interlaced PNG provides the user with basic graphic content 
before the file has completely downloaded and may download faster over a 
slow network connection.

 þ Dither Solids applies dithering to solid colors as well as gradients and images. 
see the definition of dithering that follows.

 þ Transparent displays a transparent PNG. A transparent PNG allows the 
background of your web browser to show through the portions of the PNG 
where you have not drawn any images. If you create a transparent PNG, set 
the background color by choosing Modify > Movie to match the web page 
background. Use the Smooth options to further optimize the color match.

 þ Remove Gradients converts all gradient fills in the movie to solid colors using 
the first color in the gradient. Gradients increase the size of a PNG and often 
are of poor quality. When using this option you must choose the first color of 
your gradients carefully to prevent unexpected results. The default is false.
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Dither Enables or disables dithering and specifies the method. Dithering displays 
pixels of a range of similar colors to simulate colors not available in the current 
palette. With dithering off, Flash replaces colors not in the basic color table with 
the solid color from the table that most closely approximates the specified color; 
not dithering can produce smaller files, but check the results to see if the colors are 
satisfactory. Dithering can help if a transparent image contains artifacts. Dithering 
increases the files size. Choose from the following dithering options:

 þ None disables dithering. 

 þ Ordered provides good quality dithering with the least possible file 
size increase. 

 þ Diffusion provides the best quality dithering but increases file size more than 
Ordered dithering. It also only works with the Web 216 color palette selected.

Palette Type Defines the color palette to use for the image. Choose from the 
following options:

 þ Web 216 uses the standard 216-color browser-safe color palette to create the 
PNG image. This provides good image quality and the fewest color problems 
in all types of browsers. 

 þ Adaptive analyzes the colors in the image and creates a unique color table 
for the particular PNG. This creates the most accurate color for the image but 
the resulting file size is larger than a PNG created with the Web 216 palette. 
You can reduce the size of a PNG created with an adaptive palette by 
decreasing the number of colors in the palette (see the Max Colors option that 
follows). An adaptive palette works best for systems displaying thousands or 
millions of colors. 

 þ Web Snap Adaptive is the same as the Adaptive palette option except that it 
"snaps" close colors to the Web 216 color palette. The resulting color palette is 
optimized for the image, but when possible, Flash uses colors from Web 216. 
This produces better colors for the image when the Web 216 palette is active 
on a 256-color system. 

 þ Custom lets you specify a palette that you have optimized for the current 
image. To use this option you must be familiar with creating and using custom 
palettes. To choose a custom palette, click “..." to the right of the Palette box at 
the bottom of the dialog box and select a palette file. Flash supports palettes 
saved in the ACT format. This is the same format exported by Macromedia 
Fireworks and other leading graphics applications.

Max Colors Sets the number of colors used in the PNG image. Choosing a smaller 
number of colors can produce a smaller file, but may degrade the colors in the 
image. You can specify a value for the maximum colors only when you have 
selected Adaptive or Web Snap as the Palette Type option.
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Filter Options Specifies the filtering method for the PNG. Prior to compression, a 
PNG image is filtered line-by-line to make it more compressible. Compare the 
results of the different options to see which works best for a particular image. The 
choices are the standard PNG filtering options: 

 þ None provides no filtering.

 þ Sub transmits the difference between each byte and the value of the 
corresponding byte of the prior pixel.

 þ Up transmits the difference between each byte and the value of the 
corresponding byte of the pixel immediately above. 

 þ Average uses the average of the two neighboring pixels (left and above) to 
predict the value of a pixel.

 þ Paeth computes a simple linear function of the three neighboring pixels (left, 
above, upper left), then chooses as predictor the neighboring pixel closest to 
the computed value.

QuickTime publish settings
The QuickTime publish option creates movies in the QuickTime 4 format. When 
Flash creates a QuickTime file, it copies the Flash movie on a separate track. The 
Flash movie plays in the QuickTime movie exactly as it does in the Flash Player, 
retaining all of its interactive features. If the Flash movie contains a QuickTime 
movie, Flash copies it to a separate track in the new QuickTime file. 

Use the controls in the QuickTime panel of the Publish Settings dialog box to 
change the following settings:

Dimensions Sets the size of the exported QuickTime movie to the number of 
pixels you enter in the Width and Height fields. If you turn on Match Movie, the 
entries in the Width and Height fields have no effect and Flash makes the new 
movie the same size as the Flash movie. 

Alpha Determines the alpha (transparency) mode of the Flash track in the 
QuickTime movie. Note that this does not affect any alpha settings within the 
Flash movie itself. The choices are as follows:

 þ Alpha Transparent makes the Flash track transparent. Any content in tracks 
behind the Flash track are visible. 

 þ Copy makes the Flash track opaque. All content in tracks behind the Flash 
track is masked.

 þ Auto makes the Flash track transparent if it is on top of any other tracks, but 
makes it opaque if it is the bottom track, or the only track in the movie.
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Layer Defines where the Flash track will be placed in the QuickTime movie. The 
choices are as follows:

 þ Top always places the Flash track on top of other tracks in the 
QuickTime movie.

 þ Bottom always places the Flash track behind other tracks.

 þ Auto places the Flash track in front of other tracks if there are Flash object in 
front of video objects within the Flash movie. Otherwise, it places the Flash 
movie behind all other tracks. 

Streaming Sound Makes Flash export all of the streaming audio in the Flash movie 
to a QuickTime sound track. It recompresses the audio using the standard 
QuickTime audio settings. Click Audio Settings to change these options. See the 
QuickTime documentation for a description. 

Controller Specifies the type of QuickTime controller used to play the exported 
movie. The choices are None, Standard, or QuickTime VR. 

Looping Determines whether or not the QuickTime movie loops continuously.

Pause At Start Specifies whether or not the QuickTime movie starts automatically 
when it is opened.

Play Every Frame Makes QuickTime shows every frame of the movie without 
skipping to maintain time. When this option is set in a QuickTime movie, sound 
is not played.

Flatten (Make Self-Contained) Combines the Flash content and imported video 
content into the new QuickTime movie. When this option is not set, the new 
QuickTime movie references the imported files externally; these files must be 
present for the movie to work properly. 

Creating projectors with Publish
Use Publish to create projectors for both Windows and Macintosh systems. There 
are no settings to specify for creating projectors.

Although you can create a Macintosh projector using the Windows versions of 
Flash, you must convert the resulting file use a file translator such as BinHex to 
make it appear as an application file in the Macintosh Finder. The Windows 
version of Flash names a Macintosh projector file with a .hqx extension. 

Using Publish Preview
Publish Preview exports the type of file you select from the Publish Preview menu 
and opens it in the default browser. If you preview a QuickTime movie, Publish 
Preview launches the QuickTime Movie Player. If you preview a projector, Flash 
launches the projector. 
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The Publish Preview menu displays the formats you select in the Publish Settings 
dialog box. It also export all formats using the current Publish Settings options. 

To preview a file with Publish Preview:

1 Use Publish Settings to define export options.

2 Choose File > Publish Preview and then select the file format you want to 
preview from the submenu.

Using the current Publish Settings values, Flash creates a file of the specified 
type in the same location as the Flash movie file. This file remains in this 
location until you overwrite or delete it.

Press F12 to export and preview the default format. 

Using the stand-alone player
The stand-alone player plays Flash Player movies exactly as they appear in a web 
browser or an Active X host application. The stand-alone player is installed along 
with Flash so that when you double-click a Flash Player file, the operating system 
starts the stand-alone player, which in turn runs the movie. 

There are a number of FS Command options for controlling movies in the 
stand-alone player. For example, to make the stand-alone player take over the 
whole screen, assign the FS Command action to a frame or button and enter 
FullScreen as the command and True as the argument. See Sending messages to the 
movie’s host program.

The file names of the stand-alone player are:

 þ Windows: FlashPla.exe

 þ Macintosh: FlashPlayer

While the stand-alone player is running you can do the following:

 þ Open a new file by choosing File > Open.

 þ Change your view of the movie by choosing Zoom > Show All, Zoom In/Out, 
or 100%.

 þ Make the movie take over the entire screen by choosing View > Full Screen.

 þ Control movie playback by choosing Control > Play, Rewind, Loop, Pause, or 
Fast Forward. 

 þ Create a stand-alone projector by choosing File > Create Projector. 
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Using Export Movie and Export Image
Use Export to prepare Flash content for use in other applications. Unlike Publish, 
you can only specify settings for one type of media each time you use Export 
Movie or Export Image. Also, Flash does not store Export settings separately with 
each file as it does with Publish Settings. (Use Publish to create all the files you 
need to put a Flash movie on the web. See Publishing Flash movies.)

Use the Export Movies command to export the complete content of the current 
Flash Movie to one of the supported file types. If you use Export Movie to export 
a Flash movie to one of the still image formats, Export creates a numbered image 
file for every frame in the movie. You can also use Export Movie to export the 
sound in a movie to a WAV file (Windows only).

Use Export Image to export the content of the current frame or the currently 
selected image to one of the still-image formats, or to a single-frame 
Flash Player movie. 

 þ When you export a Flash image as a vector-graphic file (Illustrator), you 
preserve its vector information. You can edit these files in other vector-based 
drawing programs, but you can’t import these images into most page-layout 
and word-processing programs.

 þ When you save a Flash image as a bitmap GIF, JPEG, PICT (Macintosh), or 
BMP (Windows) file, the image loses its vector information and is saved with 
pixel information only. You can edit Flash images exported as bitmaps in 
image editors such as Photoshop, but you can no longer edit them in vector-
based drawing programs.

To use Export Movie or Export Image:

1 If you are exporting an image, select the frame or image in the current movie 
that you want to export.

2 Choose File > Export Movie, or File > Export Image.

3 Enter a name for the output file.

4 Choose the type of file from the Format pop-up menu.

5 Click Save. 

If the format you selected requires more information, an Export dialog 
box appears. 

6 Set the export options for the format you selected and click OK.

See the following sections for descriptions of Export options. 

7 Click Save. 
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The Export options for a Flash movie are identical to the Publish Settings options, 
see “Flash publish settings” on page 229. For a description of other options, see 
About export file formats.

About export file formats
This table shows the export file types recognized by each platform.

PNG is the only cross-platform bitmap format that supports transparency (as an 
alpha channel). Some nonbitmapped export formats do not support alpha 
(transparency) effects or mask layers.

For more information on a specific file format, see the sections that follow.

Adobe Illustrator

The Adobe Illustrator format is ideal for exchanging drawings between Flash and 
other drawing applications such as FreeHand. This format supports very accurate 
conversion of curve, line style, and fill information. Flash supports import and 
export of the Adobe Illustrator 88, 3.0, 5.0, and 6.0 formats. (See Using Adobe 
Illustrator files.) Flash does not support the Photoshop EPS format or EPS files 
generated using Print.

File type Extension Windows Macintosh

Adobe Illustrator; EPS (Version 
6.0 or earlier)

.eps and .ai ✔ ✔

Bitmap (BMP) .bmp ✔

Enhanced Metafile .emf ✔

FutureSplash Player .spl ✔ ✔

GIF publish settings .gif ✔ ✔

JPEG publish settings .jpg ✔ ✔

QuickTime publish settings .mov ✔ ✔

QuickTime Video (Macintosh) .mov ✔ ✔

PICT (Macintosh) ✔

PNG publish settings .png ✔ ✔

Windows AVI (Windows) .avi ✔

Windows Metafile .wmf ✔

WAV audio (Windows) .wav ✔
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Most Windows drawing programs support only Adobe Illustrator 88 or 3 
versions. Versions of the Adobe Illustrator format before 5 do not support 
gradient fills, and only version 6 supports bitmaps. 

The Export Adobe Illustrator dialog box contains a single option for choosing the 
version of the file format the choices are:

 þ Adobe Illustrator 88

 þ Adobe Illustrator 3.0

 þ Adobe Illustrator 5.0

 þ Adobe Illustrator 6.0

Bitmap (BMP)

Use the Bitmap format to export Flash drawings into programs that accept 
bitmapped images.

The Bitmap Export options dialog box contains the following options:

Dimensions Sets the size of the exported bitmap image specified in pixels. 
Flash ensures that the size you specify always has the same aspect ratio as your 
original image. 

Resolution Sets the resolution of the exported bitmap image in dots per inch (dpi) 
and Flash automatically calculates width and height based on the size of your 
drawing. The Match Screen button sets resolution to match your monitor. Use 
Resolution as an alternative to Dimensions.

Include Sets the size of the exported bitmap image according to the option you 
choose. If you choose Minimum Image Area from the Include pop-up menu, the 
dimensions of the bitmap are just large enough to enclose all elements in the 
frame; if you choose Full Document Size, the dimensions match those specified in 
the Movie Properties dialog box, (accessed by choosing Modify > Movie). Use 
Include as an alternative to Dimensions.

Note: When exporting a sequence of bitmaps, the dimensions always match the movie size.

Color Depth Specifies the bit depth of the image. Many Windows applications do 
not yet support the newer 32-bit depth for bitmapped images. If you have 
problems using this format, simply use the older 24-bit format.

Smooth Turns Flash anti-aliasing on and off in the exported bitmap. Smoothing 
produces a higher quality bitmapped image. However, a halo of gray pixels may 
appear around an image placed on a colored background. Export without 
smoothing if a halo appears.
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Enhanced Metafile

Enhanced Metafile Format (EMF) is a graphics format available in Windows 95 
and Windows NT that saves both vector and pixel information. Enhanced 
Metafile supports the curves used in Flash drawings better than the older 
Windows Metafile format. However, many applications do not yet support this 
newer graphics format.

There are no definable exporting options for the Enhanced Metafile format.

EPS 3.0 with Preview

You can export the current frame as an EPS 3.0 file for placement in another 
application, such as a page-layout document. The EPS file includes a preview that 
is used for placement display.

There are no definable exporting options for EPS files.

PICT (Macintosh)

PICT is the standard graphics format on the Macintosh and can contain bitmap 
or vector information.

The PICT Export options dialog box contains the following options:

Dimensions Is the size of the exported bitmap image specified in pixels. 
Flash ensures that the size you specify always has the same aspect ratio as your 
original image. 

Resolution Is specified in dots per inch (dpi), and Flash automatically calculates 
width and height based on the size of your drawing. The Match Screen button sets 
resolution to match your monitor. Normally, bitmap PICT images with 72-dpi 
resolution look best on-screen.

Include Options are Minimum Image Area from the Include pop-up menu, which 
sets the dimensions of the bitmap just large enough to enclose all elements in the 
frame; and Full Document Size, which matches the dimensions to those specified 
in the Movie Properties dialog box (accessed by choosing Modify > Movie). 

Color Depth Designates the type of PICT file, object-based or bitmap. Object-
based images generally look better when printed, and scaling doesn’t affect their 
appearance. Bitmap PICT images normally look best displayed on-screen and can 
be manipulated in applications such as Adobe Photoshop. You can also choose a 
variety of color depths with bitmap PICT files.

Include Postscript Is available only for an object-based PICT file to include 
information that optimizes printing on a PostScript printer. This information 
makes the file larger and may not be recognized by all applications.
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QuickTime

The QuickTime export option creates movies in the QuickTime 4 format. 
QuickTime export options are identical to QuickTime publish options. See 
QuickTime publish settings. 

QuickTime Video (Macintosh)

The QuickTime Video option is available on Macintosh systems only. It exports 
using the QuickTime 3 file format, so all Flash content is bitmapped. Using this 
option, a Flash movie loses all of its interactivity. This format is useful if you want 
to change Flash content in a video editing application.

The QuickTime Video Export options dialog box contains the following options:

Size Specifies a width and height in pixels for the frames of a QuickTime movie. 
By default, you need specify only the width or the height and the other dimension 
are automatically set to maintain the aspect ratio of your original movie. If you 
deselect Maintain Aspect Ratio, you can set both the width and the height.

Format Selects a color depth.

Smooth Turns Flash’s anti-aliasing on and off in the exported QuickTime movie. 
This improves the appearance of the bitmapped frame images. However, anti-
aliased images might have a halo when placed over a colored background.

Compressor Selects a standard QuickTime compressor.

Quality Controls the amount of compression applied to your movie. The exact 
effect depends upon the compressor selected.

Sound Format Sets the export rate for sounds in the movie. Higher rates yield 
better fidelity and larger files. Lower rates save disk space. 

Windows AVI (Windows)

Windows AVI is the standard Windows movie format and is a good format to use 
if you want to open a Flash animation in a video-editing application. Since AVI is 
a bitmap-based format, movies that contain long or high-resolution animations 
can quickly become very large. 

The Windows AVI Export options dialog box contains the following options:

Dimensions Specifies a width and height in pixels for the frames of an AVI movie. 
Specify only the width or the height; the other dimension is automatically set to 
maintain the aspect ratio of your original movie. Deselect Maintain Aspect Ratio 
to set both the width and the height.

Video Format Selects a color depth. Many applications do not yet support the 
Windows 32-bit image format. If you have problems using this format, simply use 
the older 24-bit format.
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Smooth Turns Flash anti-aliasing on in the exported AVI movie. Smoothing 
produces higher quality images. However, a halo of gray pixels may appear 
around an image placed on a colored background. Export without smoothing 
if a halo appears.

Compress Video Displays a dialog box for choosing standard AVI 
compression options.

Windows Metafile

Windows Metafile format is the standard Windows graphics format and is 
supported by most Windows applications. Importing and exporting files in this 
format provides good results.

There are no definable exporting options for Windows Metafile export.

WAV audio (Windows)

The WAV option for Export Movie exports all the sounds in the current movie to 
a single WAV file. You can specify the sound format of the new file.

The Export Windows WAV files contains the following options:

Sound Format Determines the sampling frequency, bit rate, and stereo or mono 
setting of the exported sound. 

Ignore Event Sounds Excludes events sounds from the exported file. 

Creating templates for HTML publishing
During the publish process, Flash inserts the Publish Settings parameters in a 
template you select in the HTML panel. A template is a text file that includes 
special variables beginning with a dollar sign ($). (Use \$ if you need to use a $ for 
another purpose in the document.) Flash substitutes the appropriate value for 
each template variable. A template can be any text file containing the appropriate 
template variables. 

Flash does not change anything in a template except for the template variables in a 
template, so a template can include any HTML content for your application, or 
even code for special interpreters such as Cold Fusion, ASP, and the like. 

Flash saves the modified template using the file name of the Flash movie with the 
extension of the template. For example, if you select a template named 
Standard.asp for use with a Flash movie named MyMovie.swf, the resulting file 
would be named MyMovie.asp. 

A template does not have to include all of the template variables. Flash simply 
does not insert values for any missing variable and the default values remain. 
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When no template has been selected in the Publish Settings dialog box, Flash uses 
a template named Default.html. If Default.html is not present, Flash uses the first 
template on the list. 

Flash stores templates in the Flash application folder in a folder named HTML.

Flash templates have the following characteristics:

 þ A one-line title which appears on the Template pop-up menu.

 þ A longer description which appears when you click the Info button. 

 þ Template variables beginning with $ which specify where parameter values 
should be substituted when Flash generates the output file. 

The following tables lists all the template variables Flash recognizes. For a 
definition of all the tags these variables work with, see About Flash HTML 
requirements.

Parameter Template Variable

Template title $TT

Template description start $DS

Template description finish $DF

Width $WI

Height $HE

Movie $MO

HTML alignment $HA

Looping $LO

Parameters for OBJECT $PO

Parameters for EMBED $PE

Play $PL

Quality $QU

Scale $SC

Salign $SA

Wmode $WM

Devicefont $DE

Bgcolor $BG

Movie text (spot to write movie text) $MT
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Movie URL (location of movie URLs) $MU

Image width (unspecified image type) $IW

Image height (unspecified image type) $IH

Image file name (unspecified image type) $IS

Image map name $IU

Image map tag location $IM

QuickTime width $QW

QuickTime height $QH

QuickTime file name $QN

GIF width $GW

GIF height $GH

GIF file name $GS

JPEG width $JW

JPEG height $JH

JPEG file name $JN

PNG width $PW

PNG height $PH

PNG file name $PN

Generator variables OBJECT tag $GV

Generator variables EMBED tag $GE

Parameter Template Variable
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Creating an image map

Flash can generate an image map using any image so that buttons that link to 
URLs in the original Flash movie continue to function as links if an image is 
substituted. Flash inserts the image map code in a template when it encounters 
the $IM template variable. The $IU variable identifies the name of the GIF file. For 
example, the following code in a template:

$IM
<IMG SRC=$IS usemap=$IU WIDTH=$IW HEIGHT=$IH BORDER=0>

might produce this code in the HTML document created by Publish:

<MAP NAME="mymovie">
<AREA COORDS="130,116,214,182" HREF="http://www.macromedia.com">
</MAP>
<IMG SRC="mymovie.gif" usemap="#mymovie" WIDTH=550 HEIGHT=400 BORDER=0>

Place the frame label #Map in the keyframe in which you want to create the image 
map. If you don’t create a frame label, Flash creates an image map using the 
buttons in the last frame of the movie. 

Creating a text report

The $MT template variable causes Flash to insert all the text from the current Flash 
movie as a comment in the HTML code. This is useful for indexing the content of 
a movie and making it visible to search engines. 

Creating a URL report

The $MU template variable makes Flash generate a list of the URLs referred to by 
actions in the current movie and insert it at the current location as a comment. 
This enables link verification tools to see and verify the links in the movie. 

Using shorthand template variables

The $PO (for OBJECT tags) and $PE (for EMBED tags) template variables are useful 
shorthand elements. Both variables cause Flash to insert into a template any non-
default values for some of the most common Flash OBJECT and EMBED parameters, 
including PLAY ($PL), QUALITY ($QU), SCALE ($SC), SALIGN ($SA), WMODE ($WM), 
DEVICEFONT ($DE), and BGCOLOR ($BG). See the default template in the section that 
follows for an example of using these variables.
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Sample template

Here is an example of a template file that includes many of the commonly used 
template variables. 

$TTFlash Only (Default)
$DS
Use an OBJECT and EMBED
tag to display Flash.
$DF
<HTML>
<HEAD>
<TITLE>$TI</TITLE>
</HEAD>
<BODY bgcolor="$BG">

<!-- URLs used in the movie-->
$MU
<!-- text used in the movie-->
$MT

<OBJECT classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"

codebase="http://active.macromedia.com/flash2/cabs/swflash.cab#version=4,0,0
,0"
 ID=$TI WIDTH=$WI HEIGHT=$HE>
 $PO
<EMBED $PE WIDTH=$WI HEIGHT=$HE
 TYPE="application/x-shockwave-flash"
PLUGINSPAGE="http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_
Version=ShockwaveFlash">
</OBJECT>

</BODY>
</HTML>

About Flash HTML requirements
The Publish command creates an HTML document with all the parameters set as 
you specify in the Publish Setting dialog. If you are not familiar with HTML, you 
can rely on Publish to specify changes to HTML settings. If you are experienced 
with HTML, you can change or enter HTML parameters manually in an HTML 
editor, create your own HTML files to control a Flash movie, or create your own 
HTML templates for use with Publish.
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Using OBJECT and EMBED

To display a Flash Player movie in a web browser an HTML document must use 
the EMBED and OBJECT tags with the proper parameters. For the EMBED tag, all 
settings (such as HEIGHT, WIDTH, QUALITY, and LOOP) are attributes that appear 
between the angle brackets of the opening EMBED tag. For example:

<EMBED SRC="moviename.swf" WIDTH="100" HEIGHT="100" PLAY="true” 
LOOP="true" QUALITY="high"
PLUGINSPAGE=”http://www.macromedia.com/shockwave/download/
index.cgi?P1_Prod_Version=ShockwaveFlash”> 
</EMBED>

For OBJECT, four settings (HEIGHT, WIDTH, CLASSID, and CODEBASE) are attributes 
that appear within the OBJECT tag; all others are parameters that appear in separate, 
named PARAM tags. For example:

<OBJECT CLASSID="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" WIDTH="100"
HEIGHT="100" CODEBASE="http://active.macromedia.com/flash4/cabs/
swflash.cab#version=4,0,0,0">
<PARAM NAME="MOVIE" VALUE="moviename.swf">
<PARAM NAME="PLAY" VALUE="true">
<PARAM NAME="LOOP" VALUE="true">
<PARAM NAME="QUALITY" VALUE="high">
</OBJECT>

To use both tags together, position the EMBED tag just before the closing OBJECT 
tag, like this:

<OBJECT CLASSID="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" WIDTH="100"
HEIGHT="100" CODEBASE="http://active.macromedia.com/flash4/cabs/
swflash.cab#version=4,0,0,0">
<PARAM NAME="MOVIE" VALUE="moviename.swf">
<PARAM NAME="PLAY" VALUE="true">
<PARAM NAME="LOOP" VALUE="true">
<PARAM NAME="QUALITY" VALUE="high">

<EMBED SRC="moviename.swf" WIDTH="100" HEIGHT="100" PLAY="true” 
LOOP="true" QUALITY="high" 
PLUGINSPAGE=”http://www.macromedia.com/shockwave/download/
index.cgi?P1_Prod_Version=ShockwaveFlash”> 
</EMBED>

</OBJECT>

Note: If you are using both the OBJECT and the EMBED tags, use identical values for 
each attribute or parameter to ensure that playback is consistent across browsers. Also, 
swflash.cab#version=4,0,0,0 is optional. Leave it off if you don’t want to check for 
version number.
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The following list of tag attributes and parameters will help you understand the 
HTML that Publish creates and help you to write your own HTML to insert 
Flash movies. All items apply to both OBJECT and EMBED tags unless otherwise 
noted in the description. Optional entries are noted. When creating a template, 
you can substitute a template variable listed here for the value. See Creating 
templates for HTML publishing.

SRC

Value movieName.swf

Template variable: $MO

Description Specifies the name of the movie to be loaded. EMBED only.

MOVIE

Value movieName.swf

Template variable: $MO

Description Specifies the name of the movie to be loaded. OBJECT only.

CLASSID

Value clsid:D27CDB6E-AE6D-11cf-96B8-444553540000

Description Identifies the ActiveX control for the browser. The value must be entered exactly 
as shown. OBJECT only.

WIDTH

Value n or n%

Template variable: $WI

Description Specifies the width of the movie in either pixels or percentage of browser window.

HEIGHT

Value n or n%

Template variable: $HE

Description Specifies the height of the movie in either pixels or percentage of browser window. 

Because Flash movies are scaleable, their quality will not degrade at different sizes 
as long as the aspect ratio is maintained (for example, all of these sizes have a 4:3 
aspect ratio: 640 pixels by 480 pixels, 320 pixels by 240 pixels, and 240 pixels 
by 180 pixels).
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CODEBASE

Value http://active.macromedia.com/flash4/cabs/swflash.cab#version=4,0,0,0"

Description Identifies the location of the Flash Player ActiveX control so that the browser can 
automatically download it if it is not already installed. The value must be entered 
exactly as shown. OBJECT only.

PLUGINSPAGE

Value http://www.macromedia.com/shockwave/download/
index.cgi?P1_Prod_Version=ShockwaveFlash

Description Identifies the location of the Flash Player plugin so that the user can download it if 
it is not already installed. The value must be entered exactly as shown. EMBED only.

SWLIVECONNECT

Value true | false

Description (Optional) Specifies whether the browser should start Java when loading the Flash 
Player for the first time. The default value is false if this attribute is omitted. 
Whenever you use JavaScript and Flash on the same page, Java must be running 
for FS Commands to work; however, if you are using JavaScript only for browser 
detection or some other purpose unrelated to FS Commands, you can prevent 
Java from starting by setting SWLIVECONNECT to false. You can also force Java to 
start when you are not using JavaScript with Flash by explicitly setting 
SWLIVECONNECT to true. Starting Java substantially increases the time it takes to 
start a movie; set this tag to true only when necessary. EMBED only.

Use the Exec FS Command to start Java from a stand-alone projector. See Sending 
messages to the movie’s host program.

PLAY

Value true | false

Template variable: $PL

Description (Optional) Specifies whether the movie begins playing immediately upon loading 
in the browser. If your Flash movie is interactive, you may want to let the user 
initiate play by clicking a button or performing some other task. In this case, set 
the PLAY attribute to false to prevent the movie from starting automatically. The 
default value is true if this attribute is omitted.

LOOP

Value true | false

Template variable: $LO

Description (Optional) Specifies whether the movie repeats indefinitely or stops when it 
reaches the last frame. The default value is true if this attribute is omitted.
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QUALITY

Value low | high | autolow | autohigh | best

Template variable: $QU

Description (Optional) Specifies the level of anti-aliasing to be used during playback of your 
movie. Because anti-aliasing requires a faster processor to smooth each frame of 
the movie before it is rendered on the viewer’s screen, choose a value based on 
whether speed or appearance is your top priority:

þ Low gives priority to playback speed over appearance. With this setting, anti-
aliasing is never used.

þ Autolow emphasizes speed at first, but improves appearance whenever 
possible. Playback begins with anti-aliasing turned off. If the Flash player 
detects that the processor can handle it, anti-aliasing is turned on.

þ Autohigh emphasizes playback speed and appearance equally at first, but 
sacrifices appearance for the sake of playback speed if necessary. Playback 
begins with anti-aliasing turned on. If the actual frame rate drops below the 
specified frame rate, anti-aliasing is turned off to improve playback speed. Use 
this setting to emulate the View > Antialias setting in Flash. 

þ High gives priority to appearance over playback speed. With this setting, anti-
aliasing is always used. If the movie does not contain animation, bitmaps are 
smoothed; if there is animation, bitmaps are not smoothed. High is the 
default setting for Quality.

þ Best provides the best display quality and does not consider playback speed. 
All output is antialiased and all bitmaps are always smoothed.

The default value is high if this attribute is omitted.

BGCOLOR

Value #RRGGBB (hexadecimal RGB value)

Template variable: $BG

Description (Optional) Specifies the background color of the movie. Use this attribute to 
override the background color setting specified in the Flash file. This attribute has 
no effect on the background color of your HTML page.
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SCALE

Value showall | noborder | exactfit

Template variable: $SC

Description (Optional) Defines how the movie is placed within the browser window when 
WIDTH and HEIGHT values are percentages.

þ Default (Show all) makes the entire movie visible in the specified area while 
maintaining the original aspect ratio of the movie. No distortion occurs. 
Borders may appear on two sides of the movie.

þ No Border scales the movie to fill the specified area while maintaining the 
original aspect ratio of the movie. No distortion occurs. Portions of the movie 
might be cropped.

þ Exact Fit makes the entire movie visible in the specified area. However, no 
attempt is made to preserve the original aspect ratio, and distortion may occur.

The default value is showall if this attribute is omitted (and WIDTH and HEIGHT 
values are percentages).

ALIGN

Value L | R | T | B 

Template variable: $HA

Specifies the ALIGN attribute for the OBJECT, EMBED, and IMG tags and determines 
how the Flash movie window is positioned within the browser window. 

þ Default centers the movie in the browser window and crops edges if the 
browser window is smaller than the movie.

þ Left aligns the movie along the left edge of the browser window and crops the 
top, bottom, and right sides as necessary. 

þ Right aligns the movie along the right edge of the browser window and crops 
the top, bottom, and left sides as necessary. 

þ Top aligns the movie along the top edge of the browser window and crops the 
bottom, left, and right sides as necessary. 

þ Bottom aligns the movie along the bottom edge of the browser window and 
crops the top, left, and right sides as necessary.
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SALIGN

Value L | R | T | B | TL | TR | BL | BR 

Template variable: $SA

Description (Optional) Specifies where a scaled Flash movie is positioned within the area 
defined by the WIDTH and HEIGHT settings. See “SCALE” on page 256 for more 
information about these conditions.

þ L aligns the movie along the left edge of the browser window and crops the 
top, bottom, and right sides as necessary.

þ R aligns the movie along the right edge of the browser window and crops the 
top, bottom, and left sides as necessary.

þ T aligns the movie along the top edge of the browser window and crops the 
bottom, left, and right sides as necessary.

þ B aligns the movie along the bottom edge of the browser window and crops 
the top, left, and right sides as necessary.

þ TL aligns the movie to the top left corner of the browser window and crops the 
bottom and right sides as necessary.

þ TR aligns the movie at the top right corner of the browser window and crops 
the bottom and left sides as necessary

þ BL aligns the movie at the bottom left corner of the browser window and crops 
the top and right sides as necessary.

þ BR aligns the movie at the bottom right corner of the browser window and 
crops the top and left sides as necessary.

If this attribute is omitted, the movie is centered in the browser window. 
Cropping may occur or borders may appear on any side, as necessary.

BASE

Value base directory or URL

Description (Optional) Specifies the base directory or URL used to resolve all relative path 
statements in the Flash Player movie. This attribute is helpful when your Flash 
Player movies are kept in a different directory from your other files.
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MENU

Value true | false

Template variable: $ME

Description (Optional) Specifies what type of menu the viewer receives when right-clicking 
(Windows) or command-clicking (Macintosh) the movie area in the browser. 

þ True displays the full menu, allowing the user a variety of options to enhance 
or control playback.

þ False to displays a menu that contains only the About Flash option.

The default value is true if this attribute is omitted.

WMODE

Value Window | Opaque | Transparent

Template variable: $WM

Description (Optional) Lets you take advantage of the transparent movie, absolute 
positioning, and layering capabilities available in Internet Explorer 4.0. This tag 
works only in Windows with the Flash Active X control.

þ Window plays the movie in its own rectangular window on a web page.

þ Opaque makes the movie hide everything behind it on the page.

þ Transparent makes the background of the HTML page show through all the 
transparent portions of the movie. Animation performance might be slower 
when you use this setting.

The default value is Window if this attribute is omitted. Object only.
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Configuring a web server for Flash
When your files are accessed from a web server, the server must properly identify 
them as Flash Player files in order to display them. If the MIME type is missing or 
not properly delivered by the server, the browser might display error messages or a 
blank window with a puzzle piece icon.

To ensure that visitors can see your movies, you (or your server’s administrator) 
must add the Flash Player MIME types to the server’s configuration files and 
associate these MIME types with the Flash Player file extensions. The relevant 
MIME types and suffixes are:

If you are administering your own server, consult your server software 
documentation for instructions on adding or configuring MIME types. If you are 
not administering your own server, contact your Internet service provider, 
webmaster, or IT department and ask them to add the MIME type information.

If your site is on a Macintosh server, you must also set the following parameters: 
Action: Binary; Type: SWFL; and Creator: SWF2.

MIME type Suffix

application/x-shockwave-flash .swf

application/futuresplash .spl
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Keyboard Shortcuts

File menu

Command Windows Macintosh

New Control+N Command+N

Open Control+O Command+O

Open as Library Control+Shift+O Command+Shift+O

Close Control+W Command+W

Save Control+S Command+S

Save As Control+Shift+S Command+Shift+S

Import Control+R Command+R

Export Movie Control+Alt+Shift+S Command+Shift+Option+S

Print Control+P Command+P

Quit Control+Q Command+Q
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Edit menu

Command Windows Macintosh

Undo Control+Z Command+Z

Redo Control+Y Command+Y

Cut Control+X Command+X

Copy Control+C Command+C

Paste Control+V Command+V

Paste In Place Control+Shift+V Command+Shift+V

Clear Delete Delete

Duplicate Control+D Command+D

Select All Control+A Command+A

Deselect All Control+Shift+A Command+Shift+A

Copy Frames Control+Alt+C Command+Option+C

Paste Frames Control+Alt+V Command+Option+V

Edit Symbols Control+E Command+E
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View menu

Go To submenu 

Command Windows Macintosh

100% Control+1 Command+1

Show Frame Control+2 Command+2

Show All Control+3 Command+3

Outlines Control+Alt+Shift+O Shift Option+Command+0

Fast Control+Alt+Shift+F Shift Option+Command+F

Antialias Control+Alt+Shift+A Shift Option+Command+A

Antialias Text Control+Alt+Shift+T Shift Option+Command+T

Timeline Control+Alt+T Command+Option+T

Work Area Control+Shift+W Command+Shift+W

Rulers Control+Alt+Shift+R Command+Option+Shift+R

Grid Control+Alt+Shift+G Command+Option+Shift+G

Snap Control+Alt+G Control+command+G

Show Shape Hints Control+Alt+H Command+Option+H

Command Windows Macintosh

First Home Home

Previous Page Up Page Up

Next Page Down Page Down

Last End End
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Insert menu

Modify menu

Command Windows Macintosh

Create Symbol F8 F8

Frame F5 F5

Delete Frame Shift+F5 Shift+F5

Key Frame F6 F6

Blank Key Frame F7 F7

Clear Key Frame Shift+F6 Shift+F6

Command Windows Macintosh

Instance Control+I Command+I

Frame Control+F Command+F

Movie Control+M Command+M

Font Control+T Command+T

Paragraph Control+Shift+T Command+Shift T

Align Control+K Command+K

Group Control+G Command+G

Ungroup Control+Shift+G Command+Shift G

Break Apart Control+B Command+B
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Style submenu  

Kerning submenu 

Transform submenu

Command Windows Macintosh

Plain Control+Shift+P Command+Shift+P

Bold Control+Shift+B Command+Shift+B

Italic Control+Shift+I Command+Shift+I

Align Left Control+Shift+L Command+Shift+L

Align Center Control+Shift+C Command+Shift+C

Align Right Control+Shift+R Command+Shift+R

Justify Control+Shift+J Command+Shift+J

Command Windows Macintosh

Narrower Control+Alt+Left Command+Option+Left

Wider Control+Alt+Right Command+Option+Right

Reset Control+Alt+Up Command+Option+Up

Command Windows Macintosh

Scale and Rotate Control+Alt+S Command+Option+S

Remove Transform Control+Shift+Z Command+Shift+Z

Add Shape Hint Control+H Command+H
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Arrange submenu 

Curves submenu 

Control menu

Command Windows Macintosh

Bring to Front Control+Shift+Up Command+Shift+Up

Move Ahead Control+Up Command+Up

Move Behind Control+Down Command+Down

Send to Back Control+Shift+Down Command+Shift+Down

Lock Control+Alt+L Command+Option+L

Unlock All Control+Alt+Shift L Command+Option+Shift+L

Command Windows Macintosh

Optimize Control+Alt+Shift+C Command+Option+Shift+C

Command Windows Macintosh

Play Enter Enter

Rewind Control+Alt+R Command+Option+R

Step Forward > >

Step Backward < <

Test Movie Control+Enter Command+Enter

Test Scene Control+Alt+Enter Command+Option+Enter

Enable Frame Actions Control+Alt+A Command+Option+A

Enable Buttons Control+Alt+B Command+Option+B

Mute Sounds Control+Alt+M Command+Option+M
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Window menu

Controlling layers and keyframes

Drawing shortcuts

Command Windows Macintosh

New Window Control+Alt+N Command+Option+N

Inspector Control+Alt+I Command+Option+I

Library Control+L Command+L

To Windows Macintosh

Move a keyframe Control-drag Command-drag

Extend frames from 
a keyframe

Control-drag the right 
border of the keyframe

Command-drag the right 
border of the keyframe

Link or a unlink a layer 
to a mask or motion 
guides layer

Alt-click a layer icon Control-click a layer icon

To Windows Macintosh

Set fill and line attributes 
for all tools with the 
dropper tool

Shift-click with the 
dropper tool

Shift-click with the 
dropper tool

Create a new 
corner handle

Control-drag a line Control-drag a line

Move a selected element 
by one pixel

Arrow keys Arrow keys

Move a selected element 
by 8 pixels

Shift+Arrow keys Shift+Arrow keys

Change between zoom in 
and zoom out while the 
magnifier tool is active

Alt Option

Drag a copy of the 
selected element

Control-drag Option-drag

Drag the stage with 
hand tool

Press Spacebar and drag Press Spacebar and drag
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Spring-loaded tools

Hold down the corresponding key listed below to temporarily activate certain 
tools. When you release the key, the tool you were using before reactivates.

Switching tools

Press the keys listed below to switch to a different tool. 

To temporarily activate 
this tool

Windows Macintosh

Arrow Control Command

Lasso Tab Tab

Hand Spacebar Spacebar

Magnifier zoom in Control+Spacebar Command+Spacebar

Magnifier zoom out Control+Shift+Spacebar Command+Shift+Spacebar

To switch to this tool Press

Arrow a

Text t

Rectangle r

Oval o

Pencil p

Ink bottle i

Brush b

Paint bucket u

Eraser e

Dropper d

Magnifier m

Lasso l
Appendix A268



INDEX

A
actions

assigning to buttons 173
button parameters 175
Call, using 193
Comment, using 190
Drag Movie Clip, using 188
Duplicate Movie Clip, using 187
editing 177
frame actions 176
FS Command, using 183
Get URL, using 179
Go To, using 178
If Frame is Loaded, using 179
If, using 192
Load Movie, using 181
Load Variables, using 183
Loop, using 192
Movie Clip, using 188
On Mouse Event, using 173
Play, using 177
Remove Movie Clip, using 187
Set Property, using 189
Set Variable, using 191
Stop All Sounds, using 178
Stop Drag, using 189
Stop, using 177
Tell Target, using 185
Toggle High Quality, using 177
Trace, using 203
Unload Movie, using 181

ActiveX controls 223
Adobe Illustrator

exporting 243
importing 127

Adobe Type Manager 115
ADPCM sound compression 220
AIFF sounds, importing 213
ALIGN parameter 256

setting in Publish 232
aligning, objects 111
AllowScale FSCommand 185
alpha settings

bitmaps 125
gradients 93
solid colors 91
symbol instances 150

animation 168
adding text to 116
changing length of 168
color changes 159
frame-by-frame 166
motion paths for 161
moving 171
placing frames in 168
reversing 168
still images 157
tweened 158
tweening motion 159
tweening shape 163
using layers in 157

Antialias command 73
Antialias Text command 73
arrays, emulating in actions 194
arrow tool 102
Audio Event Rate and Compression option 229
Audio Stream Rate and Compression option 229
authoring environment 51
AutoCAD DXF

exporting 128
importing 127

AVI
exporting 246
sound in 221

B
Bandwidth Profiler 226
BGCOLOR parameter 255
Bitmap Properties dialog box 131
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bitmaps
alpha settings 125
breaking apart 129
copying frames and 105
importing 125
painting with 129
using as fill 129
working with 125

Bitmaps on Clipboard preference (Windows only) 74
Blank Keyframe command 168
BMP

exporting 244
importing 127

breaking apart
bitmaps 129
Break Apart command 113
groups 113
symbols 153
text 113

Bring to Front command 106
brush tool 80
button symbol 142
buttons

action parameters 175
adding sounds to 218
assigning actions to 173
creating 145
enable and disable 148

C
Call action, using 193
center point of objects 112
changing instance properties, buttons 173
CLASSID parameter 253
Click Accuracy 95
Clipboard, copying to 105
CODEBASE parameter 254
color palettes

changing 91
importing and exporting 90

colors
alpha settings for 93
animating color changes 159
changing 91
creating new gradient color 93
creating new solid color 91
deleting 93

colors (continued )
editing 91
effects for symbol instances 150
matching 93
text 122
transparency 93

Comment action, using 190
Connect Lines 95
connecting lines and shapes 104
Controller command 57
coordinates as properties 200
copying

frames 168
shapes 106

curves
creating special effects 99
optimizing 97
straightening 96

cutting 104

D
deleting

colors 93
frames 168
gradient colors 93
lines 82
scenes 64
shapes 106

depth, for duplicate movie clips 188
Deselect All command 102
DEVICE FONT parameter 231
device fonts 115
dialog boxes in forms 207
dimensions, setting in Publish 230
Disable Timeline Docking preference 75
display, speeding 73
Dither Solid Colors

GIF 234
PNG 237

down state, for buttons 146
download performance 226
Drag Movie Clip action, using 188
drawing preferences

Assistant command 94
setting 94

Duplicate Movie Clip action, using 187
duplicating symbols 144
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E
easing tweened frames 159
Edit Center command 112
Edit Multiple Frames button 170
editable text 117
editing

reshaping lines and shape outlines 95
soften edges of an object 99
symbols 148
text 119

editor for expressions 196
Else statement 192
EMBED parameters. See individual parameters
empty symbols, creating 143
Enable Buttons command 147
Enhanced Metafile

exporting 245
importing 127

EPS
exporting 245
importing 127

eq operator 199
eraser tool 82

mode modifier 82
shape modifier 82

event sound 215
Exec FSCommand 185
Expand Shape command 99
export file formats

about 243
Adobe Illustrator 243
AVI 246
BMP 244
Enhanced Metafile 245
EPS 245
GIF 233
JPEG 236
PICT 245
PNG 236
QuickTime 246
SWF 228
Windows Metaflile 247

exporting
color palettes 90
Flash Player movies 228
images 242
sound in movies 221

exporting (continued )
sound in video 221
SWF 228
WAV files 247
with Publish 228

expression editor, use 196
eye dropper tool 89
eye icon 135

F
fade in or out 159
Fast command 73
fill

adjusting gradient or bitmap 86
applying value of none 84
locking 88
using bitmaps as 129
using locked gradient or bitmap 88

Flash Player movies
about 51
configuring web server for 259
creating 223
exporting 228

flipping shapes 109
focusrect as property 202
fonts 115
forms

advanced interactivity 205
verifying data 208

FPS (frames per second) 157
frame actions

assigning to keyframes 176
creating 176

frame comments 63
frame labels 63
frame rate, setting 157
Frame View pop-up menu 62
frame-by-frame animation 166
Frame-by-Frame graph 227
frames

about 59
adding sounds 214
converting keyframes into 168
copying 168
deleting 168
displaying 62
easing tweened frames 159
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frames (continued )
editing 157
exporting as static images 242
placing in animation sequence 168
registering images in 169

FreeHand
exporting 245
importing 127

FS Command action
using 183

Full Screen command 241
FullScreen FSCommand 185
functions

Get Timer 199
Int 198
Length 198
Random 198
substring 198

FutureSplash Player, importing 127

G
Generate Size Report option 229
geometric shapes, drawing 78
Get Property in actions 194
Get Timer function 199
Get URL action

for sending email 206
in forms 206
using 179

GIF
dither settings 235
importing 127
publish and export settings 233

Go To action, using 178
gradient colors

alpha settings 93
copying frames and 105
creating and editing 93
deleting 93
linear 93
radial 93
transparency 93

Gradients on Clipboard preference 74
Gradients preference (Macintosh only) 74
graphic symbol 142

play mode for instances of 153

grids 71
Grid command 71
grid layers 136

groups
breaking apart 113
creating 112
editing 112
stacking order of 106
ungrouping 113

guide layers 136

H
HEIGHT parameter 253

setting in Publish 230
hidden layers 135
hiding, rulers 71
highquality, as property 202
Hit state, buttons 146
HTML

publish settings 230
tag reference 251
templates 247

I
If action, using 192
If Else statement 192
If Frame is Loaded action, using 179
Illustrator

exporting 245
importing 127

image map, creating 250
images, exporting 242
importing

Adobe Illustrator 127
AIFF 213
AutoCAD DXF 127
BMP 127
color palettes 90
Enhance Metafile 127
Freehand 127
FutureSplash Player 127
GIF 127
JPEG 127
libraries 154
PICT 127
PNG 127
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importing (continued )
QuickTime 127
sounds 213
SWF 127
symbols 154
WAV 213
Windows Metafile 127

in point, setting for sounds 221
ink bottle tool 88
Insert Frame command 168
Inspector window, using 69
Instance Properties dialog box 150
instances

changing properties 150
color effects 150
creating 144

Int function 198
interactivity, about 173
interlace

GIF 234
PNG 237

J
Java, starting in Netscape 254
joining lines and shapes 104
JPEG

importing 127
publishing and exporting 236

K
kerning, manual 121
keyframes

assigning frame actions 176
associating with sounds 217
converting into frames 168
creating 155
extending images 157
frame-by-frame animation 166
motion 159
shape 163
tweening 158

L
labels, frame 63
Large frame view 62
lasso tool 103

layers
changing the order of 136
copying 134
creating 133
deleting 134
displaying as outlines 157
grid layers 136
guide layers 136
hidden layers 135
locked layer 134
locking 157
manipulating to edit frame contents 157
mask 137
renaming 136
selecting 134
selecting everything on 102
selecting multiple 134
showing 135
sound 214
using in animation 157

Length function 198
length of animation 168
libraries

bitmaps 125
from other movies 154
included in Flash 68
sounds 213

Library window 65
linear gradients 93
lines

drawing 78
Lines to Fills command 99
removing with Eraser tool 82
straightening 96
styles 84
widths 84

links. See  instances
Load Default Colors 89
Load Movie action, using 181
Load Order option 229
Load Variables action

in forms 206
using 183

Lock command 102
lock fill modifier 88
locking layers 134
Loop action, using 192
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LOOP parameter 254
setting in Publish 231

Loop Playback command 57
looping sounds 221

M
magnet modifier 98
magnification level, changing 70
magnifier tool 70
mailto, using Get URL action 206
manual kerning 121
markers, frame 63
mask layers 137

link and unlink layers 139
matching colors 93
maxscroll value 201
Medium frame view 62
MENU parameter, setting in Publish 231
MIME type for Flash Player 259
Modify Onion Markers context menu 170
morphing 163
motion paths 161
motion tweening 159
movie

controlling playback 57
creating 53
properties 56

Movie Clip action, using 188
movie clip symbol 142

creating 143
MOVIE parameter 253
moving shapes 104
MP3 sound compression 220
Mute Sounds command 57

N
New command 53
Normal frame view 62

O
OBJECT and EMBED parameters. 

See individual parameters
objects

aligning 111
copying 106
cutting 106
deleting 106
erasing 82
flipping 109
moving 104
pasting 104
restoring transformed 110
rotating 108
scaling 107
selecting 101
skewing 110

OLE objects 113
On Mouse Event action, using 173
100% command 71
onion skinning 169
Open as Library command 154
optimize colors

GIF 234
PNG 237

optimizing curves 97
optimizing movies 225
out point, setting for sounds 221
outline icon 136
Outlines command 73
ovals and rectangles, drawing 80
over state, buttons 146
Override Sound Settings option 229

P
padlock icon 135
Paeth, PNG filter option 239
paint bucket tool 85
paragraph settings 121
passwords 208
Paste in Place command 104
Paste Special command 104

Windows version 105
pasting shapes 104
path, tweening along 161
pencil tool 78
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PICT
exporting 245
importing 127

PICT Settings for Clipboard preference
(Macintosh only) 74

Play action, using 177
Play All Scenes command 57
PLAY parameter 254

setting in Publish 231
playback rate 157
player 241
playing, QuickTime 128
PLUGINSPAGE parameter 254
PNG

exporting 236
importing 127
publish settings 236

pop-up menu, creating 209
Postscript font preferences 115
preferences 74

Bitmaps on Clipboard (Windows only) 74
Disable Timeline Docking 75
Gradients (Macintosh only) 74
Gradients on Clipboard 74
PICT, settings for Clipboard (Macintosh only) 74
Printing Options (Windows only) 74
Shift Select 75
Show Tooltips 75
Size Limit (Windows only) 74
Undo Levels 74

preferences, drawing 94
preview

Preview frame view 62
Preview in Context frame view 62
Print Preview command 72
Publish Preview command 240

printing 72
Printing Options preference (Windows only) 74
projectors

creating 240
playing with stand-alone player 241

properties
coordinates 200
focusrect 202
highquality 202
in actions 190
rotation, setting 200

properties (continued )
soundbuftime 202
text field scrolling 201
using Get Property 194
visible, setting 201
xscale 200
yscale 200

Publish command 228
Publish Preview command 240
Publish Settings 228

Flash 229
GIF 233
HTML 230
JPEG 236
PNG 236
projectors 240
QuickTime 239

Q
QUALITY parameter 255

setting in Publish 231
QuickTime

exporting 246
importing 127
manipulating 128
playing 128
publish settings 239
setting path 128
sound in 221

R
radial gradients 93
Random function 198
Recognize Lines 95
Recognize Shapes 95
registering images from frame to frame 169
registration point, moving 112
Remove Gradients 234
Remove Movie Clip action, using 187
renaming layers 136
rendering settings 73
reshaping

lines and shapes 95
type 123

restoring transformed objects 110
reversing animation 168
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rotating
Rotate command 108
rotate modifier 102
rotation property 200
shapes 108

rulers 71

S
SALIGN parameter, setting in Publish 233
scale modifier 102
SCALE parameter

Default 232
Exact Fit 232
No Border 232
setting in Publish 232

scaling shapes 107
scenes

changing name of 64
changing order of 64
creating 64
deleting 64
pasting into 104
selecting everything on every layer of 102
using 63
viewing 64

Score. See Timeline
scroll value 201
secure information, sending variables 208
segmenting 104
Select Unused Media command 65
selecting

deselecting 102
shapes 101
with a selection marquee 102
with the arrow tool 102
with the lasso tool 103

Send to Back command 106
Set Property action, using 189
Set Variable action, using 191
shape hints 165
shape tweening 163

shape hints 165
tips 165

shapes 82
copying 106
cutting 106
deleting 106
drawing 78
erasing 82
filling and stroking 83
flipping 109
grouping 112
moving 104
pasting 104
rotating 108
scaling 107
selecting 101
size 107
skewing 110
snapping 98

Shift Select preference 75
Shockwave Flash. See Flash Player
Short frame view 62
Show All command 71
Show Frame command 71
Show Streaming command 227
Show Tooltips preference 75
ShowMenu FSCommand 185
Size Limit preference (Windows only) 74
size report 229
skewing shapes 110
slanting shapes 110
Small frame view 62
Smooth

GIF publish setting 234
PNG publish setting 237

smooth modifier 102
smoothing curves, lines 96
snap modifier 102
snapping 98
Soften Edges command 99
solid colors, creating 91
soundbuftime as property 202
sounds

about 213
adding to buttons 218
adding to frames 214
ADPCM sound compression 220
associating with keyframes 217
event 215
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sounds (continued )
exporting movies with sound 219
exporting to video 221
importing 213
looping 221
MP3 sound compression 220
Override Sound Settings option 229
reusing 221
stream 215

SRC parameter 253
stacking order of groups 106
Stage 53

about 53
defining the size of 53
viewing 70

stand-alone player 241
static images, exporting frames as 242
still images 157

exporting 242
Stop action, using 177
Stop All Sounds action, using 178
Stop Drag action, using 189
straighten modifier 102
straightening curves, lines 96
stream sound 215
stream synchronization 221
Streaming Graph 227
Substring, function 198
SWF

exporting 228
importing 127

SWLIVECONNECT parameter 254
symbols

breaking apart 153
color effects for instances 150
creating 142
creating instances 144
dissolving 113
duplicating 144
edit in place 148
editing 148
from other movies 154
instances properties 150
tweening colors 159
using symbols from other movies 154

synchronizing graphic instances 160

T
Targets, specifying in expressions 186
Tell Target action, using 185
templates

creating 247
sample 251
selecting 230
shorthand variables 250
variables 248

Test movie command 58
Test Scene command 58
testing

download performance 226
movies 58

testing frame actions 176
text

adding 116
aligning
breaking apart 113
colors 122
editing 119
justification
kerning 121
paragraph settings 121
reshaping 113
typesetting 116

text field
creating 117
saving font outlines 119
scrolling properties 201
setting properties of 118

text report, in HTML file 250
text tool 116
Timeline

about 59
disable docking preference 75
displaying frames 62
frames 59

Timelines, understanding multiple 185
timers 199
Tiny frame view 62
Toggle High Quality action, using 177
Toolbox, using 58
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tools
arrow 102
brush 80
eraser 82
eyedropper 89
ink bottle 88
lasso 103
magnifier 70
paint bucket 85
pencil 78
text 116

Trace action, using 203
Track as Menu Item, for pop-up menus 209
Transform Fill modifier 86
Transform Inspector

rotating with 108
skewing with 110

transitions 159
transparency. See  alpha settings
TrueType fonts 115
tweening 158

along a path 161
easing 159
motion paths for 162
shape 163
symbol colors 159

type. See text
typesetting text 116

U
Undo Levels preference 74
Ungroup command 113
Unload Movie action, using 181
Up state, buttons 146
URL report, in HTML file 250

V
values in actions 194
variables

identifying in movie clips 191
in actions 191
in forms 206
sending secure data 208
template 248
verifying 208

verifying entered data 208
View menu commands 71
visible, as property 201

W
WAV sounds, importing 213
WAV, exporting 247
web servers, configuring for Flash Player 259
WIDTH parameter 253

setting in Publish 230
Windows Metafile

exporting 247
importing 127

WMMODE parameter, setting in Publish 232
WMODE parameter 258
work area 53
Work Area command 71

X
x property 200
xscale, as property 200

Y
y property 200
yscale as property 200

Z
zooming 70
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